1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Placement of pop-ups on a forum page

Discussion in 'Support' started by vefatica, Jun 6, 2012.

  1. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    When I'm on a forum's page, seeing a list of threads, and I hover the mouse on the title of a thread, I get a balloon showing the first few lines of the first post in the thread. The default behavior (here) is for that balloon to appear about 5 inches below the thread's subject (so I typically see nothing for a thread below the third one. That ALWAYS happens in FireFox. It usually happens in IE but occasionally (for no apparent reason) IE shows them where they should be (right above the thread subject), and occasionally, IE doesn't show them at all (or is showing them so far from where they belong that I can't see them). Can anything be done about that?
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    Not reproducible here with Chrome or IE9, so I suspect it's a browser rendering bug. (I gave up on Firefox last year.)

    There's nothing I can do about it - I don't have the browser source code (or the XenForo source to try to hack around the problem with FireFox.) Did you report it to the FireFox developers?
     
  3. Joe Caverly

    Joined:
    Aug 28, 2009
    Messages:
    659
    Likes Received:
    8
    Try starting FireFox without any Add-Ons. (Help -> Restart with Add-Ons disabled). If all works well without any Add-Ons, then an Add-On may be causing the problem.

    Joe
     
  4. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    Tried that, total safe mode in fact, no difference. Remember, IE does it too (almost all the time).
     
  5. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    And I just installed Chrome. It does it too.
     
  6. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    And FireFox12 and IE8 both do it on lucky, my XP machine at work.
     
  7. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    I never see any popup when hovering on a thread title...?
     
  8. K_Meinhard

    Joined:
    May 20, 2008
    Messages:
    311
    Likes Received:
    0
    Strange. That's the same thing I complained about when the forum was very new. But for me it went and stayed away. I now see the balloon in the right place (opening directly above the title) under IE9, FF12, GC and Safari. I thought then that Rex must have done something ...
     
  9. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    Like Klaus, on WinXP using Firefox (including 13.0, just installed) all balloon show ABOVE the hovering pointer, no problems now or previously.
     
  10. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    When I don't see 'em I figure they're off the screen.
     
  11. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    I just upgraded FireFox 12->13 ... still does it.
     
  12. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    Okay, I see it now.

    The issue seems to depend on a number of factors, including the browser and the font size (enlarging fonts with Control-Plus magnifies the error; reducing fonts with Control-Minus reduces the error.) But the single biggest factor in the popup-positioning error appears to be the number of threads listed on the current screen: more threads, larger misalignment! So, for example, in the "Announcements" forum, with only six messages, the popups either point to the correct thread, or to the thread immediately below it*. Contrariwise, the first page of "Support" always has twenty threads, so the popups are so far away from where they should be as to be invisible.

    I had never even noticed the popups before you mentioned them. Guess which forum I spend more time in: Support or Announcements?


    * And that's actually a lot more annoying than invisible popups. When the popup is aligned with the thread immediately below the one it should be on, it opens and closes, opens and closes, opens and closes....
     
  13. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    Good observations, Charles. Now that I look, that's exactly how I see it. Perhaps Rex should invite XenForo to see for themselves.
     
  14. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    Still not reproducible here, but I'll pass it on to XenForo.
     
  15. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    I do not have problems with pop-up locations, regardless of using Firefox' "increase/decrease font size" feature. However, when I increase font size beyond a certain point, page width increases beyond window width, requiring horizontal scrolling to see the right end. I attached Firefox' settings file prefs.js (renamed to an acceptable extension).
    Here are all potentially relevant settings:
    WinXP home SP3
    Firefox 13.0 with add-ons: Addblock Plus 2.0.3; Flagbox 4.1.15; Hungarian dictionary 1.6.1.1; Java Quick Starter 1.0; United States Enlish Spellchecker 6.0
    Disabled add-ons: MS .NET Framework Assistant 0.0.0; TACO with Albine 4.45
    Firefox view settings:
    page style: basic
    character encoding: UTF-8
    Firefox options:
    Content -> default font: Times New Roman, 16
    Content ->advanced -> Fonts for Western:
    Proportional: serif 16
    Serif: Times New Roman
    Sans Serif: Arial
    Monospace: Courier New 13
    Allow pages to choose their own fonts: checked
     

    Attached Files:

  16. Stefano Piccardi

    Joined:
    May 31, 2008
    Messages:
    376
    Likes Received:
    2
    Absolutely no issues with popups using Opera 11.64 - a popup displays directly above its message title in the Support forum.
     
  17. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    Not on my machine -- though it's closer in Opera than in Firefox.
     
  18. Stefano Piccardi

    Joined:
    May 31, 2008
    Messages:
    376
    Likes Received:
    2
    This is what it looks like in my Opera, with thread display options included. I wonder if it's a specific forum skin or some forum option that trigger this issue.
    2012-06-08_172559.png
     
  19. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,287
    Likes Received:
    39
    Buy that man a beer! -- Or send him some kind of JP Software swag.

    The issue only appears in "Default Style", not in "BP White".
     

Share This Page