Global command not working

May 3, 2020
5
0
I have a situation. I have a folder where ill behaved software don't clean up after exiting and leave a lot of .tmp files in various folder levels. I need to backup the folder but without these*.tmp files. I try to clean these up by using following command as suggested in the help file ....

global /S10 del *.tmp

The immediate response is "file not found" when I know and can see the files in Total Commander.

I need to run this from a batch file which will go through the routine and at the end of the process depending on the day of the week it will either hibernate or shutdown.

Any suggestions?
 

Attachments

Apr 18, 2014
249
8
From what you say it looks like your E:\PortableApps directory has no *.tmp files in it. Del is therefore returning an error when it attempts to delete the *.tmp files in that directory and the Global command stops.

You can overcome that by using the /i option which tells Global to ignore errors:
Code:
global /i /s del *.tmp

Alternatively, you could avoid Global (which is really intended for use with external commands) and just use the /s option of Del to delete the files in the subdirectories:
Code:
del /s *.tmp
 
May 3, 2020
5
0
Tried them both and they worked. Thanks once again.

BTW There were no *.tmp files in the E:\Portable Apps folder itself but a whole lot of them in subfolders up to 5 & 6 levels deep.

I use a number of applications in portable format running off of USB drive to keep my machine and registry free of clutter and carry them on service calls to have exactly what I want available on hand.