Set Win 10 File Explorer to Run As Administrator

Oct 18, 2009
315
12
UPDATE -- IGNORE THIS THREAD. IT TURNS OUT EVEN IF YOU "Run As Administrator" BY CREATING THE SUGGESTED SHORTCUT IT DOESN'T ACTUALLY RUN AS ADMINISTRATOR.

=======================
An apparent major difference between "Windows Explorer" in Win 7 and "File Explorer" in Win 10 is that with Win 10 you can't Run As Administrator.

Turns out that's not true!

The File Explorer link won't show "Run As Administator". In fact, both link to C:\Windows\explorer.exe.

If in Win 10 you navigate to that file and create your own shortcut, your shortcut will show the name as Windows Explorer and if you right click your shortcut, there will be a Run As Administrator option.
 
Last edited:
May 26, 2008
526
4
This doesn't work for me.

Same issue that I've had trying to do this in previous Windows versions - the new explorer window runs in the same process as the main Explorer process, so it remains unelevated.

I even tried checking the "Run Explorer windows in a separate process" option but it made no difference. The new process STILL isn't elevated (confirmed by checking Task Manager, Details tab, and showing the "Elevated" column)
 
May 26, 2008
526
4
And you shouldn't do that, ever.
I wouldn't go so far as to say that. In general of course, run Explorer with the protection of UAC. But sometimes you want admin level access to files. I usually just run an elevated prompt and manage files that way when needed.
 
Oct 18, 2009
315
12
This doesn't work for me.

Same issue that I've had trying to do this in previous Windows versions - the new explorer window runs in the same process as the main Explorer process, so it remains unelevated.
I don't think you understood my post. You create the shortcut--e.g., on the desktop, close explorer, and then right-click on the shortcut. You should see a Run As Administrator option.
 
May 26, 2008
526
4
If not, I believe I understood you correctly. It just flat out doesn't work for me. I am prompted to elevate explorer when I click the shortcut, but it really isn't elevated. Did you confirm by looking at Task Manager / Details / Elevated column?