Fixed @Lua does not behave as documented

Jan 19, 2011
605
15
Norman, OK
@mikea Check to make sure you have PerlScript installed as per the documentation. I don't have it installed and got the same error.
 
Dec 7, 2009
238
2
Left Coast, USA
Ah, so this relies on PerlScript, eh? I have never installed it. I'd always thought this kind of problem with Perl pertained to some weirdness with ActiveState's Perl (which is the only version I've used).
 
Jan 19, 2011
605
15
Norman, OK
Now I get this
Code:
[C:\BIN\JPSoft\TCMD20] 11:04:16 $ echo %@lua[print 'foo']
foo
ECHO is OFF

[C:\BIN\JPSoft\TCMD20] 11:04:27 $ %@lua[print 'foo']
foo
 
May 20, 2008
11,536
103
Syracuse, NY, USA
Echoing the result of @LUA is kind of pointless, as it will always return 0 unless there's an internal Lua error, in which case you'll get an error message and the ECHO will never be executed.
That doesn't agree with what JQS observed. Why wasn't "0" echoed in his first example? And I would have expected
Code:
TCC: Unknown command "0"
from his second example.
 
Similar threads
Thread starter Title Forum Replies Date
D Lua does not work on the commandline Support 5
T Take Command 28: Lua reports version 5.4.0 (5.4.3 expected) [SOLVED] Support 1
fpefpe Documentation LUA and friends Support 4
T Returning a value from internal Lua scripts to TCC Support 2
H Lua and lpeg Support 1
fpefpe How to? LUA script Support 0
fpefpe How to? Lua Examples Support 1
H lua Causes Take Command Tab to Exit Support 5
jbarnes1967 TC 18.00 x64 issue with lua io.popen() Support 2
M How to make Lua modify env-vars Support 18
Joe Caverly Internal Lua and require Support 0
jbanaszczyk LUA, tcmd.chm, TCC/LE problem Support 0
Jay Sage Executable Extension with Lua Support 5
tmaynard Invalid item name "Lua" Support 6
vefatica Help LUA Support 1
T Lua sharing data with batch files Support 2
JohnQSmith Documentation Lua Support 0
p.f.moore Lua for Take Command, release 1.0 Support 0
T Plugins for Lua and Idle Support 4
T Fixed Function @timer[] does not work as required Support 6
D Parsing an array variable to an array does not work Support 5
J Take command does not start on Windows 10 Support 3
J ffind does not find files Support 4
Joe Caverly PAUSE does not erase countdown timer Support 0
D ParentDirectory does not update directory history Support 6
D Documentation Help "Startup" page does not describe global lists Support 0
Charles Dye Does HASH's /E option do anything? Support 1
fishman@panix.com First TCC instantiation after reboot does not work. Support 17
D Fixed @VERSION does not increment pre-fixed version numbers. Support 1
vefatica Why does @WSLPATH double the leading '/'? Support 7
D What does the file "..\Everything\Run history.csv" store? Support 5
Peter Murschall WAD rem does not work correctly Support 8
vefatica Does @SYMLINK work? Support 6
R Tree on FAT32 does not sort by name by default. Support 6
A Tcc does not recognize "bcdedit" Support 20
MickeyF Why does this batch file give me 'unknown command "else"' error? Support 17
M Ctrl-C when using command line history does nothing Support 2
vefatica JOBS /K ... how does it work? Support 5
Joe Caverly Why does TCCRT return VIEW as an internal command? Support 6
D Does TCC improve CMD's implementation of ECHO? Support 6
vefatica Find Files/Text dialog: does it work? Support 0
Alpengreis [v22.00.41] sync command flag "/X" does not work Support 22
Joe Caverly .PS1 script does not work with PSHELL Support 11
M MOVE does not behaves like intended (on failure) Support 1
R Fixed Sendmail parameter /USER= does not work Support 4
twaterloo does tcc have a task sceduler Support 4
Brian Woodward How to? Does FTP.CFG only support SSL over port 21? (Newbie) Support 6
M Activation Key does not correspond… Support 2
James Miller tcc shell window does not disappear Support 18
D Fresh instance of TCMD does not use TCMD.INI Support 7

Similar threads