Take command does not start on Windows 10

Jun 4, 2021
3
0
I installed latest version on Win10.
If I click the shortcut, the cursor changes shortly but no Take command GUI is shown.
If I run the Windows Compatibility troubleshooter and test the program the GUI does appear.
Saving those settings and then try to run from shortcut the UI still does not start.

The windows eventviewer entry:
Faulting application name: tcmd.exe, version: 27.1.23.0, time stamp: 0x6087924b
Faulting module name: ntdll.dll, version: 10.0.17763.1879, time stamp: 0x932fd580
Exception code: 0xc0000005
Fault offset: 0x000000000005e4eb
Faulting process id: 0x4e24
Faulting application start time: 0x01d75919a08c0d28
Faulting application path: C:\Program Files\JPSoft\TCMD27\tcmd.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 1cc49dc2-50be-497b-83a9-95bbb3897785
Faulting package full name:
Faulting package-relative application ID:

There is no (exception) log file at C:\ProgramData\JP Software\Take Command 27

Can you help me with this problem?

Kind regards,
John
 

rconn

Administrator
Staff member
May 14, 2008
12,312
147
Is this an initial installation, or an upgrade of an existing (& running) install?

First, go to your installation directory and try running TCC.EXE and see if that starts. (TCMD will try to start TCC when it loads.) We need to isolate which module is causing the issue.

If TCC works, then try starting TCMD without TCMD.INI (using the /N startop option). If that works, we need to isolate what's gone wrong in your .INI.

If that doesn't work, try running REGEDIT and deleting the "HKEY_CURRENT_USER\Software\JP Software\Take Command 27" key. (TCMD will recreate it automatically when it starts.)
 
Jun 4, 2021
3
0
It is an initial installation.

When I double click tcc.exe it starts

When I start tcmd from windows admin command prompt it starts with and without /N startup option
Double click tcmd from explorer does not start. Added /N to shortcut, also does not start

Content of TCMD.ini:
[Toolbar1]
Title=Untitled
[ViewMode]
Style=4

Deleted the registry key but the result was the same. From command prompt tcmd starts, double click does not start it.

Running tcmd.exe from batch file also starts it (cmd /C "C:\Program Files\JPSoft\TCMD27\tcmd.exe"). Unfortunately the initial command prompt windows does not close until Take Command is closed or I close it deliberately myself.
 
Jun 4, 2021
3
0
Is there any news on this issue? Today I installed the latest version but the problem is still not solved.
 
Similar threads
Thread starter Title Forum Replies Date
MickeyF Why does this batch file give me 'unknown command "else"' error? Support 17
M Ctrl-C when using command line history does nothing Support 2
Joe Caverly Why does TCCRT return VIEW as an internal command? Support 6
Alpengreis [v22.00.41] sync command flag "/X" does not work Support 22
E View (internal command) does nothing now Support 3
I "IF" command in a variable does not expand redirection variable name Support 0
Alpengreis WAD Command "MSGBOX /?" does not show option /N Support 2
Paul Hsieh Take Command does not launch GUI at all for me anymore. Support 3
SeoulBigChris Does TC intercept the APPEND command? Support 7
fpefpe WAD Python support does not process command line Support 14
M How to? Does the "Do" command effectively do a "SetLocal/EndLocal"??? Support 2
M "V(iew)" command does not work at all for me in V13... Support 6
deleyd How does TCC search for a command? Support 2
gschizas Keyboard switching does not work in Take Command (TCMD) Support 18
rconn News Take Command / TCC / CMDebug / TCC-RT v28 Released Support 0
T Take Command 28: Lua reports version 5.4.0 (5.4.3 expected) Support 0
Jay Sage WAD Possible Bug With OPTION Command With @FILE Support 5
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.24 uploaded Support 0
vefatica `Back quotes` - command line vs. batch file Support 5
Jay Sage WAD Failure of Alias Command with /Z Option Support 14
Phileosophos Is there any way to open the Take Command options dialog from the command line? Support 7
Phileosophos Command-line Editing Shortkeys That Fail Support 6
fpefpe How to? free (internal) command Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.23 uploaded Support 0
T How to? retain command history across reboot? Support 6
rconn News Take Command / TCC / CMDebug / TCC-RT v27.01 Build 22 Uploaded Support 0
Jay Sage Bug With Flow Control and/or Command Grouping Support 2
GermanDirk How to? EVENTLOG Command with simple User Rights not functional Support 4
Jay Sage Take Command Is Too Fast! Support 4
Jay Sage Comparison of IF with Command Group and IFF Support 6
D Open Windows 10 Photos app from command line Support 11
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.21 uploaded Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.20 uploaded Support 0
U Can not get/start Take Command gui Support 1
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.19 Support 0
S Increasing Font Point Size in Command Tabs Support 2
mfarah Fixed The DATE command produces the wrong error message. Support 1
vefatica Command name mix-up Support 3
FreezerBurnt "Missing SETLOCAL" when initializing Visual Studio Command Prompt. Support 9
E How to? Closing desktop created by DESKTOP command Support 10
rconn News Take Command / TCC / CMDebug / TCC-RT v27.0.18 Support 0
K Take Command fox XP? Support 7
Joe Caverly Documentation Replace internal command with LIBRARY command Support 0
fpefpe How to? command echo in title line/bar Support 2
U Command help on file names Support 5
vefatica Command line DO with no closing parenthesis? Support 9
vefatica Command history search is off Support 7
H How to? How can I say "if the command separator is not ~ then setdos /C~" Support 8
N Command execution slows down in TCC Prompt after a while Support 6
R Long commands retrieved from command history have blank line when wrapped Support 20

Similar threads