TC "Registering" but NOT Registering, Now Hung on TCMD Option Screen

Sep 7, 2011
14
0
#1
Purchased an upgrade license for TC 17 x64 this morning. Installing it on a new company laptop which has never had TC on it before. Then downloaded the 64-bit evaluation version and installed it. Clicked on "Run Take Command 17" in the installer after it finished; nothing happened and that window wouldn't respond to mouse clicks or key presses. Killed it with Task Manager

I ran TC 17 again (not the installer) a while later from the windows Start menu and it presented that continue/register window. Clicked "Register", entered my new registration information and it said it was successfully registered, TCMD came up with a tab for TCC.

Noticed it didn't have my TC 12 options nor my aliases, and realized I needed to 'import' those somehow. I exited TC without typing any commands except "exit".

Couldn't find anything about 'updating' my TC options, so I thought, "I wonder if it will take the tcmd.ini, tcstart.btm and aliases from my TC 12 installation," So I copied those into the TCMD executable directory and started it up again.

Got the evaluation/register window again... Eh? I registered already. I entered the registration information again and it said it was successfully registered.

My aliases were there! It sure looked like copying those files worked.

I decided to go into the Options and see how things looked. Clicked on "Options" in the TCMD GUI, then on the button for Take Command. It brought up the "Properties" window and I rummaged around through that and clicked on the "Register" tab. IT SAID I WASN'T REGISTERED!

I entered my registration information for a third time. When I clicked on "Apply" a small window popped up for less than a second that said, "Registration successful".

I clicked on "Ok" AND THE PREFERENCES WINDOW DID *NOT* CLOSE! Instead I got ANOTHER "Registration successful" message. I could click "OK" over and over and it would briefly flash the "Registration successful" window, but not exit. "Cancel" doesn't do anything, clicking the red X in the upper right corner does nothing.

Because the "Properties" window is modal, the TC screen only dings if I try to click there. If I try to run an instance of CMD.EXE, TC grabs it and adds it as a tab in its window, but I can't use any of those CMD windows because I only get a 'ding' when I try to select one.

I will probably kill TCMD with task manager; I hope my CMD windows that TC sucked up don't close when I do that because I had one up before I even installed TC and TC grabbed that up on a tab as well, and I need to look at the commands I've issued because I'm debugging something.

I haven't rebooted since I installed it (right in the middle of some 'stuff' that I don't want to exit just now). I don't recall whether it asked for a reboot as part of the installation process...

Help!!?

Lenovo T440s, Intel Core i5-4300U at 1.90 GHz, 12 Gb RAM, Windows 7 Enterprise 64-bit SP1, 167 Gb SSD
Corporate VPN being accessed from a hi speed Home Broadband Ethernet. (cabled to router, not using wireless)
 
Sep 7, 2011
14
0
#3
Thanks, Rex!

I'm not quite sure what happened, but when I ran it as Administrator it came up and said it was registered to my name, i.e. no "evaluation/register" window like before.

I registered again anyway, and now I can bring up TCMD and/or TCC and it just comes right up and shows it as registered to me.