Start TCMD.EXE with an alternate INI file

#1
Hi,

I'm trying to start TCMD.EXE with an alternate INI file. The reason for this is all my data is on an E drive and the EXEs on the C drive. The E drive gets backed up.

Note: I've removed the TCMD.INI file from %LOCALAPPDATA% and put it in the folder E:\HoylD\TakeCommand\.

In a windows shortcut I've tried the following target:

"C:\Program Files\JPSoft\TCMD9\TCMD.EXE" /@"H:\Documents\TakeCommand\TCMD.INI"

I've also tried from a CMD.EXE prompt:

"C:\Program Files\JPSoft\TCMD9\TCMD.EXE" @"H:\Documents\TakeCommand\TCMD.INI"


Since my INI points to a custom 4START.BTM file with a customised PROMPT I can tell straight way that the file has not loaded. On querying %_ININAME I always get back the %LOCALAPPDATA%\TCMD.INI even though it doesn't exists.

If I replace TCMD.EXE with TCC.EXE everything works and the correct INI file is loaded.

What am I missing?

Ref: Windows XP SP2, NTFS Partitions, TCMD version 9.02.129.

regards
Dave.
 
#2
HoylD wrote:
| Hi,
|
| I'm trying to start TCMD.EXE with an alternate INI file. The reason
| for this is all my data is on an E drive and the EXEs on the C drive.
| The E drive gets backed up.
|
| Note: I've removed the TCMD.INI file from %LOCALAPPDATA% and put it
| in the folder E:\HoylD\TakeCommand\.
|
| In a windows shortcut I've tried the following target:
|
| "C:\Program Files\JPSoft\TCMD9\TCMD.EXE"
| /@"H:\Documents\TakeCommand\TCMD.INI"
|
| I've also tried from a CMD.EXE prompt:
|
| "C:\Program Files\JPSoft\TCMD9\TCMD.EXE"
| @"H:\Documents\TakeCommand\TCMD.INI"
|
|
| Since my INI points to a custom 4START.BTM file with a customised
| PROMPT I can tell straight way that the file has not loaded. On
| querying %_ININAME I always get back the %LOCALAPPDATA%\TCMD.INI even
| though it doesn't exists.
|
| If I replace TCMD.EXE with TCC.EXE everything works and the correct
| INI file is loaded.
|
| What am I missing?
|
| Ref: Windows XP SP2, NTFS Partitions, TCMD version 9.02.129.

Above you mentioned E: as your drive, but the commands you list reference
H:.

The following dump (using TCC's SHORTCUT command) of my shortcut to start
TCMD (not TCC) works as intended (verified by what program is run in which
tab):

Command=C:\JPSOFT\IZ\tcmd.exe
Arguments=/@C:\JPSOFT\TC9REG.INI
Directory=C:\JPSOFT
Description=TCMD, penultimate build
Link=C:\Documents and Settings\All Users\Desktop\JP TZ TC caZ.lnk
Icon=C:\JPSOFT\IZ\tcmd.exe
Offset=0
Mode=3
Hotkey=Ctrl-Alt-Z

--
HTH, Steve
 
#3
HoylD wrote:
| I'm trying to start TCMD.EXE with an alternate INI file. The reason
| for this is all my data is on an E drive and the EXEs on the C drive.
| The E drive gets backed up.

Sorry, though I already answered to the substance, but you posted in the
wrong NG. You should have been in the TC Support group
([email protected] by email).
--
Steve
 

rconn

Administrator
Staff member
May 14, 2008
10,779
97
#4
HoylD wrote:


> I'm trying to start TCMD.EXE with an alternate INI file. The reason for
> this is all my data is on an E drive and the EXEs on the C drive. The E
> drive gets backed up.
>
> Note: I've removed the TCMD.INI file from %LOCALAPPDATA% and put it in
> the folder E:\HoylD\TakeCommand\.
>
> In a windows shortcut I've tried the following target:
>
> "C:\Program Files\JPSoft\TCMD9\TCMD.EXE"
> /@"H:\Documents\TakeCommand\TCMD.INI"
>
> I've also tried from a CMD.EXE prompt:
>
> "C:\Program Files\JPSoft\TCMD9\TCMD.EXE"
> @"H:\Documents\TakeCommand\TCMD.INI"
>
> Since my INI points to a custom 4START.BTM file with a customised PROMPT
> I can tell straight way that the file has not loaded. On querying
> %_ININAME I always get back the %LOCALAPPDATA%\TCMD.INI even though it
> doesn't exists.
>
> If I replace TCMD.EXE with TCC.EXE everything works and the correct INI
> file is loaded.
>
> What am I missing?
There are two different programs (TCMD.EXE and TCC.EXE) loading the
TCMD.INI file. Your example above only tells TCMD to load the custom
file; any TCC tab windows are still going to be loading the default
TCMD.INI. (%_ininame is a TCC variable and reflects TCC's .INI file,
not TCMD's.)

You can specify the .INI file to use for TCC in a startup tab, or a
toolbar button.

Rex Conn
JP Software
 
#5
HoylD wrote:

There are two different programs (TCMD.EXE and TCC.EXE) loading the
TCMD.INI file. Your example above only tells TCMD to load the custom
file; any TCC tab windows are still going to be loading the default
TCMD.INI. (%_ininame is a TCC variable and reflects TCC's .INI file,
not TCMD's.)

You can specify the .INI file to use for TCC in a startup tab, or a
toolbar button.

Rex Conn
JP Software

Rex,

Thank you thank what I was missing the COMSPEC bit. Sorry for posting the the wrong area it was a mistake.

regards
Dave.