1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unknown command (newbie post - be gentle)

Discussion in 'TCC/LE Support' started by Geoff Corner, Oct 10, 2012.

  1. Geoff Corner

    Joined:
    Oct 10, 2012
    Messages:
    2
    Likes Received:
    0
    Hi, Some years ago I inherited a 4NT setup which performed a "scripted" compile and copy of a suite of Microsoft .NET programs using MakeFiles. This has all worked for many years. However our server is showing signs of age, so we are moving to a new server. The old server was Windows Server 2003 (32-bit) the new one is Windows Server (64-bit).
    As I didn't have the installation media for 4NT, I simply copied the code directory to the new machine. 4NT ran up OK except it now says I have a 30 day trial version, not the fully licensed version on the old machine. I contacted JPS and got a very quick response to say 4NT is no longer supported (no surprise) and that I should try (the free) TCC LE, which I am doing (I have actually installed both the 32-bit version and the 64).
    TCC starts OK and it runs the first few elements of my old BTM and BAT files but then (both versions) fail:- unknown command "nmake"
    nmake is a Microsoft program, buried deep in Visual Studio. I have placed the folder containing nmake.exe on the Windows PATH.
    If I start a Windows cmd pane then DOS finds nmake correctly, but TCC can't find it.

    Curiously 4NT also has the same problem - but yesterday I am sure it could find it (most confusing)

    Hope this makes sense and someone can explain the problem
     
  2. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    Did you try to close TCC/LE and restart it after modifying the Windows PATH? When you issue the PATH command in TCC, is nmake's directory in the list?
     
  3. Geoff Corner

    Joined:
    Oct 10, 2012
    Messages:
    2
    Likes Received:
    0
    The answer to that is "Yes AND No" - I updated the PATH yesterday before I installed TCC/LE. When I got the failure I checked the PATH and simply added a ";" to the end just to help the next updater.
    However (after my first post) on doing some investigation I noted that both 4NT and the two versions of TCC showed a PATH without the nmake folder - even the 4NT pane started after I added the ";" - DOS showed the full PATH.
    Following your reply I restarted both 4NT and TCC and now they both find nmake -
    Very curious timing of events - but at least I am on to the next hurdle.

    THANKS for the prompt reply
     
  4. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,523
    Likes Received:
    4
    The timing is actually normal. When TCC starts, it inherits PATH as it exists at the time. Changing it in Windows thereafter is not known to TCC. The same thing is true of most programs, Explorer included (though there are techniques to force instant notification of those programs which listen to them). Possibly the update did not get through Explorer the first time you tried in TCC.
     

Share This Page