PDir causing Take Command/TCC to crash...

May 24, 2010
855
0
Northlake, Il
I am "reawakening" this issue as a new thread because this started two days ago and since I had nothing new to add at that immediate time I feel that it may have "fallen off of the map", so to speak.

So here it is again, in summary. The command
Code:
PDir C:\Windows\winsxs\* /A-D /S /(-128.128fn zc dy/m/d th:m:s fp) >AFile.txt
cause(d) my copy of Take Command, TCC to "silently" crash; no error message, no dialog box, nothing at all visible; rather the TCC window where I had entered said command just "disappeared" from the screen. However, it turns out the was a ".gpf" file in my "C:\users/myuserid/AppData/Local.JPSoft" directory; I just didn't notice it initially (probably my bad eyes again as usual). So, after several hours of work, I was able to isolate the single line in TCC.ini that was causing TCC to consistently GPF (consistently because every time, absolutely no exceptions, that I start TCC with this line in the TCC.ini file and run the above-listed command, it (silently) GPF's. Without this single line, absolutely no problem.

So what is this single line? Simple:

NTFSDescriptions=Yes

And, as I said there is (or maybe are is a better word because I've been renaming each of them as they are generated and there are now 23 of them as I write this "note") .gpf files in my ".../AppData/Local/JPSoft" directory. The contents of just one of said .gpf files is:

TCC 12.11.76
Module=D:\Program Files\JPSoft\TCMD12BuildLast\TakeCmd.dll
Address=1000637A
Exception=C0000005
EAX=0D430D88 EBX=7F4F0008 ECX=0D430D88 EDX=029A03E0
ESI=029AC760 EDI=00010000 EBP=01706A60 ESP=016FA9F0
CS=0000001B DS=00000023 ES=00000023 SS=00000023
Flags=00010206

Stack:
1 : TakeCmd.dll 00000001:0000537a
2 : TakeCmd.dll 00000001:0000ceb6
3 : TakeCmd.dll 00000001:0000a85e

(The contents of all of the other .GPF files are similar except for explicit address(es).)

So, in effort to "isolate" the line that was "causing" the GPF, I followed the following procedure. First, I split the file TCMD.ini into 4 individual "sections", "[PopupFont]", "[4NT]", "[Font]", "[TakeCommand]", and tried the given "PDir" command with a TCC session started using a TCMD.ini file consisting of one, and only one, of those complete "sections". The only TCC session that "crashed" in this configuration was the TCC session that was using the TCMD.ini file containing the "[TakeCommand]" section, and only the "[TakeCommand]" section.

So I then essentially did a "binary" search. I "cut" out the second half of the file (again, the TCC.ini containing only the "[TakeCommand]" section), tested it, not bomb, added back one quarter of what I had cut out, tested it, if bombed, cut out the "last" 1/2 of the quarter (or 1/8th) of the file, if didn't bomb, cut out the "first" 1/8 of the file in the quarter that had been originally cut, if bombed, cut out the "last" 1/2 of the the 1/8th (or 1/16th of the file) that had been added...; and I repeated this sequence over and over and over until I had it (each iteration cutting and/or restoring fewer and fewer lines) down to only 1 line.

And finally, again after several hours of doing this (each individual test in the sequence took me between 5 and 10 minutes), I found that the line I reported caused the TCC session to "silently" GPF if present, and the "PDir" command successfully ran to completion if absent. As final test(s) to "confirm" my results, executing the "PDir" command with the original "total" TCC.ini file (containing all four "sections" and all lines in each "section") caused a GPF, executing the "PDir" command with the original "total" TCC.ini file minus the "NTFSDescriptions=Yes" line caused the "PDir" command to run to completion without a GPF. And I executed the last two tests 4 or 5 times with always exactly the same results (i. e., it was totally and completely repeatable in all respects).

I have to say that, in all honestly, I don't really particularly care at this point in time whether or not anyone else in the world can repeat this problem, and that is because, for me, running without the "NTFSDescriptions" line (which I don't need anyway since I don't use NTFS "Descriptions") is not at all an issue. However, when I was a programmer type for about 30 years, I would want to know about any "crashes" that occurred in any of the programs that I wrote; and I am sort of assuming that the same is true for Rex.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,446
88
Albuquerque, NM
prospero.unm.edu
However, it turns out the was a ".gpf" file in my "C:\users/myuserid/AppData/Local.JPSoft" directory; I just didn't notice it initially (probably my bad eyes again as usual).

Or perhaps because I told you, wrongly, to look in the program directory....

I haven't been able to reproduce this. But looking over your .INI file, I get the sense that you may be using x64 Windows?
 
Nov 3, 2010
9
0
On Tue, 04 Oct 2011 13:45:14 -0400, mathewsdw <>
wrote Re [Support-t-3259] PDir causing Take Command/TCC to crash...:


>So what is this single line? Simple:
>
>NTFSDescriptions=Yes

You mentioned previously that you don't need NTFSDescriptions. Why
not just set it to NO?
 
May 24, 2010
855
0
Northlake, Il
On Tue, 04 Oct 2011 13:45:14 -0400, mathewsdw <>
wrote Re [Support-t-3259] PDir causing Take Command/TCC to crash...:
You mentioned previously that you don't need NTFSDescriptions. Why
not just set it to NO?
Caesar, while that just might work, I didn't do that because my effort was to isolate the line that was causing the GPF, that and only that. And, simply put, because it works fine without that line, I have no incentive whatsoever to take the time to do more experimentation by putting that line back in the file and setting its value to "NO".
 
May 24, 2010
855
0
Northlake, Il
Still not reproducible here, with or without NTFSDescriptions=Yes.

The stack trace shows that your system ran out of memory.
Rex, since, as I said previously, I have an effective "workaround" and I don't have the ability to decode "stack traces" in general at this point in time (particularly since I've been effectively retired for more than ten years) and anyway don't have either the source code or the compiler listings to check the "stack trace" against, there is absolutely no way I can or would "dispute" your finding(s) on that issue. However (yes, there is a "however"), that absolutely does not, in and of itself, explain why that particular "PDir" command successfully runs to completion if that line is not in the .ini file and (silently) GPF's if that line is in the .ini file, and I just repeated the test yet one more time before starting this reply and that absolutely still is the case for me. I would also have to add, "why is no other application or TCC session not executing that particular command not having that particular problem?" I have no more to say on this subject unless you have something more you would like me to say or you have a question that I can answer. As the saying goes, "I am at your service".
 
Similar threads
Thread starter Title Forum Replies Date
Phileosophos PDIR to list filenames without extensions? Support 2
vefatica PDIR and streams Support 1
vefatica PDIR with fixed-width unqualified filename? Support 2
W pdir returns diff results between tcc and tcmd - one is an error msg Support 5
thedave pdir /s Support 2
Emilio III pdir /f switch Support 1
D pdir ignores pm Support 2
WadeHatler pdir broken in 19.1 for directories with spaces Support 1
M WAD PDir not working correctly... Support 5
vefatica WAD Nested variable expansion in PDIR's @function[*]? Support 13
mfarah More on pdir's options: /(fq) Support 5
mfarah How to? Getting pdir to display relative paths. Support 2
S PDIR and @LABEL questions Support 4
M How to? PDir on multiple wildcard patterns... Support 2
A pdir function usage Support 3
T How to? dir/pdir - 2nd level down only Support 7
JohnQSmith PDIR and descriptions Support 21
G WAD PDIR @IF bug, @WORD bug Support 8
S WAD PDIR: files with percent sign % in name cause not listing other files in directory Support 9
S WAD PDIR ignores exclusion ranges Support 1
M PDir format question... Support 3
M How to? "PDir" not working the way the I _thought _ the documentation said it does… Support 8
S WAD /Sn mishandled in DIR and PDIR, possibly elsewhere Support 15
S Fixed GPF in PDIR Support 3
S PDIR issue Support 1
M A "PDir" issue... Support 16
M A simple question related to the "dir" (and "pdir") commands... Support 5
J pdir /b1 issue Support 20
M Missing PDir option... Support 5
J Maybe Not So Hard Pdir Question Support 1
S PDIR fails in 12.10.55 Support 3
J V12 PDIR failure Support 1
S PDIR command causes GPF Support 5
D pdir inconsistency Support 4
S PDIR has trouble processing filenames with embedded percent sign Support 3
P PDIR woes Support 0
gschizas pdir crashes horribly in one specific folder Support 5
S PDIR question Support 2
S pdir /(fq) not working Support 5
R Colored directory listing bug with pdir. Support 1
nickles Bias in PDIR Support 5
F pdir problem Support 3
D can PDIR list full filepaths of docs in a nested folder? Support 13
R New Cloud Storage Tab in TCC options causing problems Support 0
vefatica What's causing this error? Support 4
T TCC reading TCMD.INI causing "Invalid item name" warnings and pauses Support 2
C MD / RD sometimes causing TCC to lockup Support 2
D Can alias pass parameters to for command? Support 3
samintz How to? Search for %(command) in Help? Support 1
T VIEW only works from command line Support 14

Similar threads