btm execute ondouble click

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Sep 24, 2008
23
0
#1
Take Command 10

On my laptop (XP Pro) with an older version of Take Command, I would just double click my btm scripts and they would execute.

With the new version on my new workstation (server 2008), the Take Copmmand console opens up but the scripts don't execute.

How can I get them to execute with a double click?

Thanks
 
#2
Kygre wrote:
| Take Command 10
|
| On my laptop (XP Pro) with an older version of Take Command, I would
| just double click my btm scripts and they would execute.
|
| With the new version on my new workstation (server 2008), the Take
| Copmmand console opens up but the scripts don't execute.
|
| How can I get them to execute with a double click?

In the installation directory of TCC/Take Command there is a batch file
tccbatch.btm. Execute it from a TCC prompt (either in a TCMD tab or a TCC
window), and it will associate .BTM files with TCC. It ought to do the
trick!
--
HTH, Steve
 
Sep 24, 2008
23
0
#3
Thanks for the tip - I ran the batch file, double clicking still just pulls up the TCC console. I still have to find the file I want to execute and copy it into the prompt window.

If I right-click on the file, and select "Open With", the select TCC, the file will execute directly. That will work for now, but it would be nice to get the double click back, since that is my previous habit.

Any suggestions?

Thanks,

Kyle
 
Sep 24, 2008
23
0
#4
correction on my previous msg

right-click "Open With" TCC actually opens the script in a dos prompt window instead of TCC.

Does the old TakeCommand standalone window still exist? That was well suited to my purposes...

Thanks,

Kyle
 
Sep 24, 2008
23
0
#6
Correct, but that is what opens upon a right-click, "Open With", then select TCC. A dos prompt window opens, and fails to run the btm file.

So I can't get a btm file to run on Server 2008 with a double click (which just opens the TCC Console) or a right-click "Open With"

The double click still works on my XP Pro, even though I upgraded for 9.x to 10.x

Thanks,

Kyle
 
Sep 24, 2008
23
0
#7
The TCC version 8.01 is running on the XP Pro machine. TCC 10 is installed, but version 8 is what comes up with a double click.

I would hope to see a simple window like that again with version 10 on my Server 2008.

I have literally hundreds of scripts I run this way.

Thanks,

Kyle
 
#8
On Fri, 11 Sep 2009 19:22:32 -0500, Kygre <> wrote:

|Correct, but that is what opens upon a right-click, "Open With", then select TCC. A dos prompt window opens, and fails to run the btm file.
|
|So I can't get a btm file to run on Server 2008 with a double click (which just opens the TCC Console) or a right-click "Open With"
|
|The double click still works on my XP Pro, even though I upgraded for 9.x to 10.x

Compare registry entries on the two machines:

HKEY_CLASSES_ROOT\btmfile\shell\open\command

The default value should have data something like this:

drive:\path\tcc.exe /c "%1" %*

Verify the path and exename are correct for each machine.
--
- Vince
 
#9
Kygre wrote:
| The TCC version 8.01 is running on the XP Pro machine. TCC 10 is
| installed, but version 8 is what comes up with a double click.
|
| I would hope to see a simple window like that again with version 10
| on my Server 2008.

IIRC the double-click start the program which is associated with the file
type (that's a two-step procedure), i.e., the ASSOC command assigns a
"filetype" to an extension, and the FTYPE command assigns a program to the
"filetype". The file TCCBATCH.BTM, installed in every directory where you
install TCMD or TCC, associates .BTM files with the copy of TCC.EXE which
executes it. If you have more than one version of TCC installed (obviously
in separate directories) and you do not move them, whichever version of
TCC.EXE had last executed TCCBATCH.BTM will be used to process .BTM files
via double-click. On the machine you mentioned in the first paragraph above
you must have executed TCCBATCH using 4nt.exe version 8.01 and not TCC 10.
Just start TCC10, and run TCCBATCH again, and it will be the new
"double-click" handler. BTW, the latest (and last) version of 4nt8 is
version 8.02, build 106, and upgrading from 8.01 is free.
--
HTH, Steve