Unable to start any BTM file from Explorer

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
May 22, 2013
21
0
#1
Until to day I used TCC / TCMD version 11, but under Windows 10, HELP often crasshes. Ok, may be time to buy a newer version 18. (64 bits) So I got the evaluation version.

Any attempt to open a BTM from Windows Explorer, now result in a TCC windows opens, displays an error message to short to read it, and closes.

During installation, I did not tell the installer to associate BTM files (or any other file) with TCC as version 18 should use the associations of version 11, including my right mouse options like Edit with my editor, Debug, Print etc.

Just "Open" does immediately close in version 18 :-( Starting the BTM from the command line works

Any idea what may be wrong?
 
May 20, 2009
217
0
53
ITALY
#2
I You create an almost empty .btm file, with just a echo on and then a pause, are You able to read the error message?

Regards

Rodolfo Giovanninetti
 
May 22, 2013
21
0
#3
No, that did not work, but yes thanks Rodolfo as your hint in a somewhat different way did the job. I have put a pause in 4EXIT.BTM and the result was:

TCC: Unknown command /CD:\Desktops\DSwitch.btm

It is a bug! Not a major one, but it it has stolen some hours of my time :-)
/C is not a part of the file name! A blank between /C and the command was never required in command.com, 4dos.com, 4nt.exe and still not required in CMD.

Modifying file associations for btm files in the registry has fixed the problem and i have registered version 18.

Thanks!
 
May 22, 2013
21
0
#5
Run OPTION, and see if you have "PathExt" checked on the Startup page. If you do, you have to have ".BTM" somewhere in your PATHEXT environment variable or TCC will not consider a BTM file to be executable. Windows does not insert BTM in the default PATHEXT variable.
No, that's irrelevant in my case. I need a BTM to be associated with extra commands, like Edit (not with notepad) Print by <printer1>, Print by <printer2> debug. So at installation Take Command is not allowed to associate BTM files as such would do it in a different way.

In the registry, HKCR\btmfile\shell\open\command was set to C:\4NT\TCC.EXE /C"%1" %* and such did no longer work because the missing blank between /C an "%1".

The same incompatibility in several shortcuts. C:\4NT\TCC.EXE /C<command> no longer works if there is no blank between /C or /K and the command.
In version 11 and older (Back to good old 4DOS) that spac was not required en in the very very past COMMAND.COM did not accept that blank.

It is not a real problem, thus don't stop your excellent work. There is no life without Take Command.
 
Last edited: