By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

TCC: C:\TC28\TCSTART.btm Take Command is not loaded

When I start TC v28 my TCSTART.btm gives me an error:
TCC: C:\TC28\TCSTART.btm [5] Take Command is not loaded
TC28 C:\TC28

TC28 C:\TC28
The TCSTART.btm line that is failing is:
@tcfont "lucinda console" 14 700

This happens whenever I reboot, and it happens running TCC or TCMD. but it does not happen afterwards. I fix it by typing TCSTART, which runs TCSTART.btm

I have three different versions of TCMD on the same laptop, and I run batch files frequently. My prompt tells me the command processor that I am running, followed by the current folder, followed by '>' on a new line. I fix the batch files so they use the latest TCMD. Eventually I will remove the older versions of TCMD.

I am trying to fix a problem with TCMD and TCC running in a window with a very big font. Yes, I know I can set this in options, but that does not work with 4 different screens. I have two monitors connected to my laptop, and all have different sizes from my laptop. Sometimes I just run the laptop away from my office, and sometimes I use a large TV as a monitor connected to my laptop.

tcfont "lucinda console" 14 700
works every time. This is also an alias

Steve Kraus
As a workaround, you might try adding a line
do while %@words[%_consolepids] lt 2 ( delay 1 )
before your TCFONT command.

(Also — and this is a completely irrelevant nitpick — I'm pretty sure the name of the font is Lucida Console.)
Hi Charles,

Adding a line to TCSTART.btm do while %@words[%_consolepids] lt 2 ( delay 1 )
before the TCFONT line did not work. ,
This caused TCmd and tcc to hang looping forever on the do while.

Also, you are right, the "lucida console" font name is "Lucida Console"
I was lazy when I tried it and just pasted my lower case command into the editor loaded with tcstart.btm.

What's happening is that TCMD is starting a thread to handle the communications with TCC processes running in tab windows. When your TCC process starts and runs TCSTART, the TCMD thread may not have been started yet by Windows (depending on timing which is unpredictably affected by a myriad of factors).

The simplest workaround (if you don't have other things in your TCSTART that you can move to the beginning to give Windows time to get the IPC thread started) is to add something like "delay /m 500" before your TCFONT command.

Similar threads