1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cd command altered in batch file

Discussion in 'Support' started by jsampsontheumpteenth, Jun 16, 2015.

  1. jsampsontheumpteenth

    Joined:
    Jan 25, 2011
    Messages:
    31
    Likes Received:
    0
    I have a batch file with a cd command. Since upgrading to v.18 I have found that this brings up a choice box. It did not do this before. If I do not make a choice there is a runaway execution of unwanted file copies and I have to kill TCC quick. The command is:
    cd C:Users\User\.moneydance\Documents\finances.moneydance

    How can I revise this to make it do what it did before I upgraded to v.18?

    Regards

    John Sampson
     
  2. Christian Albaret

    Joined:
    Jul 1, 2008
    Messages:
    154
    Likes Received:
    1
    Not reproducible here.
    A few points to (re-)check:
    - are you sure the dialog is related to the cd command? what does the dialog show? with the /= option, some commands show a "command dialog" to specify arguments and options, but cd does not seem to.
    - could there be an alias interfering?
    - could there be an interference with the fuzzy search, as you give a relative name? does the directory exist?
     
  3. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,812
    Likes Received:
    82
    Sounds like you're seeing the fuzzy directory dialog (without a screenshot it's difficult to tell what you're referring to). Go to OPTION and click on the "Command Line" tab. If you don't want fuzzy directory searches, make sure "Extended Directory Search / Search Level" is set to 0.
     
  4. jsampsontheumpteenth

    Joined:
    Jan 25, 2011
    Messages:
    31
    Likes Received:
    0
    Many thanks, gentlemen.
    I have found out what the problem is. I did not put a backslash after "C:" Previously TCC went straight to the quoted folder, but now it brings up the fuzzy directory dialog. The present behaviour is correct so I expect it must have been put right as TCC was revised.
     

Share This Page