1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable audible beep on input and inkey

Discussion in 'Support' started by thorsten, Jul 17, 2017.

  1. thorsten

    Joined:
    Aug 16, 2008
    Messages:
    124
    Likes Received:
    0
    The documentation says "to disable all error beeps set the length and frequency to 0. If you do, the BEEP command will still be operable, but will not produce sound unless you explicitly specify the frequency and duration." Nevertheless inkey and input beep very loudly.

    How can I make input and input "quiet"?
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,809
    Likes Received:
    82
    If the duration is set to 0, TCC will use the Windows default sound. You need to set duration > 0 (1 is fine) and the frequency to 0.
     
  3. thorsten

    Joined:
    Aug 16, 2008
    Messages:
    124
    Likes Received:
    0
    Actually I was mistaken: the error happened in an interactive script and I used TCC_RT as executing shell. That's why it didn't pick up the settings of my interactive shell. "option //BeepLength = 0" made the beep silent.
     

Share This Page