Invalid updates configuration file. ??

#1
For several days the TCC "Help" "Check for Updates" option has been returning the following Error popup.
Error
Invalid updates configuration file. The first line of the .INI file should be ";aiu;".
This happens on both systems where TCC is installed.
TCC 9.02.151 Windows XP [Version 5.1.2600]
TCC Build 151 Windows XP Build 2600 Service Pack 3
Registered to xxxxxxxxxxxxxxx 2 - 2 System License
AFAIK there have been no configuration changes to either system since updating to 9.02.151. -- other than routine updates to Opera, Firefox2, TortoiseSVN, and UltraEdit.

What do I need to do to get "Updates" working again? Thanks.
 

rconn

Administrator
Staff member
May 14, 2008
10,506
94
#2
Bob Chapman wrote:

> For several days the TCC "Help" "Check for Updates" option has been
> returning the following Error popup.
> Quote:
> Error
> Invalid updates configuration file. The first line of the .INI file
> should be ";aiu;".
What are the contents of your TCMDUPDATE.AIU file?

Rex Conn
JP Software
 
#3
rconn said:
What are the contents of your TCMDUPDATE.AIU file?
It turns out that the Error pop up was correct because the file contained:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /downloads/v9/tcmdupdate.aiu was not found on this server.</p>
<hr />
<address>Apache/2.0.46 (Red Hat) Server at jpsoft.com Port 80</address>
</body></html>
I removed (i.e. renamed) TCMDUPDATE.AIU and was gratified to find that (1) Check for Updates was working again and (2) TCMDUPDATE.AIU had been recreated with appropriate contents.

I'm sorry that I didn't find and check TCMDUPDATE.AIU before posting but it has provided an opportunity to thank you for the customary prompt and professional support that enhances an exceptional application.