1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Configuration dialogs in TCMD 11 look horrible on Win7

Discussion in 'Support' started by mscheuner, Oct 26, 2009.

  1. mscheuner

    Joined:
    May 21, 2008
    Messages:
    20
    Likes Received:
    0
    I just downloaded and installed TCMD v11 Build 30 x64. But running it on Win7 is no fun - the configuration dialogs look awful all around, they're cutting off lots of settings (and I'm running at 100% font setting - no enlarged fonts!).

    This needs to be fixed ASAP - I am going back to TCMD 8 for now, until v11 can be really used and configured properly.

    I have a number of screenshots from my system, see them on my Skydrive:

    http://cid-d06d619dc9f536d4.skydrive.live.com/browse.aspx/TakeCommand11/Configuration Dialogs
     
  2. dim

    dim Dimitry Andric

    Joined:
    May 31, 2008
    Messages:
    203
    Likes Received:
    0
    On 2009-10-26 11:00, mscheuner wrote:

    I can't reproduce this on Windows 7 x64, at least not in VMware. The dialogs look a bit flat, and the fonts are not antialiased, but no chopping off.

    Are you by any chance running a German version of Windows 7? Maybe this has something to do with language settings... just a wild guess.



    Post just one screenshot, that should be enough to show the effect. Just make sure to use PNG compression, or JPG with low-quality settings to minimize the size of the shot.
     
  3. mscheuner

    Joined:
    May 21, 2008
    Messages:
    20
    Likes Received:
    0
    Nope, using Windows 7 Enterprise which is "MUI enabled", but I'm using just the plain basic US-English settings.


    Posted them all up on Skydrive - see my updated original post.
     
  4. dim

    dim Dimitry Andric

    Joined:
    May 31, 2008
    Messages:
    203
    Likes Received:
    0
    Hmm, Firefox chokes on those skydrive pages with an XML parsing error; these live.com sites really are IE-only :(

    Anyway, the fonts in these dialogs are the so-called large fonts; I recognize the form immediately. I have no idea how these came to be enabled, but I also don't understand why the dialogs aren't auto-sized.

    Can you please post the output of:

    Code:
    reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontDPI" /v LogPixels
    
    to check?
     
  5. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,860
    Likes Received:
    83
    Not reproducible here (tried it on three systems).

    There was one other report during the beta of this problem, but that user
    was unable to reproduce it on any other system. Those dialogs are vanilla
    Windows dialogs, nothing is being overridden or customized. So this is
    likely to be (1) a Windows 7 bug, that is (2) system-specific. I suspect
    that Windows is confused about whether it's supposed to be resizing the
    dialogs for large fonts, and it ends up using large fonts but *not* resizing
    the dialogs. Can you try forcing a font dpi change to something other than
    the default to see if that clears up the internal confusion?

    Rex Conn
    JP Software
     
  6. Fross

    Joined:
    May 30, 2008
    Messages:
    223
    Likes Received:
    1
    Configuration dialogs in TCMD 11 look horrible on Win7

    Hello,

    I was the guy that mentioned this previously. It works fine on my home
    machine, but not on my notebook. I thought it was just me, but it sounds
    like at least one other person is seeing this.

    I'm running:

    TCC 11.00.30 x64 Windows 7 [Version 6.1.7600]
    TCC Build 30 Windows 7 Build 7600

    on my Lenovo R500.

    I'll try setting the font size to medium or larger (the default is
    "smaller-100%") and report back.

    Michael


    On Mon, Oct 26, 2009 at 7:54 AM, rconn <> wrote:


     
  7. Fross

    Joined:
    May 30, 2008
    Messages:
    223
    Likes Received:
    1
    Configuration dialogs in TCMD 11 look horrible on Win7

    Hello,

    I changed the Control Planel / Display setting from Smaller-100% to
    Medium-125%. After logging out and in (required) the option dialog box
    opened correctly. After switching back, the same problem appeared.

    Any thoughts?

    Michael


    TCC 11.00.30 x64 Windows 7 [Version 6.1.7600]
    TCC Build 30 Windows 7 Build 7600


    On Mon, Oct 26, 2009 at 11:02 AM, frossm <> wrote:


     
  8. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,860
    Likes Received:
    83
    Configuration dialogs in TCMD 11 look horrible on Win7

    First thought is that is DEFINITELY a Windows bug.

    Second thought is to try a custom DPI setting (i.e., try 101% or 99%) and
    see if that works.
     
  9. gschizas

    Joined:
    May 30, 2008
    Messages:
    81
    Likes Received:
    0
    I can reproduce the ugly dialog boxes only in the 64-bit edition. 32-bit edition (on 64-bit Windows 7) shows proper buttons. 64-bit edition shows "Windows 95-like" buttons. Other than the ugliness though, dialogs seems to work ok.

    I found out that the manifests of the exe files in 64-bit edition only have the trustInfo/security part, while the 32-bit files also have assemblyIdentity, description and dependency keys. I remember, from back in the Windows XP days, that when an application didn't display the new (then) rounded buttons, a .manifest file was all that was needed to "fix" the application. Unfortunately this doesn't work with files that already have a manifest, but perhaps the problem is related to the difference in the manifest resource.
     
  10. mscheuner

    Joined:
    May 21, 2008
    Messages:
    20
    Likes Received:
    0
    Here's the output:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontDPI\LogPixels
    REG_DWORD 0x78


    Does that help anything? My settings are to use standard fonts (100%) - no enlarged fonts or anything.
     
  11. mscheuner

    Joined:
    May 21, 2008
    Messages:
    20
    Likes Received:
    0
    This seems to have been fixed with Build 31 - everything looks ok, in terms of sizing of the "Options" dialogs.

    Thanks!
    Marc
     
  12. dim

    dim Dimitry Andric

    Joined:
    May 31, 2008
    Messages:
    203
    Likes Received:
    0
    On 2009-10-29 09:35, mscheuner wrote:

    Yes, 0x78 = 120 DPI, which usually corresponds to the "large font"
    setting in Windows. The normal setting is 96 DPI (which would give 0x60
    for the LogPixels value).

    E.g. in some way you managed to select a larger DPI, but without
    apparently switching your normal system fonts?
     
  13. Fross

    Joined:
    May 30, 2008
    Messages:
    223
    Likes Received:
    1
    Re: Configuration dialogs in TCMD 11 look horrible on Win7

    Interesting. I checked it on my working machine and it is indeed set to
    60. I checked on my broken machine and it is set to 78. However, both have
    the same "Smaller - 100%" setting in the control panel display dialog.

    My "78" machine is a notebook, but I couldn't see how that would matter.
    Regardless, they both work correctly with build 31.

    Regards and thanks for all the help.

    Michael


    On Thu, Oct 29, 2009 at 4:19 AM, dim <> wrote:


     
  14. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,860
    Likes Received:
    83
    That is definitely the wrong setting (that's large fonts, 120dpi). The
    change in build 31 was to fix a different bug (Windows 7 using the wrong
    common control), but even if it's (mysteriously) working with that setting
    you should change it back to 0x60 to avoid other (as yet unknown?) potential
    conflicts.
     
  15. dim

    dim Dimitry Andric

    Joined:
    May 31, 2008
    Messages:
    203
    Likes Received:
    0
    Re: Configuration dialogs in TCMD 11 look horrible on Win7

    On 2009-10-29 13:10, frossm wrote:

    It looks like Windows 7, and possibly Vista, are capable of using
    per-user DPI settings. Can you check the output of:

    reg query "HKCU\Control Panel\Desktop" /v LogPixels

    ? This should contain your 'personal' DPI setting.
     

Share This Page