By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Unable to bind multiple keys to the same key mapping directive

I recently upgraded to V28 from V24 and I noticed that I can no longer bind multiple keys to the same key mapping directive. This has worked fine in V24 and earlier. I don't know anything inbetween.

Looking in the documentation I found this statement:

"You can bind multiple key combinations to a directive (for example, the default Paste directive accepts either Ctrl-V or Shift-Ins)."

Which implies it should work.
Is this a known issue?
Ctrl-V and Shift-Ins both work (v28). What are you trying to do?
Left-Ctrl V works, but Right-Ctrl V does not work on my system, for the Paste Directive.

That is because, under Take Command Tabs Configuration Dialog, I have selected the Right Ctrl key.

With this dialog open, press the F1 key to read more detail about this.

In a stand-alone TCC window, this does not apply, so both Left- and Right-Ctrl V apply the Paste Directive.

     _x64: 1
   _admin: 1
_elevated: 1

TCC  28.01.14 x64   Windows 10 [Version 10.0.19043.1237]
I have several like this but I will use this example:

The last one is applied, the earlier one is lost.
In V24 and earlier this worked fine, I noticed this after installing V24 and trying to do my normal command line editing
I had already assigned "copy" to something else Ctrl-c
This is the exact version I am running: 24.02.51
What version are you running?
I'm running 28.01.14. I don't know if Win 11 matters (I doubt it). You gave this example:


In my INI file, they look like this.

EraseLine=Esc Ctrl-Y
Ohhh, thank you so much. It used to work the way I showed, but does not anymore.
I am switching to multiple definitions on the same line and that is working.
Thanks again

Similar threads