ANSI issues

samintz

Scott Mintz
May 20, 2008
1,495
16
Solon, OH, USA
If start WSL2 by clicking the Ubuntu icon in my start menu, it launches a console window that I can attach to a tab in TCMD. However, if I do that, ANSI stops working in that window. I get similar behavior if I do "start /tab wsl" from my TCC prompt.

However, if I just run wsl from a TCC prompt within TCMD, everything works correctly.

I am running Windows 10 20H2. Tcmd v27.00.19 x64.
TCC 27.00.19 x64 Windows 10 [Version 10.0.19042.685]
TCC Build 19 Windows 10 Build 19042
 
May 20, 2008
11,378
98
Syracuse, NY, USA
Same here. When I do the attach, I see
1612463458818.png

Attaching "Ubuntu" works, but ANSI is clobbered and continues to be clobbered if I detach the tab.. Attaching the other one (wslhost) is useless.
 
Similar threads
Thread starter Title Forum Replies Date
vefatica ANSI, PROMPT ... ??? Support 1
vefatica ANSI??? Support 9
FreezerBurnt ANSI Prompt messes up list output. Support 39
samintz ANSI Colors Support 33
nickles ANSI Colors Windows 7 no longer working Support 6
samintz WAD ANSI issue Support 3
AndrewJ TakeCommand v23 + ANSI color sequences leads to black on black text Support 6
K ANSI Not Working Support 8
vefatica ANSI, ANSIWin10 ... ? Support 2
vefatica Win10's ANSI doesn't like 2>NUL Support 10
vefatica How do I see Windows 10's ANSI in action? Support 3
M Please explain TCMD's ANSI x3.64 support Support 4
M ANSI is used to show files instead of OEM in version 17 to 19 ! Support 5
vefatica ANSI Support 11
vefatica WAD ANSI still misbehaves with build 35 Support 36
vefatica ANSI misbehavior????? Support 4
Peter Murschall UNICODE mixed with ANSI Code Support 11
J Piping ANSI control sequences through 'type' Support 4
gschizas Take Command (Environment) doesn't show v2 ANSI colors Support 30
B How to? Convert Unicode to ANSI Support 1
D Can ANSI escape sequences be used in keystroke aliases? Support 8
vefatica WAD ANSI <ESC>[K Support 5
M Ansi.sys and old Dos programs Support 7
R ansi.sys ?? Support 15
E Shorter prompt / ANSI codes support Support 10
S Issues with version v26.02.42 x64 Support 0
Jay Sage Issues With TCMD File Explorer Support 0
KarstenG PSUBST issues with Win10 2004 ? Support 4
Joe Caverly @HISTORY issues Support 4
Peter Murschall V26-Issues in the BDEBUGGER ! Support 11
J Moving from TCC v22 to TCMD v24 issues Support 3
A Downloads page issues Support 1
T @select and @selectarray issues Support 2
M A list of issues .. Support 17
Robert Kantor 20.00.25 Issues Support 6
T tchelp.exe issues Support 2
E Fixed Issues with DEDUPE Support 0
H New Install; Everything setup issues Support 9
Jay Sage WAD Issues with LOG Command Support 4
cgunhouse Registry Issues Support 8
S Take Command issues at high resolution Support 9
samintz WAD @format has issues in v18.00.14 Support 10
Charles Dye Assorted trivial issues Support 5
jbanaszczyk bdebugger issues Support 4
JohnQSmith Fixed Copying with regex (several issues) Support 7
S Documentation HELP issues Support 8
nikbackm Fixed v15: VIEW - encoding and CSV issues Support 9
Dan Glynhampton Documentation Minor issues with HELP Support 0
B Two Issues With TIMER Command In V14 Support 10
M @FileRead from a device issues... Support 6

Similar threads