Google Sendmail ?

Apr 2, 2011
1,441
10
54
North Carolina, USA
C:\Users\Galloway\Desktop\New folder]for %fn in (*.jpg) set sAttr=%sAttr /a "%fn"
[C:\Users\Galloway\Desktop\New folder]for %data in (@c:\TCMD\INIs\GMail_CSGalloway.set) option //%data
[C:\Users\Galloway\Desktop\New folder]sendmail %sAttr /d /v "csgalloway@gmail.com" "My pictures" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\Users\Galloway\Desktop\New folder]

c:\TCMD\INIs\GMail_CSGalloway.set has full lines that start off as:
MailServer=smtp.gmail.com
MailAddress=CSGalloway@gmail.com
MailPort=465
MailUser=CSGalloway@gmail.com
MailPassword=whatever

Anyone know why SENDMAIL is always returning with Interrupted ? Its works fine with NC.RR.COM -

VER:
TCC 15.01.52 x64 Windows 7 [Version 6.1.7601]
TCC Build 52 Windows 7 Build 7601 Service Pack 1
Registered to Charles S Galloway - 5 System License
 
Apr 2, 2011
1,441
10
54
North Carolina, USA
Follow-up.

The nc.rr.com outgoing server does not reguire authentication, while the gmail outgoing one does. Looking at how the gmail outgoing server is setup in Windows Live Mail here is what is different:

- Requires authentication, use same settings as incoming server
- Under incoming mail server settings, set to "Log on using clear text authentication"

Not sure how to do the additional settings withb TCMD/TCC.

Please advise.
 
Apr 2, 2011
1,441
10
54
North Carolina, USA
Hi Rex, and others following this thread.....

Any ideas why it's not working here?

C:\TCMD\INIs]for %data in (@c:\TCMD\INIs\GMail_CSGalloway.set) option //%data
[C:\TCMD\INIs]for %fn in (*) set sAttr=%sAttr /a "%fn"
[C:\TCMD\INIs]sendmail /=
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL=0 /x "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL=1 /x "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL=2 /x "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL /x "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL=0 "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL=1 "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]sendmail %sAttr /d /v /SMTP=smtp.gmail.com /SSL=2 "csgalloway@gmail.com" "My INIs" For your pleasure.....
Connecting to mail server.
Connected.
TCC: Interrupted.
[C:\TCMD\INIs]
 
May 20, 2008
11,411
99
Syracuse, NY, USA
Your TCC options should have

User: csgalloway (userid only, don't know about case sensitivity)

I also checked "AutoSSL"

Otherwise, my INI settings were the same as yours. It worked for me the first time with not much on the command line:

Code:
v:\> sendmail /ssl /v "vefatica@syr.edu" foo bar
Connecting to mail server.
Connected.
220 mx.google.com ESMTP fy7sm22273993qeb.1 - gsmtp
EHLO zz
250-mx.google.com at your service, [74.79.84.76]
250-SIZE 35882577
250-8BITMIME
250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN
250-ENHANCEDSTATUSCODES
250 CHUNKING
AUTH LOGIN
334 VXNlcm5hbWU6
dmVmYXRpY2E=
334 UGFzc3dvcmQ6
aG9vc2Vnb3c=
235 2.7.0 Accepted
RSET
250 2.1.5 Flushed fy7sm22273993qeb.1 - gsmtp
MAIL FROM: <vefatica@gmail.com>
250 2.1.0 OK fy7sm22273993qeb.1 - gsmtp
RCPT TO:<vefatica@syr.edu>
250 2.1.5 OK fy7sm22273993qeb.1 - gsmtp
DATA
354  Go ahead fy7sm22273993qeb.1 - gsmtp
.
250 2.0.0 OK 1378701446 fy7sm22273993qeb.1 - gsmtp
QUIT
221 2.0.0 closing connection fy7sm22273993qeb.1 - gsmtp
Disconnected.

Rex, does "AutoSSL" mean you don't have to put /SSL on the command line?
 
May 20, 2008
11,411
99
Syracuse, NY, USA
Actually, Charles, it works for me even if I include "@gmail.com" in the "User" field. Try this:
Code:
nslookup smtp.gmail.com
and post the IPs. I'll try your server.
 
Apr 2, 2011
1,441
10
54
North Carolina, USA
Vince,

How would I get it to work if I do not check AutoSSL in the Option > Internet tab? I see from the CHM file:

"Auto SSL : If checked, SENDMAIL and SENDHTML will use Auto SSL negotiation. If the remote port is set to the standard plaintext port, TCC will use Explicit mode. In all other cases, SSL negotiation will be implicit."

and looking up what the sendmail /SSL=0 does - it should work, shouldn't it?

"
/SSL=nType of SSL negotiation. The values are:

0Automatic (default if no n value is specified). If the remote port is set to the standard plaintext port, SENDMAIL will use Explicit mode. In all other cases, SSL negotiation will be implicit.

"

Your TCC options should have

User: csgalloway (userid only, don't know about case sensitivity)

I also checked "AutoSSL"

Otherwise, my INI settings were the same as yours. It worked for me the first time with not much on the command line:

Code:
v:\> sendmail /ssl /v "vefatica@syr.edu" foo bar
Connecting to mail server.
Connected.
220 mx.google.com ESMTP fy7sm22273993qeb.1 - gsmtp
EHLO zz
250-mx.google.com at your service, [74.79.84.76]
250-SIZE 35882577
250-8BITMIME
250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN
250-ENHANCEDSTATUSCODES
250 CHUNKING
AUTH LOGIN
334 VXNlcm5hbWU6
dmVmYXRpY2E=
334 UGFzc3dvcmQ6
aG9vc2Vnb3c=
235 2.7.0 Accepted
RSET
250 2.1.5 Flushed fy7sm22273993qeb.1 - gsmtp
MAIL FROM: <vefatica@gmail.com>
250 2.1.0 OK fy7sm22273993qeb.1 - gsmtp
RCPT TO:<vefatica@syr.edu>
250 2.1.5 OK fy7sm22273993qeb.1 - gsmtp
DATA
354  Go ahead fy7sm22273993qeb.1 - gsmtp
.
250 2.0.0 OK 1378701446 fy7sm22273993qeb.1 - gsmtp
QUIT
221 2.0.0 closing connection fy7sm22273993qeb.1 - gsmtp
Disconnected.

Rex, does "AutoSSL" mean you don't have to put /SSL on the command line?
 
Apr 2, 2011
1,441
10
54
North Carolina, USA
[C:\TCMD\INIs]nslookup smtp.gmail.com
Server: dns-cac-lb-01.rr.com
Address: 209.18.47.61
Non-authoritative answer:
Name: gmail-smtp-msa.l.google.com
Addresses: 2607:f8b0:400d:c01::6d
173.194.68.109
173.194.68.108
Aliases: smtp.gmail.com

Actually, Charles, it works for me even if I include "@gmail.com" in the "User" field. Try this:
Code:
nslookup smtp.gmail.com
and post the IPs. I'll try your server.
 
May 20, 2008
11,411
99
Syracuse, NY, USA
Vince,

How would I get it to work if I do not check AutoSSL in the Option > Internet tab? I see from the CHM file:

"Auto SSL : If checked, SENDMAIL and SENDHTML will use Auto SSL negotiation. If the remote port is set to the standard plaintext port, TCC will use Explicit mode. In all other cases, SSL negotiation will be implicit."

and looking up what the sendmail /SSL=0 does - it should work, shouldn't it?

"
/SSL=nType of SSL negotiation. The values are:

0Automatic (default if no n value is specified). If the remote port is set to the standard plaintext port, SENDMAIL will use Explicit mode. In all other cases, SSL negotiation will be implicit.

"
What port? When I use port 25, it works with "AutoSSL" checked and does not work otherwise (even with any of /ssl[=0123]). In all the failing cases, whether I use your server or mine, I get
Code:
530 5.7.0 Must issue a STARTTLS command first. x1sm1726122qai.6 - gsmtp
TCC: SMTP protocol error. 530 5.7.0 Must issue a STARTTLS command first. x1sm172
6122qai.6 - gsmtp.

Why don't you want to check "AutoSSL"?
 
May 20, 2008
11,411
99
Syracuse, NY, USA
It would seem that you cannot, on the command line, do the equivalent of checking "AutoSSL". Maybe it's one for Rex.
 
Apr 2, 2011
1,441
10
54
North Carolina, USA
Maybe it's that I would like to get the /SSL=[0-3] tp work - only use SSL when I need to.....

and from my orginal post:

MailPort=465

shows the port.
 
May 20, 2008
11,411
99
Syracuse, NY, USA
This worked: port: 465, user including @gmail.com, AutoSSL NOT checked ...
One thing I don't understand ... port 465 is for SSL and you want to use it without SSL ...?
Code:
v:\> sendmail /v /ssl=0 "vefatica@syr.edu" foo bar
Connecting to mail server.
Connected.
220 mx.google.com ESMTP z6sm6455547qar.0 - gsmtp
EHLO zz
250-mx.google.com at your service, [74.79.84.76]
250-SIZE 35882577
250-8BITMIME
250-AUTH LOGIN PLAIN XOAUTH XOAUTH2 PLAIN-CLIENTTOKEN
250-ENHANCEDSTATUSCODES
250 CHUNKING
AUTH LOGIN
334 VXNlcm5hbWU6
dmVmYXRpY2FAZ21haWwuY29t
334 UGFzc3dvcmQ6
aG9vc2Vnb3c=
235 2.7.0 Accepted
RSET
250 2.1.5 Flushed z6sm6455547qar.0 - gsmtp
MAIL FROM: <vefatica@gmail.com>
250 2.1.0 OK z6sm6455547qar.0 - gsmtp
RCPT TO:<vefatica@syr.edu>
250 2.1.5 OK z6sm6455547qar.0 - gsmtp
DATA
354  Go ahead z6sm6455547qar.0 - gsmtp
.
250 2.0.0 OK 1378782145 z6sm6455547qar.0 - gsmtp
QUIT
221 2.0.0 closing connection z6sm6455547qar.0 - gsmtp
Disconnected.
 
Apr 2, 2011
1,441
10
54
North Carolina, USA
... and do those servers respond on port 465 without SSL? I may be behind the times but I thought good old SMTP was good old port 25.

SRA = Server Requires Authentication.

aim.com, SRA=yes, SSL=no, port=25
aol.com, SRA=yes, SSL=no, port=587
gmail.com, SRA=yes, SSL=yes, port=465
hotmail.com, SRA=yes, SSL=yes, port=25
nc.rr.com, SRA=yes, SSL=no, port=25
yahoo.com, SRA=yes, SSL=yes, port=465
 
Similar threads
Thread starter Title Forum Replies Date
fpefpe (the new) google drive Support 15
C Google intregration error Support 4
vefatica Forums, Facebook, Google, Twitter Support 7
rconn News Google translation Support 4
Jay Sage Problem Launching Google Earth from TCMD Support 17
Jay Sage How to? SENDMAIL with G-Suite Mail Account Support 6
vefatica SENDMAIL via smtp.gmail.com? Support 3
C How to? inline IMG with sendmail? Support 7
R TCC-RT sendmail Support 8
R Fixed Sendmail parameter /USER= does not work Support 4
C sendmail in v20.00.25 x64 Support 7
Mordachai How to pass URL to sendmail? Support 10
J Sendmail, SSL and MS Servers Support 11
C SendMail and yahoo.com Support 1
C Sendmail w/GMail - problem Support 6
Joe Caverly How to? SendMail and SSL Support 2
Dan Glynhampton Fixed v15 sendmail : password encryption problem Support 18
Jay Sage SENDMAIL Apparently Not Setting Priority Support 2
S @CON: does not work with sendmail for pipe Support 2
vefatica SENDMAIL, command line override SMTP server? Support 2
Joe Caverly SENDMAIL under v14 Support 3
dcantor SENDMAIL /= missing field Support 4
C Using dif. sending addresses with sendmail Support 11
C sendmail TO name? Support 9
A Using SENDMAIL with Exchange Server Support 1
H Minor bug in v12 SENDMAIL Support 0
Jay Sage SENDMAIL Problem in TCC12 Support 10
dcantor Problem with SENDMAIL /H Support 4
Jay Sage How Can SENDMAIL Create Messages with Plain Text and HTML Support 2
C sendmail question Support 1
dcantor Feature request for SENDMAIL Support 0
S SENDMAIL attachment size limit Support 1
S SENDMAIL vs. RFC 2822 Support 0
S SENDMAIL vs. RFC 2822 Support 0
J Configure SendMail to go through GMAIL as SMTP server Support 10

Similar threads