1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Sendmail parameter /USER= does not work

Discussion in 'Support' started by Ruud Uphoff, Aug 14, 2017.

  1. Ruud Uphoff

    Joined:
    May 22, 2013
    Messages:
    21
    Likes Received:
    0
    I used this command line for test and it work fine:

    sendmail /V /X win10@uphoff.eu "Test message" @d:\mytext.txt >d:\testlog.txt

    However, I need to override the sender

    sendmail /USER="another@uphoff.eu /V /X win10@uphoff.eu "Test message" @d:\mytext.txt >d:\testlog.txt

    The last is right as documented by TCC help. But regardless where I add /USER=, the parameter us used as an (invalid) recipient and the message is rejected by the server.

    Someone can tel me what I am doing wrong?
     
  2. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,035
    Likes Received:
    0
    Not sure if this is all that is wrong - but I only see 3 double quotes.

    sendmail /USER=another@uphoff.eu /V /X win10@uphoff.eu "Test message" @d:\mytext.txt >d:\testlog.txt

    See if that works..
     
  3. Ruud Uphoff

    Joined:
    May 22, 2013
    Messages:
    21
    Likes Received:
    0
    Thanks, but to make it more complicated, the first quote was a typo in my message.
    In the mean time i found this (is it a bug or am I just somewhat stupid.

    WORKS: sendmail /V /X /USER=win10@uphoff.eu ruud@uphoff.eu "Test message" @d:\dirtest.txt
    WORKS: sendmail /V /X ruud@uphoff.eu "Test message" @d:\dirtest.txt >D:\testlog.txt
    ERROR: sendmail /V /X /USER=win10@uphoff.eu ruud@uphoff.eu "Test message" @d:\dirtest.txt >D:\testlog.txt

    Thus only using both /USER= AND redirection results in the following message:
    TCC: D:\testmailX.btm [2] SMTP protocol error. 550 Administrative prohibition.

    Any idea what happens?
     
  4. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    10,026
    Likes Received:
    84
    The problem isn't with /USER or redirection; the problem is with the /X option -- it isn't skipping the whitespace before looking for the next switch argument. If you put the /X after the /USER it should work.

    I have fixed this for the next build of TCC.
     
  5. Ruud Uphoff

    Joined:
    May 22, 2013
    Messages:
    21
    Likes Received:
    0
    Moving the /X has no effect, however removing it has solved the problem. And now I see that even without /X, te command uses EHLO

    Thanks!
     

Share This Page