1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SENDMAIL Problem in TCC12

Discussion in 'Support' started by Jay Sage, Aug 20, 2010.

  1. Jay Sage

    Joined:
    Jun 2, 2008
    Messages:
    284
    Likes Received:
    1
    I have copied the Internet settings from TCC11 to TCC12. The same
    SENDMAIL command that works in TCMD11 fails in TCMD12 with the following
    error report: TCC: error during handshake[2]: 0x80090308.

    I have another issue of confusion. Both versions report in the options
    dialog that they are using the same file:

    ...AppData\Local\JPSoft\TCMD.INI

    The options, however, are not the same, so something is keeping track of
    both versions.

    -- Jay
     
  2. Joe Caverly

    Joined:
    Aug 28, 2009
    Messages:
    638
    Likes Received:
    6
    I'm having a similar problem;

    Code:
    sendmail /v 5191231234@msg.koodomobile.com %1 @%1
    Connecting to mail server.
    Connected.
    220 toip3.srvr.bell.ca ESMTP
    EHLO LRDELLXP
    250-toip3.srvr.bell.ca
    250-8BITMIME
    250 SIZE 31457280
    STARTTLS
    500 #5.5.1 command not recognized
    TCC: SMTP protocol error. 500 #5.5.1 command not recognized.
    This works fine in Version 11 but not in Version 12.

    I have gone into Options, Configure TCC, Internet, and have entered the same info that I had in V11.

    I am using;

    Code:
    TCC  12.00.23   Windows XP [Version 5.1.2600]
    TCC Build 23   Windows XP Build 2600  Service Pack 3
    I have the TCMD.INI file in my TCMD12 directory.
    I have the TCMD.INI file in my TCMD11 directory.

    Code:
    echo %_ininame
    
    returns

    Code:
    C:\Program Files\JPSoft\TCMD12\TCMD.INI
    Joe
     
  3. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,785
    Likes Received:
    29
    I can repro it too. FWIW, here is my server's session log.

    Code:
    19:10:12.671: Connection from 74.71.55.217, Fri Aug 20 19:10:12 2010<lf>
    19:10:12.671: << 220 lucky.syr.edu ESMTP server ready.<cr><lf>
    19:10:12.718: >> EHLO ZZ<cr><lf>
    19:10:12.718: << 250-lucky.syr.edu Hello ZZ; ESMTPs are:<cr><lf>250-TIME<cr><lf>
    19:10:12.718: << 250-SIZE 0<cr><lf>
    19:10:12.718: << 250 HELP<cr><lf>
    19:10:12.968: >> STARTTLS<cr><lf>
    19:10:12.968: << 502 STARTTLS not enabled by administrator.<cr><lf>
    19:10:12.015: --- Connection closed normally at Fri Aug 20 19:10:12 2010. ---
     
  4. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,730
    Likes Received:
    80
    The problem is that your creaky old mail server doesn't understand SSL.
    I'll have to add a fallback option for aged servers.


    It's definitely not TCMD!

    Rex Conn
    JP Software
     
  5. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,730
    Likes Received:
    80
    So turn on SSL! (At least you apparently have the option; some others have
    mail servers that are apparently > 10 years old and don't even recognize
    it.)

    Rex Conn
    JP Software
     
  6. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,785
    Likes Received:
    29
    On Fri, 20 Aug 2010 19:27:12 -0400, rconn <>
    wrote:

    |---Quote---
    |> I can repro it too. FWIW, here is my server's session log.
    |>
    |> Code:
    |> ---------
    |> 19:10:12.968: >> STARTTLS<cr><lf>
    |> 19:10:12.968: << 502 STARTTLS not enabled by administrator.<cr><lf>
    |---End Quote---
    |So turn on SSL! (At least you apparently have the option; some others have
    |mail servers that are apparently > 10 years old and don't even recognize
    |it.)

    SSL/SMTP is certainly not the norm. It's the first time in 6 years
    I've seen a client request it. And my RoadRunner smtp server doesn't
    recognize it either:

    Code:
    Connecting to mail server.
    Connected.
    220 Welcome Road Runner. WARNING: *** FOR AUTHORIZED USE ONLY! ***
    EHLO ZZ
    250-hrndva-omtalb.mail.rr.com says EHLO to 74.71.55.217:1825
    250-PIPELINING
    250-8BITMIME
    250 ENHANCEDSTATUSCODES
    STARTTLS
    500 5.5.2 unrecognized command
    TCC: SMTP protocol error. 500 5.5.2 unrecognized command.
     
  7. Rod Savard

    Joined:
    May 26, 2008
    Messages:
    480
    Likes Received:
    3
    Agreed, regular ol' SMTP (non SSL) is still very common.
     
  8. Howard Goldstein

    Joined:
    Jun 1, 2008
    Messages:
    111
    Likes Received:
    1
    Yes, and that's why most email clients give you the choice of whether or not
    to use SSL in their account settings. I guess it's time for YAID: yet
    another ini directive.
     
  9. Jay Sage

    Joined:
    Jun 2, 2008
    Messages:
    284
    Likes Received:
    1
    > The problem is that your creaky old mail server
    > doesn't understand SSL. I'll have to add a fallback
    > option for aged servers.

    Hmm. Was there some way we were supposed to know that SSL was now
    required? Now that I knew, I changed the port number to the value my
    mail server uses for SSL processing, and SENDMAIL works (I'm still using
    the version of TCMD that gave me trouble before). And I figured I might
    as well configure Thunderbird to use an SSL connection as well, which
    also works now.

    -- Jay
     
  10. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,730
    Likes Received:
    80
    It's in the "What's New".

    However, it's no longer relevant, as I added an option to SENDMAIL in
    12.0.24 to allow you to specify whether you want SSL.

    Rex Conn
    JP Software
     
  11. Jay Sage

    Joined:
    Jun 2, 2008
    Messages:
    284
    Likes Received:
    1
    > However, it's no longer relevant, as I added an
    > option to SENDMAIL in 12.0.24 to allow you to specify
    > whether you want SSL.

    As a result, my SENDMAIL script quit working again, since I had set the
    Internet configuration in TCC for SSL. I just updated the script to
    include "/SSL=0" in the command line if the port setting is the value my
    mail server uses for SSL.

    -- Jay
     

Share This Page