1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Help @FUNCTION, missing paragraph

Discussion in 'Support' started by vefatica, Dec 21, 2016.

  1. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,874
    Likes Received:
    30
    I didn't check them all, but for the several I did check, the v20 help is missing the first paragraph, which usually gives the syntax and description. Compare:
    upload_2016-12-21_22-53-58.png
     
  2. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,874
    Likes Received:
    30
    Not the whole first paragraph, but rather a certain number of lines.
    upload_2016-12-21_23-9-18.png
     
  3. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,812
    Likes Received:
    82
    Not reproducible here (Win 10 x64).

    Anybody else seeing this?
     
  4. Rodolfo

    Joined:
    May 20, 2009
    Messages:
    213
    Likes Received:
    0
    On my pc with Windows 8.1 x64 it works.


    Regards

    Rodolfo Giovanninetti
     
  5. JohnQSmith

    Joined:
    Jan 19, 2011
    Messages:
    559
    Likes Received:
    7
    I am able to reproduce the problem. From the command prompt, "help @truncate". If I browse to any of the linked functions, they are also cut off. Actually, any command help opened from the command line is chopped off, not just functions. Try "help dir".
    However, I if open the help by itself and then browse to the functions, they are displayed correctly.
     
  6. Rodolfo

    Joined:
    May 20, 2009
    Messages:
    213
    Likes Received:
    0
    When I said that on my windows 8.1 x64 pc it works, I did not think to test the "help @truncate".
    So, also for me, if I start help and then go to the @truncate page it works, but if I use help @truncates I see that the first lines are missing.

    Regards

    Rodolfo Giovanninetti
     
  7. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,874
    Likes Received:
    30
    And those pages you get to with "HELP item" don't have the link to the TOC that the online help has.

    upload_2016-12-22_23-23-2.png
     
  8. Alpengreis

    Joined:
    Jan 12, 2014
    Messages:
    228
    Likes Received:
    6
    I have this behaviour too since new v20.10, NOT before ..

    PS: Win 10 Pro x64
     
  9. Glenn Bowes

    Joined:
    Oct 11, 2015
    Messages:
    29
    Likes Received:
    1
    I am seeing it as well.

    TCC 20.10.32 x64 Windows 10 [Version 6.3.14393]
     

Share This Page