By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

No help

I have finally just got around to upgrading to tcmd/tcc v31, and was trying to write a .btm file. I pressed F1 for help and got only a blank window in the new eWriter Viewer program. I tried also from the Take Command help menu, and manually opening the TakeCommand.ewriter file from eWriter Viewer. Nothing worked, I just got a blank window. I happened to leave the eWriter Viewer program open in the background, and when I went back to it maybe 10 minutes later, the window did now have some text with links to the JPSoft.com web site that worked. But it was not formatted properly and none of the options for local help data produced anything. Does anyone know how to fix the help?

Just some thoughts:

Local help ... firewall? The local help uses port 8000 and various high-numbered dynamically-assigned ports.

Web help ... browser? ... I use Firefox. I occasionally see that ancient-looking rendering of web pages. I have never determined that the problem was on my end and it always fixed itself without my intervention. Maybe it has something to do with web-caching, local or remote.
Running TakeCommand.ewriter results in a popup to "Select an app to open this .ewriter file". I also again tried going to the C:\Program Files\JPSoft\TCMD31 directory and running eViewer.exe from there. I got an empty eViewer window, from where I selected the TakeCommand.ewriter file to view. But I just got a blank window, as before, and then after waiting for a couple of minutes, I got the same result as in the screenshot above.
After running ewriter-viewer-setup.exe, it offered to open eWriter Viewer, so I said yes. Then when I went to the menu to open the TakeCommand.ewriter file, it was already on the correct C:\Program Files\JPSoft\TCMD31 directory, so I just selected the file. Unfortunately, it was just the same as before - at first a blank window (with the correct title in the title bar), and then after a few minutes the same as my original screenshot.
I have passed this on to the eWriter developers. Since yours is the only report of a problem viewing the help, it's going to be hard to reproduce it elsewhere.

The stock answer from the ewriter developers is going to be:

You need to be running a valid version of Windows (Windows 10 or 11), which will automatically have the required version of the Windows WebView, which is based on IE 11. Earlier versions are invalid now and can cause problems.

Provided you didn't do something like uninstall IE 11 (and you aren't running a non-updated original Win 10 build) that shouldn't be an issue.
I am indeed running a valid version of Windows 11. However, it has been upgraded from an original Windows 7 install via Windows 10 rather than being a clean install of Windows 11.
This is what I got today from the eviewer developers:

Ask him which version of Windows he is using. The eViewer must use the Windows WebView component for rendering the HTML pages, and this component is still the rendering engine of Internet Explorer, even if it is not officially used any more in current versions of Windows. If he has an old version of Windows and/or an outdated version of IE that could be the cause. Another possibility is that he has a restrictive security policy that is preventing IE from working in eViewer.
I checked Settings > System > About and it says I am running Windows 11 Pro 22H2. It seems that Windows Update is having problems downloading things, so it looks like it is unable to automatically update to the 23H2 version it should currently be on. Internet Explorer was long ago updated by Microsoft to the Edge browser. If I run iexplore.exe, it runs Edge instead. I have not set up any restrictive security policies, and it is a home system, not under any corporate control.
It's not iexplore.exe that's important, it's the dll's that it (used to) use that are still used by a number of other apps.

I created a debug build of the help that will display what eviewer is trying to load & the response from the system in a window at the bottom of the page. Download it from:

and post the contents of the debug window.
I downloaded the TakeCommandDebug.ewriter file and put it in the "C:\Program Files\JPSoft\TCMD31" directory and ran it from there from a TCC prompt. This is what the debug window at the bottom showed initially:

Load page:
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/index.html
Ok: index.html
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/jquery.tools.min.js
Ok: jquery.tools.min.js
Request handled: 1

Then when I went back again in a minute or so and the partial page display was present, as per my attachment on my first post. This is the full debug window output after that:

Load page:
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/index.html
Ok: index.html
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/jquery.tools.min.js
Ok: jquery.tools.min.js
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/jquery.easing.1.3.js
Ok: jquery.easing.1.3.js
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/helpman_navigation.js
Ok: helpman_navigation.js
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/hmwebhelp.js
Ok: hmwebhelp.js
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/helpman_settings.js
Ok: helpman_settings.js
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/background-logo.png
Ok: background-logo.png
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/search.svg
Ok: search.svg
Request handled: 1
Load page: -> Frame: hmcontent
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/browse.svg
Ok: browse.svg
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/index_off.svg
Ok: index_off.svg
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/search_off.svg
Ok: search_off.svg
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/overview.htm
Ok: overview.htm
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/default.css
Ok: default.css
Request handled: 1
Request: /EE0C892B-A6CB-4BE2-BECA-3D189D45CBB1/hm_topic.css
Ok: hm_topic.css
Request handled: 1
This is what the eviewer developers said after seeing the debug output:

I downloaded your file and it's absolutely fine, and your own debug output confirms this. The problem must be on the system of the specific end user. We need to know a) what version of Windows he's running and b) if he has any restrictive internet policies installed.
More feedback from the developer:

Another question: In some cases, passing on the eViewer.exe program without signing it with your own code certificate could also have an effect like this. If this is the case, ask the user to download and install our signed version with this link:


Installing this will change the file association for .ewriter on the user's to this eViewer version with our signature.
No luck with the signed version of eViewer.exe.

Enabling web help works, except that the URL it goes to is a bit mangled. It first opens:

which does a 404 error. If I remove the .htm or the .html from that, I get the web help. It looks like the web help does everything I need, and this PC is only going to be without Internet access when the net is down, so I should be fine with that. My laptop does not have this problem - eViewer works there!
Very strange mangling on your web help URL - TCC & TCMD do not insert "index.html" for webhelp, only for eviewer help. Definitely not reproducible here.

Are you setting web help in both TCMD and TCC? (It is a separate option in each).

How exactly are you invoking help to get that mangled URL? I.e., F1, or HELP at the TCC prompt, or from the Help menu in TCMD?

Do you have any aliases for HELP, or any plugins that could be intercepting & modifying the help call?
I had only set the Web Help option for tcmd. I have now set the tcc option also, but it made no difference. The mangled URL happens when I use the F1 key from a tcc prompt running from tcmd. The tcc HELP command also used the mangled URL. The three help buttons from the tcmd menu work correctly. I have no HELP aliases, and no extra plugins.

Then I created a symbolic link from my C:\Users\Public\Documents\JPSoft\TCMD31.INI file to C:\Program Files\JPSoft\TCMD31\TCMD.INI and that has fixed the mangled URL problem.

Similar threads