By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

[v31.x] Help says "Do not enable UTF-8" - but it's enabled by default. Why?

About the UTF-8 Option, the help says following:

TCC Startup Configuration Dialog
UTF8: If enabled, TCC will check (non UTF-16) files to see if they are in UTF-8 format (i.e., for UTF-8 batch files, SET /R, @LINE, etc.). TCC (and Windows) are UTF-16 internally, so TCC will convert UTF-8 characters to their UTF-16 equivalents before processing the line. TCC will first check the BOM to see if it is UTF-8; if not TCC will examine the beginning of the batch file looking for valid UTF-8 characters. If the file is very small or has very few (<4) UTF-8 characters, TCC will assume the file is ASCII. We recommend you do not enable this option unless you know you need to read UTF-8 files.

But with fresh install, this option is enabled by default, why is that?

PS: was perhaps also the case with v30.x or so already ...
The help is wrong. UTF8 was changed to the default in v26 -- a combination of Microsoft finally providing some support for UTF8 and TCMD / TCC adding more support to extend what Windows does.

UTF8 output doesn't cause any problems with ASCII output, so it doesn't introduce any incompatibilities.

Similar threads