Incorrect icon for TCC/LE prompt here, Windows 10

May 20, 2016
5
0
#1
I suspect this is caused by something that's not quite configured correctly on my system, but here's what I'm experiencing. This is under Windows 10, ver reports:

TCC LE 14.00.6 x64 Windows 10 [Version 6.3.15063]

If I double click on tcc.exe itself, or a shortcut, the window that appears has the correct TCC icon.

However, if I use the TCC/LE prompt here option in explorer, the icon is a "generic console" icon.

See the attached image for details.

Is there anything I should do to fix this?
 

Attachments

Jun 2, 2008
300
1
#4
I hunted down a Windows 10 machine and it exhibited the same behavior. The entry in the registry for that function uses the whole path to the program with quotes around it, so I wondered if that had something to do with the issue since the command and PowerShell entries use just the program names because their folders are in the PATH. So I added the TCC LE folder to the PATH, changed the registry entry to just the program name, broke something in the process somehow even though everything looked ok, fixed it with the BTM file, changed it back to just the program name again and it worked and the icon showed correctly. Then I ran the BTM file again to set the registry back to what it was originally, removed the path from the PATH variable, cleared out the IconCache stuff, and the icon is still working correctly.

So, uh, all that stuff probably isn't necessary, but that's how I fixed it. Heh
 
Likes: dgnuff
May 20, 2016
5
0
#5
@TEA-Time Thanks so much, I was able to get a solution from that. I already have my TCC/LE install directory in my path, and changing the registry to just the program name fixed it.