TEE cannot handle Unicode output

About 3 weeks ago (Build 35 I think) it still worked, but in
Surprisingly, HEAD and TAIL are also completely different
work. HEAD obviously has no problems, but TAIL and TEE do.
1589536706168.png

And the output via TEE produces very zero bytes !
1589538099116.png

and
1589538157250.png
 
Last edited:

rconn

Administrator
Staff member
May 14, 2008
12,344
149
The extra 0-byte in TEE was covered in another thread (new STL bug) and was already fixed for 26.01.40.

I fixed a problem with TEE not always recognizing UTF16 input; that is also in 26.01.40.

Note that your "tee con: >& nul" syntax won't do what you're hoping - if you want to have TEE dump output without also writing to a file, use "tee nul:". Redirecting CON results in TEE recognizing STDOUT has been redirected, and it will try to write a BOM.
 
Aha, good point. Thanks for that explanation.
And yes, now it works in Build 40 :smile:
 
Similar threads
Thread starter Title Forum Replies Date
A How to? TEE - duplicate output to STDERR Support 3
C TEE command appending null characters to output Support 6
vefatica TEE /A adds newline? Support 2
D Why is the TEE command 120 times slower? Support 10
vefatica Debug messages from TEE? Support 3
Joe Caverly Problem with TEE in v22 Support 2
David McClelland TEE command puts it's output file in c:\ Support 4
Roedy problem with tee Support 2
krischik WAD Tee printing Chinese characters Support 7
J TEE Problem Support 11
vefatica WAD TEE adds newlines Support 4
A How to? Use TEE with .NET output Support 6
D WAD Multiple TEE causese weird variable scoping? Support 7
S Tee? Support 9
jdanielp Cannot step into and/or call another .bat file when debugging .bat file Support 2
fishman@panix.com HELP!! I just updated to Version 28 and as usual I cannot make extended directory search work. Support 2
samintz WAD Cannot unset .py[co] Support 2
L Cannot get DEBUGMONITOR to work Support 5
Jay Sage Cannot Postion Cursor in Command Line Using Mouse Support 7
Joe Caverly A new guard page for the stack cannot be created Support 6
O I cannot use links to .btm files Support 5
E Cannot paste dollar sign into TCC on Windows 10 1803 Support 7
N Cannot install Support 2
Patulus TCHistoryLog: TCC: (Sys) The system cannot find the path specified Support 15
thorntonpg F1 on command line The webpage cannot be found Support 5
M Fixed Cannot use the "Browse..." function in "Find files/text" dialogbox Support 2
gschizas Fixed Cannot use extended path to delete invalid file Support 3
S WAD Cannot access mapped drive in 64b Win7 Support 15
S WAD Messages cannot be seen or accessed in Forum Support 12
D cannot get into ftp://jpsoft.com/oldver Support 1
T signaling firstcondition and cannot change colors Support 8
L File association: System cannot find the associated program Support 30
Q TCC: (Sys) The process cannot access the file because it is being used by another process. Support 0
L Thanks from larryalk was Cannot apply Start in folder for Tcmd Support 11
L Cannot apply Start In folder for Tcmd Support 15
C Cannot register v12.10 without Internet access Support 19
BobK Error from START cmd, "cannot find the file" Support 16
newbie Cannot make a btm/tcc.exe window wider Support 4
P Cannot download any of Vince Fatica's plugins Support 4
Roedy Cannot have both v10 and v11 Support 7
A Cannot permanently remove Tabs toolbar using View menu - bug? Support 8
M TCC cannot find the path specified Support 4
mscheuner TCMD 8 - cannot register on Vista x64 Support 0
Joe Caverly @SMWRITE invalid handle Support 8
vefatica Job handle in target app Support 4
E Fixed DEDUPE doesn't handle filenames with whitespace properly when symlinking Support 1
C How to? handle the UAC prompt on computer restarts with Everything Support 3
S How to? Handle unexpectedly inaccessible CWD Support 8
vefatica OT: Rex, how does CMD handle its environment? Support 0
E WAD Open handle on USB drive in TCC Support 3

Similar threads