Cannot paste dollar sign into TCC on Windows 10 1803

Aug 19, 2009
16
2
After updating/upgrading to Windows 10 1803, I am no longer able to paste e.g. UNC paths containing dollar signs into TCC (the tcc.exe console app). TCC just inserts a NULL character at positions where a $ sign should be placed.

The issue does not hit TakeCommand or CMD.
 

rconn

Administrator
Staff member
May 14, 2008
12,344
149
Not reproducible here. This is unlikely to be a TCC issue, especially since it works in Take Command, which is just running TCC in a hidden window.

It's more likely a problem with the font and/or code page you're using, which may have been changed (broken?) in Win 10 1803. What font / code page / language are you using?
 
Aug 19, 2009
16
2
Easily reproducible here. Take the EN_US 1803 image (MLF_X21-79647.ISO) and create a virtual vanilla Windows from it. Select Danish for Time, Currency and Keyboard. Then Windows 10 Enterprise. And finally Denmark as region and keyboard once more. Install VMware Tools (or whatever is needed for your virtualbox). Apply all updates from Windows Update. When windows have finished updating, install tcmd-22.00.42.exe and create a shortcut for TCC on the desktop.

Open TCC enter command like "echo StringWith$Sign", execute the command and the mark, copy and paste. At the position of the dollar sign you'll get a blank, and when you execute the command, the result will be "StringWithSign" (without the blank).

HOWEVER: I have also tried to create a virtual vanilla Windows from same image but using US instead of DK for all prompts. And I have to admit that the problem does not exist on this machine. How do I convince Microsoft, that there is a locale problem in Windows 1803, but only on third party software?
 
Aug 19, 2009
16
2
Just found a "workaround". On the Options tab on the shortcut properties, there's a "Use legacy console" option (see screenshot below). When I check that option, I can now paste strings with $ signs in it. Unchecking "Filter clipboard contents on paste" didn't do it.

This option is not available on the Take Command shortcut (because it's not a console app), and that's probably the reason why TCC works inside Take Command.

1527236766812.png
 
Last edited:
Aug 19, 2009
16
2
Okay - "Use legacy console" seems to be a global option and not only an option for the shortcut being changed.
As Ubuntu Bash does not run with this option set, the workaround mentioned above does not solve my issue.

As Rex does not see this as a problem with TCC, I would appreciate any suggestions I could try.
 
Aug 19, 2009
16
2
Well, don't use WSL, or don't use native console for WSL. There's always alternatives to everything.

I think I get your point, and then again I don't.
Dont' use WSL: Well, to me this have been one of the greatest enhancements to Windows for many years. So this is not an option.
Don't use native console for WSL: Please elaborate. How do I launch bash without using native console? Tried several different approaches without any luck.
 
Aug 23, 2010
637
9
Cygwin. WSL is not an enhancement, it's a crutch. It does not integrate into Windows, it exists in a parallel universe.
MinTTY(the default Cygwin terminal) has WSL support.

This is just what I'm using myself, but I know there's more.
 
Similar threads
Thread starter Title Forum Replies Date
jdanielp Cannot step into and/or call another .bat file when debugging .bat file Support 2
fishman@panix.com HELP!! I just updated to Version 28 and as usual I cannot make extended directory search work. Support 2
samintz WAD Cannot unset .py[co] Support 2
Peter Murschall TEE cannot handle Unicode output Support 2
L Cannot get DEBUGMONITOR to work Support 5
Jay Sage Cannot Postion Cursor in Command Line Using Mouse Support 7
Joe Caverly A new guard page for the stack cannot be created Support 6
O I cannot use links to .btm files Support 5
N Cannot install Support 2
Patulus TCHistoryLog: TCC: (Sys) The system cannot find the path specified Support 15
thorntonpg F1 on command line The webpage cannot be found Support 5
M Fixed Cannot use the "Browse..." function in "Find files/text" dialogbox Support 2
gschizas Fixed Cannot use extended path to delete invalid file Support 3
S WAD Cannot access mapped drive in 64b Win7 Support 15
S WAD Messages cannot be seen or accessed in Forum Support 12
D cannot get into ftp://jpsoft.com/oldver Support 1
T signaling firstcondition and cannot change colors Support 8
L File association: System cannot find the associated program Support 30
Q TCC: (Sys) The process cannot access the file because it is being used by another process. Support 0
L Thanks from larryalk was Cannot apply Start in folder for Tcmd Support 11
L Cannot apply Start In folder for Tcmd Support 15
C Cannot register v12.10 without Internet access Support 19
BobK Error from START cmd, "cannot find the file" Support 16
newbie Cannot make a btm/tcc.exe window wider Support 4
P Cannot download any of Vince Fatica's plugins Support 4
Roedy Cannot have both v10 and v11 Support 7
A Cannot permanently remove Tabs toolbar using View menu - bug? Support 8
M TCC cannot find the path specified Support 4
mscheuner TCMD 8 - cannot register on Vista x64 Support 0
vefatica Copy/Paste anomaly Support 4
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
A How to? Copy+Paste in TCMD tabs with Ctrl-Shift-Ins? Support 5
rps Documentation "Copy+Paste+run" question Support 2
S Paste in TCC/TCMD window is very slow [v20.0.22] Support 13
Alpengreis How to? Copy & Paste without linebreak within TCMD Support 13
cgunhouse Ctrl + Shift keys and Paste (drop down menu and V) Support 4
D Fixed Cut and paste in TC's file/folder view does not remove file Support 17
samintz Hotkeys for copy/paste do not work in BDEBUGGER Support 4
J Paste corruption Support 6
S WAD Paste issue Support 2
Joe Caverly Copy Paste Run Support 12
W Copy+Paste without breaking long lines as default? Support 1
rcjackson0926 TCC 11.0 vs 4NT copy and paste Support 2
J Extra blank lines during paste Support 6

Similar threads