Cannot paste dollar sign into TCC on Windows 10 1803

Aug 19, 2009
16
2
#1
After updating/upgrading to Windows 10 1803, I am no longer able to paste e.g. UNC paths containing dollar signs into TCC (the tcc.exe console app). TCC just inserts a NULL character at positions where a $ sign should be placed.

The issue does not hit TakeCommand or CMD.
 

rconn

Administrator
Staff member
May 14, 2008
10,642
97
#2
Not reproducible here. This is unlikely to be a TCC issue, especially since it works in Take Command, which is just running TCC in a hidden window.

It's more likely a problem with the font and/or code page you're using, which may have been changed (broken?) in Win 10 1803. What font / code page / language are you using?
 
Aug 19, 2009
16
2
#3
Easily reproducible here. Take the EN_US 1803 image (MLF_X21-79647.ISO) and create a virtual vanilla Windows from it. Select Danish for Time, Currency and Keyboard. Then Windows 10 Enterprise. And finally Denmark as region and keyboard once more. Install VMware Tools (or whatever is needed for your virtualbox). Apply all updates from Windows Update. When windows have finished updating, install tcmd-22.00.42.exe and create a shortcut for TCC on the desktop.

Open TCC enter command like "echo StringWith$Sign", execute the command and the mark, copy and paste. At the position of the dollar sign you'll get a blank, and when you execute the command, the result will be "StringWithSign" (without the blank).

HOWEVER: I have also tried to create a virtual vanilla Windows from same image but using US instead of DK for all prompts. And I have to admit that the problem does not exist on this machine. How do I convince Microsoft, that there is a locale problem in Windows 1803, but only on third party software?
 
Aug 19, 2009
16
2
#4
Just found a "workaround". On the Options tab on the shortcut properties, there's a "Use legacy console" option (see screenshot below). When I check that option, I can now paste strings with $ signs in it. Unchecking "Filter clipboard contents on paste" didn't do it.

This option is not available on the Take Command shortcut (because it's not a console app), and that's probably the reason why TCC works inside Take Command.

1527236766812.png
 
Last edited:
Aug 19, 2009
16
2
#5
Okay - "Use legacy console" seems to be a global option and not only an option for the shortcut being changed.
As Ubuntu Bash does not run with this option set, the workaround mentioned above does not solve my issue.

As Rex does not see this as a problem with TCC, I would appreciate any suggestions I could try.
 
Aug 19, 2009
16
2
#7
Well, don't use WSL, or don't use native console for WSL. There's always alternatives to everything.
I think I get your point, and then again I don't.
Dont' use WSL: Well, to me this have been one of the greatest enhancements to Windows for many years. So this is not an option.
Don't use native console for WSL: Please elaborate. How do I launch bash without using native console? Tried several different approaches without any luck.
 
Aug 23, 2010
277
2
#8
Cygwin. WSL is not an enhancement, it's a crutch. It does not integrate into Windows, it exists in a parallel universe.
MinTTY(the default Cygwin terminal) has WSL support.

This is just what I'm using myself, but I know there's more.