Fixed v15: VIEW - encoding and CSV issues

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
May 30, 2008
206
1
#1
I used VIEW with some ANSI (Windows 1252) files containing non-English characters like "åäö".

It seems that VIEW often fails to detect the correct encoding and opens the file in UTF-8 mode which garbles the input. (Adding or removing a single line can cause VIEW to choose the wrong one)

Is there some way to improve this, or maybe specify the encoding on the command line when opening the file?

Refreshing (F5) the display when the file is opened seem to make VIEW choose the right encoding though. Strange. Would be good to be able to skip that step though.


Another issue with VIEW is in CSV mode. It seems that displaying the gridlines cause my monitor (I turned off the speakers) to emit some low humming noise. Turning them off makes it go away. And vice versa.

I would assume this is monitor specific, or have someone else noticed the same? Changing the gridline color to something other than black makes the humming less loud or makes it go away entirely.

The problem is that hiding the gridlines is not remembered next time VIEW is started in CSV mode. You have to hide them again. Could this perhaps be changed? Or an option to specify if they are visible at startup added?

(Best would be if there were no humming noise at all, but I realize this might be hard to fix reliably. Many different monitors out there - mine is an Eizo FlexScan S2402W)
 

rconn

Administrator
Staff member
May 14, 2008
10,101
85
#2
I used VIEW with some ANSI (Windows 1252) files containing non-English characters like "åäö".

It seems that VIEW often fails to detect the correct encoding and opens the file in UTF-8 mode which garbles the input. (Adding or removing a single line can cause VIEW to choose the wrong one)
Is this specific to v15 or does the same thing happen in v14?

Another issue with VIEW is in CSV mode. It seems that displaying the gridlines cause my monitor (I turned off the speakers) to emit some low humming noise. Turning them off makes it go away. And vice versa.
I have no idea how that could happen; I'll let Charles answer that one.
 
May 30, 2008
206
1
#3
Is this specific to v15 or does the same thing happen in v14?
Unfortunately I don't know, I've been a bit slow to update the last few years and is still on v12, which has no VIEW command.

Seems like it should be easily fixable though since pressing F5 to refresh seems to resolve the issue.
 
#5
It seems that VIEW often fails to detect the correct encoding and opens the file in UTF-8 mode which garbles the input.
VIEW does not auto-detect code pages - it always use the system code page (by default).

If you would like to use Windows 1252 (eg, to display line drawing characters), you will have to set it manually by left-clicking on "ANS" in the bottom right of the status bar and then selecting "Character Encoding"->"Western European"->"Windows 1252".

Once the code page is changed, it will be used for all further files - until you change it again.
It is possible that VIEW may incorrectly identify the file as a UTF-8 file - in which case it doesn't use the code page to display the file.

Note that you cannot specify what code page to use on the command line.

Refreshing (F5) the display when the file is opened seem to make VIEW choose the right encoding though. Strange.
Can you send me a file which exhibits this problem? (v at fileviewer.com)
Another issue with VIEW is in CSV mode. It seems that displaying the gridlines cause my monitor (I turned off the speakers) to emit some low humming noise.
I really don't know what to say about this!

You cannot permanently disable the vertical grid lines - but you can the horizontal grid lines (click on the arrow next to the CSV Mode button on the toolbar and select "CSV Options"). Perhaps this may make a difference.

Also, if the files are being displayed on a white background, you may try changing it to something like a light gray to see if it makes a difference (select "Customize Colors" from the View menu).
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,385
39
Albuquerque, NM
prospero.unm.edu
#6
Another issue with VIEW is in CSV mode. It seems that displaying the gridlines cause my monitor (I turned off the speakers) to emit some low humming noise. Turning them off makes it go away. And vice versa.
I remember seeing -- er, hearing this on old CRT monitors: strongly contrasty horizontal lines can cause the tube to make an audible noise. But I've never encountered it on an LCD!
 
May 30, 2008
206
1
#7
Once the code page is changed, it will be used for all further files - until you change it again.
It is possible that VIEW may incorrectly identify the file as a UTF-8 file - in which case it doesn't use the code page to display the file.

Can you send me a file which exhibits this problem? (v at fileviewer.com)
Yes, it's misidentified as UTF-8.

I sent a mail with example files and a little more information.


I really don't know what to say about this!

You cannot permanently disable the vertical grid lines - but you can the horizontal grid lines (click on the arrow next to the CSV Mode button on the toolbar and select "CSV Options"). Perhaps this may make a difference.

Also, if the files are being displayed on a white background, you may try changing it to something like a light gray to see if it makes a difference (select "Customize Colors" from the View menu).
Thanks.

I noticed myself that changing the grid color to dark grey fixed the noise.

Turning the horizontal grid lines off also takes care of it, but I prefer to keep them visible. But dark-grey lines and light-grey background instead of black and white works very well so this is no longer a problem for me. Only until I had changed the default colors.

I remember seeing -- er, hearing this on old CRT monitors: strongly contrasty horizontal lines can cause the tube to make an audible noise. But I've never encountered it on an LCD!
Me neither until now (unless I never noticed before).

It's not really that loud a noise, similar to a fluorescent lamp, but maybe not quite as strong as that.