VIEW only works from command line

Nov 20, 2010
4
0
Hello, I am rediscovering TC and TCC after a while away. I think I must be doing something stupid. I can run VIEW from the tcc command line to view a file. But if I try to run it from Tools|View in the menu, a file selection dialog opens but nothing happens when clicking the Open button (or pressing Enter).

Tony
 
Nov 20, 2010
4
0
Yes. I can select using the mouse and double-clicking a filename or I can type the path and filename into the edit control, but still nothing happens when I confirm the dialog box.
 
Apr 18, 2014
299
9
TCC (x64) Version 28.00 Build 11 [28.00.11]
Microsoft Windows 10 Pro (21H1) [10.0.19043.1110]

I can reproduce this, I'm seeing the exact same thing as the OP.

To answer Rex's questions:
1. The dialog box closes after clicking on Open (or double clicking the filename).
2. The VIEW window doesn't open at all, it's not in the background.
3. The VIEW icon doesn't appear on the taskbar. Also, View doesn't appear in Task Manager.


If I type View Filename at the prompt, it works.
If I just type View at the prompt, the file selection dialog opens and it all works OK.

It's only when selecting View from the TCMD Tools menu that it fails, the selection dialog opens but View doesn't appear after selecting a file.

I've tried renaming my TCSTART and TCMD.INI files, it doesn't fix the issue.
 
Jun 2, 2008
357
4
It seems V.exe doesn't like the /tcmd:25 parameter (the TCMD version number?). Via Process Explorer, left is from the Tools menu and doesn't work; V.exe starts and then closes again right away. Right is from the command prompt using VIEW and does work.

1627835976946.png
 
May 20, 2008
11,380
98
Syracuse, NY, USA
Hmmm! I have

Code:
Command Line:   v /tcmd:25 V:\agenow.btm

and it works just fine. But ... [see new thread about TCMD hiding itself]
 
May 20, 2008
11,380
98
Syracuse, NY, USA
Aha! Now I see. If, at the TCC command line (in TCMD), I

Code:
v /tcmd:NN agenow.btm

where NN = 24, 25, 26, 27, or 28 it works, probably because I have all those installed. But if I use another number, it fails as many have described.
 
Nov 20, 2010
4
0
Thank you all for looking into this. If I understand correctly, the View option on the Tools menu must be running a command like the one Vincent posted earlier, but with an invalid NN option. I only have v28 installed. Is that right?
 
May 20, 2008
11,380
98
Syracuse, NY, USA
Thank you all for looking into this. If I understand correctly, the View option on the Tools menu must be running a command like the one Vincent posted earlier, but with an invalid NN option. I only have v28 installed. Is that right?
That seems to be the case. The string v /tcmd:25 which appears in TCMD.EXE (v28) has not been updated since v25.
 
Similar threads
Thread starter Title Forum Replies Date
vefatica VIEW ... remember the UTF-8 setting? Support 0
Alpengreis Documentation Minor issue in help file for view /E Support 1
vefatica VIEW wrap searches? Support 2
R Documentation Help Nit > bdebugger View Menu Support 0
Joe Caverly Why does TCCRT return VIEW as an internal command? Support 6
Joe Caverly Pipe into VIEW and search Support 12
vefatica VIEW ... CommandPrompt ... TC21 ... unregistered Support 6
vefatica Start VIEW with the toolbar showing? Support 5
rps How to? Piping to View /gb Support 1
vefatica VIEW ... remember no toolbar Support 0
E Fixed View command broken in version 21.0 build 22 Support 9
vefatica File Explorer ... remember view settings? Support 5
vefatica "View" settings still not remembered Support 10
vefatica TCMD ... remember View settings? Support 7
C View Print Wrap - please break at whitespace Support 3
C VIEW PRINT /Wrap doesn't work Support 0
C VIEW PRINT - Documentation corrected - Font size Support 8
C WAD VIEW print multiple files - switches fail Support 10
MickeyF TCC v16 crashes when I hit F1 to view help Support 9
R V19 - 'V' and 'View" Support 6
cgunhouse Crash on View/Folder Support 1
M View doesn't recognize Ctrl+End and Ctrl+Pos1 Support 2
vefatica Speaking of VIEW Support 18
nikbackm VIEW broken in v18 + Windows 10 Support 8
Alpengreis [Bug?] View (V) Prefs Error (TC 18.00.27 x64) Support 4
D Fixed Cut and paste in TC's file/folder view does not remove file Support 17
E View (internal command) does nothing now Support 3
vefatica VIEW and chars in 128-255 Support 4
MickeyF where to view the latest JPSoft newsletter? Support 0
Joe Caverly VIEW window in a TCC tab window problems Support 5
vefatica Fixed No text in List View! Support 4
D Folder/List view changed in v15 Support 8
D How to? V15.00.30 -(help!) - Floating view windows don't open Support 1
nikbackm Fixed v15: VIEW - encoding and CSV issues Support 9
T view command not working Support 5
S TCMD No List-View with Libraries? Support 5
M Sync folder/list view with command window? Support 2
C Fixed Starting editor from VIEW Support 9
J VIEW doesn't work again Support 16
A How to? Invoke View Clipboard from command line Support 8
S Fixed View and V do not work in new 13.04.52 x64 installation Support 11
jwblyth How to? Help will not Load in View (File Viewer)?? Support 4
M Folder View Freezing Support 10
Frank is the search-function in VIEW working? Support 2
H VIEW not "screen reader friendly: Support 7
J VIEW crash on redirected input and numbered bookmarks Support 6
gschizas View uses Windows-1252 codepage instead of System codepage Support 4
D view in tab and focus follows mouse Support 10
D View Help Keyboard Support 1
rconn 13.0.18 Test build for VIEW problem Support 23

Similar threads