1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows 7 oddness with the less pager

Discussion in 'Support' started by Magus, Jun 19, 2009.

  1. Magus

    Joined:
    Apr 30, 2009
    Messages:
    17
    Likes Received:
    0
    Hello,

    I'm testing Take Command 10.00.68 under Windows 7 RC1 and while things are mostly working I'm having trouble getting the GNU project Less pager to work inside a Take Command window.

    Run from within a Take Command prompt if I just type "less" I get the "Missing filename (""less --help" for help) prompt. If I type less --help the pager hangs. If I type less <filename> the pager hangs. I get the same behavior whether I run TCMD as an admin or not.

    I fired up SysInternals Process Monitor and didn't see anything that raised a flag but I'm still looking.

    The same build of both Less and Take Command works fine under Windows XP, Vista SP2 (both 32 and 64-bit)

    Less on Windows 7 works fine from a Windows 7 command prompt.

    Any thoughts?
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,854
    Likes Received:
    83
    Magus wrote:


    It's a Windows 7 bug (with alternate screen buffers). Hopefully MS will
    fix it before they release Win7. (If not, a lot of people are going to
    have to rewrite their apps.)

    Rex Conn
    JP Software
     
  3. Magus

    Joined:
    Apr 30, 2009
    Messages:
    17
    Likes Received:
    0
    I'm getting the same behavior with Windows 7 RTM. Will fixing this require changes to TCMD or Less? Any thoughts on the matter are much appreciated.

    Magus
     

Share This Page