1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Font displaying in italics in command window

Discussion in 'Support' started by thorsten, Jun 8, 2011.

  1. thorsten

    Joined:
    Aug 16, 2008
    Messages:
    120
    Likes Received:
    0
    Hi,

    I'm using the following settings to change the font in a command window to Dejavu Sans Mono size 18:

    [HKEY_CURRENT_USER\console]
    "facename"="DejaVu Sans Mono"
    "fontsize"=dword:00120000
    "fontfamily"=dword:00000036
    "fontweight"=dword:00000190

    This works on a lot of machines but on my current home machine, the font is displayed in italics (see attachment cmd-plain). The issue is only in the standard Windows console, not in Take Command or any other terminal I tried (see cmd-in-take-command).

    It occurs for any font size in Dejavu Sans Mono but for instance not with Lucida Console.

    Does anyone have an idea what might be the cause?
     

    Attached Files:

  2. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,277
    Likes Received:
    38
    I've seen similar issues with user-installed fonts. Windows's font support for console windows is screwy. Sometimes the console will seize upon the italic variant and insist on using it as the base font.

    This is a tedious pain -- sorry -- but I'm pretty sure it will fix your issue:

    * Uninstall all variants of the DejaVu font (base, italic, bold, etc.) and remove your registry tweaks. Reboot. Open a console window and verify that DejaVu no longer appears as an option in the Properties / Font tab.

    * Reinstall only the base font, not any bold or italic variants. Reinstall your registry tweak and reboot.

    * Open a console window and verify that the base DejaVu font is available and appears correctly. Once it's working in the console window, then you can reinstall the bold, italic, etc. font files.
     
  3. thorsten

    Joined:
    Aug 16, 2008
    Messages:
    120
    Likes Received:
    0
    That's a clever procedure and I'll report back if it worked. I'm glad I posted here (even with a not strictly TC issue) because there are some pretty bright people here replying.
     
  4. samintz

    samintz Scott Mintz

    Joined:
    May 20, 2008
    Messages:
    1,177
    Likes Received:
    11
    I'm so bright my father calls me sonny!
    :))
    -Scott

    thorsten <> wrote on 06/08/2011
    10:09:38 AM:


     
  5. thorsten

    Joined:
    Aug 16, 2008
    Messages:
    120
    Likes Received:
    0
    Charles, it worked and you saved me a lot of time with your simple solution.

    Thanks!
     
  6. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,277
    Likes Received:
    38
    Glad it helped.

    (You can do it the other way around, too, if you prefer italics in the console window.)
     

Share This Page