Help Not Working

May 2, 2013
13
0
I see several other threads about issues with the help system. My problem seems to be different from those: when I press F1, nothing seems to happen. In Process Explorer I can see tchelp.exe start and it uses about 12.5% CPU as long as I let it run - apparently it maxes out one logical processor on an i7 CPU - but the help window never appears. However, if I use Help from the top menu the window opens and tchelp.exe doesn't use more than about 1% CPU, so there is kind of a work-around but it isn't context-sensitive.

I am running version 20.11.36 x64 on Win 10 x64.
 
I have the exact same issue here on my home machine. I press F1 and the help window never appears. It's running according to process explorer and is using 12.5% of my CPU.

If I enter "Help Dir" for example, it comes right up.

On the menu bar pressing Help | Content it does not com up...same as F1. Help | Search comes right up. Help | Index does not...same as F1.

It's really odd. kapark, you are not alone and I wonder what's causing this. I don't have this issue on my notebook which uses the same INI and startup files.

TCC 20.11.36 x64 Windows 10 [Version 6.3.14393]
TCC Build 36 Windows 10 Build 14393

I'll need to do a bit more troubleshooting to try to narrow this down.

Michael
 
Hi Rex,

For me, it's TCC inside of TCMD. It is not behind anything.

If I look at the properties in Process Explorer and click "Bring to Front" I get a process explorer warning that says "No visible windows found for this process."

tchelp is running as I mentioned above.

If I go back to TCC (in a TCMD tab) and press F1 again, another tchelp.exe starts. I tested this about 5 times, and one of the times, after about 30 seconds, the help did appear. However, I now have 5 tchelp.exe's running and consuming 12% of CPU and 5G of ram each. There is certainly something wrong...at least for me.

Any suggestions on how to better troubleshoot this?

Thanks,

Michael
 
May 2, 2013
13
0
My experience is the same as Fross' -- TCMD tab window, another process appears each time I press F1, no windows for it on-screen or on the task bar.
 

ron

Aug 19, 2008
151
0
ok, I'll +1 here. Didn't really know what was happening initially. Kept hitting F1, got nothing. Later that day or next I was examining CPU usage and found 3 instances of the help consuming exactly 12% each. This was a TCMD admin tab window.

Just tried again now. F1, get a tchelp.exe process with no window consuming 14%. Killed the process.
Tried Help/Contents from the menu, help appeared right away. Closed that window, no issues.

20.00.25 - guess I'm behind...but I can get help from the menu with this version :-)
 
Same thing here, TCC 20.11.36.

Clicking on "Inhalt" or "Suchbegriffe": No help window, but an instance of tchelp.exe consuming 12,5 % CPU time.
<see 1.jpg>

1.JPG



Clicking on "Index": help window appears after a long delay (>5 seconds). Tchelp.exe is much bigger.
<see 2.jpg>

2.JPG
 
Ver 20..11.38:
TCHELP.EXE still starts erraticallyl. I've experimented with the various methods to start help: from the command line via F1, from the menu's 3 buttons.

The first time I start TCHELP there's usually no help window, and only a small stub in Task Manager. If I kill that and start TCHELP by the same method again the help window usually starts within 1 - 2 seconds.
If unkilled stubs remain in memory (Task Manager), each will consume 12,5 % CPU time, and the likelyhood od a successful start of a completed Help window falls quickly.
 
Aug 3, 2016
376
9
Netherlands
There were similar issues reported (*) on the Help+Manual forums (H+M is the tool used to build the TCHELP file ànd the engine used to display the .html files).
Help+Manual have issued an updated version to fix these. My (wild; still on 20.0.25) guess is, that Take Command isn't using this updated version.

(*) Read this some time ago; don't have the links anymore.
 

ron

Aug 19, 2008
151
0
Is there another way to open the help outside of TCMD? Then I could just leave it open. I've become spoiled by the quick access to relevant content when I need it. I tried running tchelp.exe but it just starts consuming 12% and does nothing else.

If I beat on it enough, it will eventually appear. Then I just kill any instances at 12% leaving the lone 0% one running. Minimize, resume day.

Rex - you are not seeing this behavior?
 

ron

Aug 19, 2008
151
0
Down side of my workaround - if you invoke help, it starts a new 12% instance. But the help window I already have opened does go to the proper topic.
 
Similar threads
Thread starter Title Forum Replies Date
C Add link to ewriter help to program group... Support 3
samintz How to? Search for %(command) in Help? Support 1
Joe Caverly Favorites in eWriter Help Support 6
Joe Caverly Quick Search in eWriter Help Support 1
vefatica Online help? Support 2
fishman@panix.com HELP!! I just updated to Version 28 and as usual I cannot make extended directory search work. Support 2
JohnQSmith New online help file wrong logo Support 7
Jay Sage Documentation Function @DRIVE Missing in Help Lists Support 0
Charles Dye More help nits Support 0
D Documentation Typo in COPY help Support 0
FreezerBurnt Help making a CMD and TCC compatible batch file Support 7
Joe Caverly Documentation COMMANDS in Version 27 help Support 8
K_Meinhard How to? Help window position Support 7
U Command help on file names Support 5
D Documentation Help "Startup" page does not describe global lists Support 0
vefatica Help disappears? Support 6
rchapmanitt Help Purchasing Support 2
Charles Dye Documentation Help nits: @ZIPFILECRC Support 0
C version help Support 3
C Documentation Help Nit. REN / RENAME Support 0
Dmitry L. Kobyakov Documentation Error in the Help: the WINDOW command Support 0
vefatica Help for @PID Support 2
vefatica Need help with XML Support 3
Alpengreis Documentation Minor issue in help file for view /E Support 1
R Documentation Advanced Directives Help Support 0
R Documentation Help Nit with SETP Support 0
R wmic command help Support 9
R Documentation Help Nit > bdebugger View Menu Support 0
R Documentation A couple of Help nits Support 0
R Documentation Help typo Support 1
MikeBaas How to? I need help with RD Support 5
R Documentation v25 Help Comments Support 1
Joe Caverly DIRectory Colorization in v25 Help File Support 0
vefatica Help nit Support 0
D error in help documentation? Support 0
Joe Caverly _EXPANSION in help file Support 0
K_Meinhard Help file error Support 1
Joe Caverly JOBMONITOR in Help File Support 1
A Documentation [Help file] OPTION "//" synopsis formatting issue Support 0
D The local HELP viewer... Support 0
Chen Touboul Overtyping issue - i press the Insert key, help till press enter for new line in TCC Support 2
C Documentation Help nix ZIP /M Support 0
Joe Caverly v24 Help File - DATEMONITOR Support 1
Joe Caverly 7zip command links to zip help Support 0
K_Meinhard Help problems Support 3
Charles Dye Documentation Help Nits Forever: Checksum functions Support 0
Joe Caverly SAVECONSOLE in Help File Support 0
Joe Caverly CMDebug v23 Help: /FEEDBACK /UPDATE Support 0
Joe Caverly CMDebug v23 Help: Link to MOUNTVHD goes to MOUNTISO in UNMOUNTVHD Support 0
Joe Caverly Help not launching in CMDebug v23.00.14 x64 Support 1

Similar threads