Why doesn't this @Field function work?

May 24, 2010
855
0
Northlake, Il
The best way to start is probably to show a complete TCC session:
Code:
[Z:\Level 1\Level 2\Level 3\Level 4\Level 5\Level 6]fdir
12/24/2012  10:57              0  ABC.SEXT
12/24/2012  10:57              0  DEF.LEXTENSION
12/24/2012  11:00              0  GHI.BEXTEN
 
[Z:\Level 1\Level 2\Level 3\Level 4\Level 5\Level 6]echo %Sep
"\"
 
[Z:\Level 1\Level 2\Level 3\Level 4\Level 5\Level 6]PDir "::(SEXT|LEXTENSION)" /S
/A-D /(~@Field[%Sep,-2,*]~ @FileName[*])
~~ ABC.SEXT
~~ DEF.LEXTENSION
 
[Z:\Level 1\Level 2\Level 3\Level 4\Level 5\Level 6]
The first line shows the current directory, the second through fourth lines what's in the current directory. The sixth line shows the contents of a variable named "Sep". The seventh line is a PDir command with an @Field function enclosed in tildes with the field separator being "%Sep" (a backslash, of course), the second field of the full path up (should be "Level 5" me thinks) and the current full file name being indicated by the "*", of course.

As you can see above, what comes out between the tildes is nothing, a null string.

Where am I going wrong in this apparently simple task?

An update:

In experimenting while typing this posting, I changed the @Field function to "@Field[%Sep,-2,%%@Full[*]]", and this worked. The question is, of course, why I need the "@Full" function given that the asterisk is, as I understand it, already the full path to the file (and some simple experiments confirm that). Since at this point I have the problem solved with a mysterious (to me!) workaround, the answer to this question is just for my edification/education.
 
Similar threads
Thread starter Title Forum Replies Date
vefatica Setting array variable ignores leading spaces (and @execarray doesn't) Support 4
MickeyF Why doesn't my python program get executed without specifying its path? Support 2
gworley Virtual network drive filename completion doesn’t get directories Support 0
vefatica Win10's ANSI doesn't like 2>NUL Support 10
vefatica Win10, alternative screen buffer, cursor doesn't blink Support 11
M Trying to use ffind with a @file.lst doesn't work Support 4
Charles Dye Ctrl-Shift-Up doesn't update directory history Support 1
gschizas Take Command (Environment) doesn't show v2 ANSI colors Support 30
vefatica Fixed JOBS /K doesn't work Support 2
E Fixed SHRALIAS doesn't work / SHRALIAS.EXE is missing in v20.11.35 Support 2
D WAD Reboot doesn't shutdown or restart Support 13
M Documentation Q.Search doesn't support selection? Support 1
R Fixed 7ZIP Compression Method Option Doesn't Work Support 1
T Regex engine doesn't recognize native DOS line endings Support 2
E Fixed DEDUPE doesn't handle filenames with whitespace properly when symlinking Support 1
D Docking doesn't persist Support 5
E WAD DESCRIBE under TCC 19 doesn't work with diacritics Support 14
C VIEW PRINT /Wrap doesn't work Support 0
D CD doesn't always find everything Support 8
M View doesn't recognize Ctrl+End and Ctrl+Pos1 Support 2
M Ctrl-End doesn't work. DelToEnd is not executed Support 13
B Fixed FFIND doesn't find last character in file without CR/LF at EOF Support 1
G .BTM association doesn't work anymore Support 1
jadaml Documentation Is COPY realy doesn't work for any HTTP and FTP? Support 3
D do /s doesn't recurse Support 1
D WAD Alt-Left doesn't work, but Alt-Shift-Left does Support 1
I How to? Bat Works but BTM Doesn't Support 6
B %@lines doesn't count last line without cr/lf at eof Support 1
williamleara WAD ribbon doesn't remember expand/collapse setting Support 3
vefatica Why doesn't "IDE %_ININAME" work? Support 4
M How to? /Elevated doesn't do it for me... Support 8
D Why doesn't ffind find directory? Support 3
Phileosophos TPIPE doesn't work at all with v16 Support 3
D ejectmedia doesn't work in v16 Support 2
Phileosophos Fixed Register for all users doesn't register for all users Support 10
T "Checking for a newer version" doesn't complete Support 18
vefatica Doesn't IDE auto-indent? Support 3
C FFind /w works but FFind /= doesn't? Support 2
noahcoad WAD cmd.exe under tcc doesn't find apps Support 4
vefatica Fixed TPIPE doesn't /SPLIT at characters Support 0
M Site doesn't recognise cookies Support 0
D What's New doesn't mention copydir movedir Support 25
D TIMER OFF doesn't work Support 21
M @Files sure doesn't work the way I would have assumed it did! Support 4
M Why doesn't this work? Support 12
vefatica ON BREAK doesn't always work Support 23
K_Meinhard Fixed ? TCMD 14.02 doesn't start here Support 4
Stefano Piccardi 14.01.33 unset doesn't complain about undefined variables Support 8
J VIEW doesn't work again Support 16
samintz Fixed CASEALL doesn't work Support 1

Similar threads