By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

TCMD 31 installs but doesn't run...

I was a long-time user of 4DOS, 4NT, and 4OS2 and recently decided to try Take Command again, so I paid for and downloaded TCMD 31. It all seemed to install correctly, and TCC runs fine. But when I run TCMD, it shows as a Background Process in Task Manager for a while (seconds to a few minutes), then disappears.
I uninstalled and went through the registry removing any sign of Take Command, TCMD, TCC, JPSoft, and JP Software, then restarted my PC to make sure the registry changes took. On Rex Conn's suggestion, I turned off my antivirus, downloaded a new version of the Take Command installer and installed it again.
Same again.
I tried running with the /N command-line switch. Same again.
Does anybody have any ideas about what might be happening and, more importantly, how I get a workable installation?
What is your operating system?

Did you check the event log (Windows folder; system and application logs) for any clues?

Does WerSvc (Windows Error Reporting Service) start when TCMD fails? That could also give a clue.
Thanks, that looks useful information to gather - but maybe not to me :confused:

Edition Windows 11 Home
Version 22H2
Installed on ‎27/‎09/‎2022
OS build 22621.2283
Experience Windows Feature Experience Pack 1000.22662.1000.0

I've looked in the event log and didn't see anything, but to be honest I wasn't sure exactly where to look.

I stopped WerSvc and retried. Checked services after TC failed and WerSvc was running.

Now looking in the logs immediately after the crash, I see this:
Faulting application name: tcmd.exe, version:, time stamp: 0x651c0fb4
Faulting module name: ntdll.dll, version: 10.0.22621.2215, time stamp: 0x7a9f67f2
Exception code: 0xc0000005
Fault offset: 0x0000000000033a50
Faulting process ID: 0x0xDD24
Faulting application start time: 0x0x1DA0357D3520AC8
Faulting application path: C:\Program Files\JPSoft\TCMD31\tcmd.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report ID: d4090abb-6538-4952-b71e-72f3b87c1bd0
Faulting package full name:
Faulting package-relative application ID:

That looks like a big clue in the Bold line. I've attached the report.wer file (renamed as Report.txt to be able to attach - it's a text file anyway) which expands on the above.

There was no "program has stopped working" dialog.


  • Report.txt
    17.8 KB · Views: 62
Last edited:
Yes, that does seem to be useful information, also the "Fault offset" line. I'm not knowledgeable enough to investigate further but I'm confident that Rex will do so.

In the event log, I'd look here (in "System" and "Application") but I doubt there would be more information than that which you have already supplied.


Seems an access violation somehow.

Have you that too after start TCMD with admin rights?

Have you 0patch in use? See here:

Thanks, everyone, looks like it's fixed. Read on for details.


Seems an access violation somehow.

Have you that too after start TCMD with admin rights?
I did try that, it didn't work

Have you 0patch in use? See here:

That linked post was the clue. I disabled everything that I thought might possibly be interfering. That amounted to:
  • Spiceworks Agent Shell
  • 0patch
  • Lookeen
  • PowerToys
  • WindowFX
  • Glary Utilities
  • Rainmeter (though this isn't being used)
Now TCMD launches fine. I plan to reinstall things individually and see what effect this has. I'll post my findings, but don't hold your breath as I plan to restart after each one so it depends on my time.
I ruled out my antivirus (Malwarebytes) earlier. I've now reinstalled all but 0patch (suspected in the post linked to above) and Rainmeter (as I no longer use it anyway). TCMD now launches perfectly OK. My money is on 0patch as injecting code (to deal with known patches) is exactly what it is supposed to do.
So I am now a happy bunny and can start rebuilding my .btm collection and personalised set up.
Latest update:

I followed the procedure in the post that @Joe Caverly linked to, changed for TCMD.EXE not Firefox, and reinstalled 0patch. So far all is good. 0patch hasn't finished its analysis yet (this can take some time), so when it's stable I'll try again.
After a few more days everything is still working. My suspicion is that 0patch was actually doing something during the installation of TCMD rather than during normal running, but I don't feel strongly enough about it to investigate further.

Similar threads