Latest ISO8601 plugin?

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
I am having trouble getting the very latest version of the ISO8601 plugin. On the plugins page at I see that the latest version is 1.4.1 from May 21 but when I download the file I get 1.4.0 from 4/25. I've cleared my browser cache and even tried downloading on another machine but continue to get the older version. Charles, could you please look into this?