How to? Multi-plugin installation errors, Re: FedUtils8

Aug 8, 2010
Everything I've tried to get any/all FedUtils8.dll plugins loaded results in "FedUtils8.dll is not a valid Win32 application". This was also true with "9", but I tested with "8" because there was more copy/paste documentation about it. My other plugins (Chill-x64.dll, FixNames-x64.dll, Say-x64.dll) all work, but all I had to do was put them in the plugins directory.

I was going to add this to the thread "FedUtils installation, simplified" Discussion in 'Plugins' started by epement, Mar 2, 2012, but I think this issue is more about Multi-plugins in general and my lack of experience with them. That thread was the source of my unsuccesful attempts to load any/all fedutils8 plugins. I think there's a START.BTM/TC/ini setting I don't know about.

I've spent at least two hours over the last three days trying to get this to work. I read the JPSoft "Help - Plugins". I read all of the "fedutils" forum entries. I went thru the FedUtils Help, and, Yes, it was confusing - PARTICULARLY in regards to "fedpluginloader.dll" which only contributed error messages whenever/wherever I had it in a script or directory. That dll was not part of the last "fromano, Mar 2, 2012, here's how to do it:", so I left it out. I took "here's how to do it:" to be absolute and complete.

##### When I run this script in "E:\ERoot"
:: E:\ERoot\FedUtilsWont.btm
pause At Line 02

set "CONFIG_DIR=C:\Users\Administrator\AppData\Local\JPSoft"
set "PLUGINS=C:\Program Files\JPSoft\TCMD13x64\PlugIns"

pause ^NAfter sets

:: plugin /U FedUtils8
plugin /L E:\ERoot\FedUtils8.dll

pause ^NBefore Exit

##### I get:
At Line 02

After sets
TCC: (Sys) E:\ERoot\FedUtilsWont.btm [12] E:\ERoot\FedUtils8.dll is not a valid Win32 application.

Before Exit

##### If I comment "set FEDUTILS8_LOAD=DATEDIFF", I get the same.

##### If I UNcomment ":: plugin /U FedUtils8", I get:
At Line 02

After sets
TCC: (Sys) E:\ERoot\FedUtilsWont.btm [11] The system cannot find the file specified.
TCC: (Sys) E:\ERoot\FedUtilsWont.btm [12] E:\ERoot\FedUtils8.dll is not a valid Win32 application.

Before Exit

##### If I then put "FedUtils8.dll" in "C:\Program Files\JPSoft\TCMD13x64\PlugIns" so it can be found, I get:
TCC: (Sys) C:\Program Files\JPSoft\TCMD13x64\PlugIns\FedUtils8.dll is not a valid Win32 application.
At Line 02

After sets
TCC: (Sys) E:\ERoot\FedUtilsWont.btm [11] The system cannot find the file specified.
TCC: (Sys) E:\ERoot\FedUtilsWont.btm [12] E:\ERoot\FedUtils8.dll is not a valid Win32 application.

Before Exit


If I put the "load /L" command in START.BTM and insert "pause" and "exit" at the start of the script, I get the same "not a valid" message referenced to that line in START.BTM.

Otherwise, the particulars are;
- 1.5-year old HP Pavilion P7-1174 Desktop PC with Windows 7 Pro
- TCC 13.04.63 x64 Windows 7 [Version 6.1.7601]
- FedUtils8.dll 581.0 k 08/19/2007 22:42
- FedUtils8.dll CRC32 41734DBD
- The only plugin setting I have in START.BTM (that I can find) is "set /e /u noloadmsg=1"
Aug 8, 2010
Ohhhhhhh! The relatively recent threads about FedUtils led me to believe it was 64-bit compatible. Thanks for posting.
Aug 8, 2010
HEY!! Now that's a GREAT idea!! What, me - self-serving??

Seriously, I'll be happy to contribute what I can. I have some IT System Analysis experience, but no Software Development. I'll be happy to do unit/beta testing, as long I'm confident the testing won't break my one - and only - Desktop PC.

FedUtil is a really sweet suite of plugins. My presumption that it was already 64-bit was because the all-encompassing versatility of FedUtil must, surely, be state-of-the-art. Making it so would not be a small endeavor.
May 20, 2008
Syracuse, NY, USA
If someone were willing to convert FEDUTILS to 64b, would you be willing to provide the source code? Would not be me, I do not have a 64-bit development environment.
I'd do it if it is "C/C++". I suppose Visual Studio would tell me what, if anything, needs changing.
May 20, 2008
It's Delphi, haven't sprung for the price of their new compiler (that supports 64-bit), because these days I'm only working in Ruby at work and home
Similar threads
Thread starter Title Forum Replies Date
Joe Caverly 64-bit Plugin development using PureBasic Plugins 8
R New Plugin Plugins 0
Alpengreis elevated plugin questions Plugins 3
fpefpe utf-8 support in sdk/plugin api Plugins 4
S How to? Can @DU function in 4Utils64 plugin somehow cater for dirs with spaces? Plugins 3
vefatica Plugin access to arrays? Plugins 4
vefatica How big is a plugin's parameter buffer? Plugins 5
C @knownpath plugin Plugins 0
Charles Dye Updated OSD plugin Plugins 0
Joe Caverly C# plugin framework for JPSoft's TCC Plugins 0
dcantor Help for newest version of TEXTUTILS plugin Plugins 10
dcantor UISTUFF plugin missing help topic Plugins 12
M How to? Use SafeChars plugin... Plugins 2
dcantor Error in SAFECHARS plugin v 1.9.0 Plugins 2
dcantor Request for documentation for ISO8601 plugin Plugins 4
vefatica Possible with a plugin? Plugins 6
dcantor Inconsistency between textutils plugin and wrap utility Plugins 2
M (Stupid?) Problem with 64-bit 4Utils plugin... Plugins 3
H Latest ISO8601 plugin? Plugins 1
Charles Dye New plugin: QKeys Plugins 34
S Plugin to quickly locate all files hard linked together Plugins 5
S Documentation Plugin everything.dll Plugins 5
vefatica Plugin -> thread -> Command() -> Ctrl-C? Plugins 20
Charles Dye A weirdoid plugin question Plugins 6
M SafeChars plugin misbehaving... Plugins 3
M A weird error re a plugin... Plugins 0
vefatica Plugin dilemma Plugins 2
fpefpe Documentation Plugin API/SDK Plugins 3
C Looking for Vince's old 4UTILS plugin for TCMD v8 Plugins 1
S DESKTOP plugin - anyone ? Plugins 0
C How to? a plugin to sort Outlook Express "rules" Plugins 0
M ISO Plugin: Yes, it's wonderful, but it could be yet more wonderful... Plugins 7
M The ISO plugin is wonderful, but it lacks a little something... Plugins 22
Charles Dye Beta plugin: HidePasswords Plugins 3
M ISO8601 Plugin not "reporting" errors to TCC... Plugins 4
Frank 4console plugin Plugins 4
S WAD ISO8601 Plugin Plugins 15
Joe Caverly Plugin and 64-bit TCC Plugins 3
C Problem with FixNames plugin Plugins 9
dcantor Suggestion and request for DBF plugin Plugins 6
dcantor Suggestion for SafeChars plugin Plugins 7
M Charles, I just installed the "new" SafeChars plugin, ... Plugins 5
M A problem with the SafeChars Plugin... Plugins 30
S WHICHWIN (sysutils plugin) Plugins 13
M A (presumbly pretty simple) SafeChars plugin request... Plugins 2
M A "SafeChars" plugin request... Plugins 2
S ISO 8601 plugin enhancement Plugins 6
D UNKNOWN_CMD in Plugin Plugins 13
C Looking for isemailaddress[string] plugin Plugins 7
S ISO8601 Plugin Plugins 4

Similar threads