By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

unzip files with umlauts

im using the integrated unzip function from TCC, but contains the Zip-Source-File any Files with German Umlauts so show the Extraction Process, but dont extract this Files to Target and finished
UNZIP command with %_unzip_errors=0.
I have tested this with lastest TCC Version and have always the same Result. No Files with Umlauts are extracted. Listed: yes, Extracted: no.
Extenal ZIP Programs can this ZIP Files extract.

Commandline Listing Test.zip with external 7z.exe:
Date Time Attr Size Compressed Name
------------------- ----- ------------ ------------ ------------------------
2023-07-03 14:55:01 ....A 0 0 Test_File_with_Umlauts_ÄÖÜ_äöü.txt
------------------- ----- ------------ ------------ ------------------------
2023-07-03 14:55:01 0 0 1 files

Commandline Listing Test.zip with internal TCC UNZIP:
023-07-03 12:55 1 100% Test_File_with_Umlauts_���_���.txt

Commandline Extract Test.zip with internal TCC UNZIP:
unzip /e Test.zip d:\work
=> D:\work\Test_File_with_Umlauts_���_���.txt

(no File is real extracted, %_unzip_errors=0 %_unzip_files=0, ERRORLEVEL=0)

All is OK, but no File is extracted ....
It seems OK here.

v:\> echo Hello world. > ẍ.txt

v:\> type ẍ.txt
Hello world.

v:\> zip umlaut.zip ẍ.txt
<= V:\ẍ.txt

v:\> unzip /v umlaut.zip
2023-07-03  19:11             14  -14%  ẍ.txt

v:\> unzip /e umlaut.zip v:\extracted\
=> V:\extracted\ẍ.txt

v:\> d extracted\
2023-07-03  15:11              14  ẍ.txt
What exactly is the character shown as � in your post?

I used character 7821 (0x1E8D), Latin Small Letter X With Diaeresis.

Note that I can paste it here: Test_File_with_Umlauts_ẍ_ẍ_ẍẍ.txt
Create in Windows a Test-File with Umlauts (Sample: Test_File_with_Umlauts_ÄÖÜ_äöü.txt) and ZIP this File with a Windows ZIP Program (WinZIP, WinRAR, 7Zip) to a Archive with Name Test.ZIP. Now List this Archiv in TCC and show the Umlauts in Filename are �.
Thats a historical Problem with Codepages in Windows and DOS/TCC (OEM850). But TCC UNZIP Listing the File in Archive,
but extract this never and Return with RC=0.
OK. Now I see what you mean. I have this file.

2023-07-04  11:06              14  Test_File_with_Umlauts_ÄÖÜ_äöü.txt

I zipped it thus.

d:\7zip\7z.exe a zipped.zip Test_File_with_Umlauts_ÄÖÜ_äöü.txt

1. TCC's UNZIP does not print the name correctly.

v:\> unzip /v zipped.zip
2023-07-04  15:06             14    0%  Test_File_with_Umlauts_���_���.txt

2. And UNZIP does not unzip it although it claims to have done so.

v:\> unzip /e zipped.zip v:\extracted\
=> V:\extracted\Test_File_with_Umlauts_���_���.txt

v:\> dir /k /m /h v:\extracted\
TCC: (Sys) The system cannot find the file specified.

The same thing happens if I create a zipped folder with Explorer, drag/drop the test file to it, and try to UNZIP it with TCC.

I suspect that Rex will fix this if he can.
I tried (and failed) to fix this with 7zip's -scs option. One anomaly is that, in 7-zip's help (v21.07), a(Add) is listed among the commands that can be used with the -scs switch, but -scs is not listed among the switches that can be used with the a(Add) command.

Similar threads