Unzip /F and /U not working in V12

If I use UNZIP with either the /U or /F switches, no files are extracted
even though the zip file contains many files that are newer than those in
the target directory. This is with 12.00.26 under XP.

--
Howard
 
May 20, 2008
11,400
99
Syracuse, NY, USA
On Thu, 02 Sep 2010 22:01:02 -0400, Howard Goldstein <>
wrote:

|If I use UNZIP with either the /U or /F switches, no files are extracted
|even though the zip file contains many files that are newer than those in
|the target directory. This is with 12.00.26 under XP.

I can reproduce that.

And UNZIP /C doesn't work very well:

Code:
v:\ziptest> type test1.txt
foo

v:\ziptest> zip zipfile.zip *.txt
<= V:\ziptest\test1.txt
<= V:\ziptest\test2.txt

v:\ziptest> unzip /c zipfile.zip test1.txt
??
?

It's the same for "zip /c".

Code:
v:\ziptest> zip /c zipfile.zip test1.txt
??

The help says "ZIP /C" and "UNZIP /C" do the same thing ... is that so?

And ...

Is there a way to **uncontitionally** put a file into a zip archive, replacing
it if necessary (and regardless of timestamp)? It's the default behavior of my
ZIP.EXE.

v:\ziptest> zip zipfile.zip test1.txt
<= V:\ziptest\test1.txt
TCC: Error in archive V:\ziptest\zipfile.zip :
File already exists in the archive. "V:\ziptest\test1.txt"

v:\ziptest> u:\zip.exe zipfile.zip test1.txt
updating: test1.txt (172 bytes security) (stored 0%)
 
Similar threads
Thread starter Title Forum Replies Date
S UNZIP all archives to separate subdirectory Support 10
C unzip problems Support 2
D unzip fails to find valid license Support 3
Jay Sage Fixed Mistake in Command Dialog for UNZIP Support 0
fishman@panix.com Inadequate HELP for UNZIP command. Support 3
H 12.10 UNZIP ignores destination path spec Support 2
Phileosophos unzip not using specified path Support 5
D unzip problem in tcmd 12 b 36 Support 3
nikbackm unzip issues in v12 Support 12
fishman@panix.com Unzip in 12.0 Support 1
H UNZIP /F and /U still not right 12.0.27 Support 0
H V12 UNZIP very slow under certain circumstances Support 3
H UNZIP /U issue Support 0
Phileosophos Unzip doesn't extract to specified output folder Support 5
D unzip /d in directory with space in name Support 1
fishman@panix.com Problem with unzip Support 4
H ZIP/UNZIP issues Support 4
Joe Caverly ZIP, UNZIP v11 Beta Support 6
twaterloo FolderMonitor for the 1st time not working Support 5
Tim Rowe NTFS Descriptions not working Support 13
J Batcomp still not working for me in TCMD27 Support 1
M Oracle batch OPatch.bat.bat not working in TCC but correctly in CMD Support 5
M Why did BEEP just quit working? Support 12
cgunhouse SETLOCAL not working in BDEBUGGER Support 9
nickles ANSI Colors Windows 7 no longer working Support 6
K ANSI Not Working Support 8
thorntonpg option /u not working The directory name is invalid Support 5
Charles Dye Is the "File Associations" installer dialog working? Support 4
H @ceiling @floor @int not working version 21.01.63 Support 9
K Command Line Selection Not Working Support 12
G Extended directory search not working Support 4
B %@fileseek is not working ? Support 2
C "Take Command has stopped working" Support 1
H New command not working well in Windows 7 Support 4
C "TakeCommand has stopped working" Support 3
N ping DNS lookup not working Support 1
N Updater/silentall not working? Support 1
K Help Not Working Support 11
R Fixed set /r has stopped working in build 35 Support 4
U Keys and IDX not working Support 11
Jesse Heines How to? Everything Tool Not Working After Version 20 Installation Support 8
WavSlave Fixed LIST /U not working in TCC v19 Support 5
Jay Sage %_selected no longer working Support 15
S iftp copying pgp files from ftp is not working Support 11
fishman@panix.com Extended Directory Searches are not working for me in CDD Support 9
J How to set working directory Support 10
vefatica Fixed LEAVE N not working Support 7
P %date5 not working Support 6
M WAD PDir not working correctly... Support 5
Detlef Fixed ParameterChar in TCMD.INI no longer working Support 35

Similar threads