Directory Alias Access to FTP Servers

Jun 2, 2008
312
1
Newton, MA
I have the following directory alias defined:

ftpsage:=ftp://sagefamily.org:password@ftp.tigertech.net/

When I run the command "DIR ftpsage:" in TCMD version 19, it works fine, and I see all the files and folders on the server. When I run it in version 25, I get an error message:

The system cannot find the drive specified.
"/ftp:sagefamily.org:kB6FTfn6n65V@ftp.tigertech.net\*"

What do I have configured incorrectly? I've gone through all the screens and everything seemed to be set the same in both versions. (Of course, this is not the only thing that works differently in version 25 and required a lot of work to restore. It's the main reason why I don't upgrade very often.
 
May 20, 2008
10,573
78
Syracuse, NY, USA
Here, it's OK in v24 and fails as Jay said in v25. Here's v25.

Code:
v:\> dir ftp://vefatica.net/

 Directory of  ftp://vefatica.net/*

2017-10-18  00:00         <DIR>    4plugins
2017-07-21  00:00         <DIR>    pmaddons
2014-08-08  00:00       3,657,325  arnex4.JPG
2012-07-17  00:00         109,138  MercOnSvcDesk.png
2018-10-19  00:00          24,775  ppro.docx
2018-12-06  00:00          65,746  pset64.zip
2018-05-28  00:00          25,908  shelltest.zip
           3,882,892 bytes in 5 files and 2 dirs

v:\> alias myftp: ftp://vefatica.net/

v:\> dir myftp:

TCC: (Sys) The system cannot find the drive specified.
 "/ftp:vefatica.net/"
 

rconn

Administrator
Staff member
May 14, 2008
11,910
133
This actually never actually worked. In v24 & earlier there were 2 bugs; the second one would abort the filename processing and try to treat the ftp name as a Netware name. Which accidentally succeeded because you had a full name that didn't need expansion.

V25 fixed the second bug and exposed the first. I have fixed the first one for build 17.