Directory Alias Access to FTP Servers

Jun 2, 2008
376
2
Newton, MA
I have the following directory alias defined:

ftpsage:=ftp://sagefamily.org:password@ftp.tigertech.net/

When I run the command "DIR ftpsage:" in TCMD version 19, it works fine, and I see all the files and folders on the server. When I run it in version 25, I get an error message:

The system cannot find the drive specified.
"/ftp:sagefamily.org:kB6FTfn6n65V@ftp.tigertech.net\*"

What do I have configured incorrectly? I've gone through all the screens and everything seemed to be set the same in both versions. (Of course, this is not the only thing that works differently in version 25 and required a lot of work to restore. It's the main reason why I don't upgrade very often.
 
May 20, 2008
11,400
99
Syracuse, NY, USA
Here, it's OK in v24 and fails as Jay said in v25. Here's v25.

Code:
v:\> dir ftp://vefatica.net/

 Directory of  ftp://vefatica.net/*

2017-10-18  00:00         <DIR>    4plugins
2017-07-21  00:00         <DIR>    pmaddons
2014-08-08  00:00       3,657,325  arnex4.JPG
2012-07-17  00:00         109,138  MercOnSvcDesk.png
2018-10-19  00:00          24,775  ppro.docx
2018-12-06  00:00          65,746  pset64.zip
2018-05-28  00:00          25,908  shelltest.zip
           3,882,892 bytes in 5 files and 2 dirs

v:\> alias myftp: ftp://vefatica.net/

v:\> dir myftp:

TCC: (Sys) The system cannot find the drive specified.
 "/ftp:vefatica.net/"
 

rconn

Administrator
Staff member
May 14, 2008
12,344
149
This actually never actually worked. In v24 & earlier there were 2 bugs; the second one would abort the filename processing and try to treat the ftp name as a Netware name. Which accidentally succeeded because you had a full name that didn't need expansion.

V25 fixed the second bug and exposed the first. I have fixed the first one for build 17.
 
Similar threads
Thread starter Title Forum Replies Date
Joe Caverly Using a Directory Alias with @iniwrite fails Support 14
cgunhouse Directory Alias Issue Support 7
J Initialise; Alias; Extended directory search Support 2
P directory alias bug? Support 4
fishman@panix.com HELP!! I just updated to Version 28 and as usual I cannot make extended directory search work. Support 2
D How to use multi-line DO to loop through first level directory names Support 5
D ParentDirectory does not update directory history Support 6
samintz CDD to non-existent directory hangs Support 2
gworley rd (Remove Directory) gives interesting error: Support 2
D Directory History Window with wildcard search Support 3
D How to? Skip removing directory (RMDIR) without error message Support 2
gentzel Directory stack empty when running TCEXIT? Support 9
vefatica Disable extended directory searches (completely)? Support 8
M WAD "Pictures" directory is empty in TCC but not in CMD or Explorer Support 4
G Local Directory Corruption Support 11
Joe Caverly DIRectory Colorization in v25 Help File Support 0
K copy changing destination current directory Support 1
thorntonpg option /u not working The directory name is invalid Support 5
J built in file explorer - how do i go back "up" the directory? Support 2
vefatica Extended directory searches? Support 6
A Installer /extract: extracts into current directory if target not exists Support 12
Charles Dye Ctrl-Shift-Up doesn't update directory history Support 1
G Extended directory search not working Support 4
CWBillow Editing in the root directory of windows 10 Support 6
D Directory stack empty Support 1
J directory or folder to start in Support 2
M How to unlock a directory Support 1
Alpengreis Fixed TCMD FileExplorer Start-Directory problem Support 4
R V19 - At startup, TCC save directory in the directory history list Support 2
C Touch command — I Need to touch matching files in another directory. Support 5
nickles Move takecommand.18.0.key location to installation directory Support 4
fishman@panix.com Extended Directory Searches are not working for me in CDD Support 9
vefatica TCMD's current directory? Support 4
J How to set working directory Support 10
nickles How to? Follow a JUNCTION type directory link Support 9
Steve Pitts WAD Strange output from DEL of a non-existent directory Support 7
I tab completion with directory commands Support 7
vefatica Start-up directory for new tabs? Support 7
cgunhouse Problem with CALL and Directory Aliases in V17 Support 9
vefatica FFIND /S, find directory with specified name? Support 7
David Wilbanks How to make new tab open in same directory as previous tab? Support 4
H WAD Wild Card in Directory @shfolder[25] acting differently Support 3
M How to? List path getting short file and directory names... Support 10
A How to? Can't change directory ("cd") into system hidden files Support 13
mfarah How to? So I want a custom directory for the plugins... Support 16
D Why doesn't ffind find directory? Support 3
T dir /h error in empty directory Support 22
S directory history locks up TCC Support 3
B Why Does @GETDIR Repeat Selected Directory Name In Returned Value Support 7
ed neff How to? exit TCC/Take Command to a new directory Support 10

Similar threads