Editing in the root directory of windows 10

#1
I get that it is a security issue and therefore not set as default, but is there a way to allow editing of files in the root folder / directory? I cannot even do it to a text file. I have to copy it to my desktop, edit and then copy it back.

No other way?

Regards,
Chuck Billow
 
#2
There isn't anything particularly special about the root directory, you just need administrative credentials.

Since we're talking about TCMD/TCC here, start TCC elevated and you can then use any tools in TCC, or launch Notepad or whatever else.

You can't right click and launch editors elevated, but if you launch an editor elevated you can then modify files in the root.
 
Jun 2, 2008
300
1
#3
Another thing you can do is edit the properties of your editor/TCMD/TCC shortcut or .exe file itself and set it to always run as an Administrator.
 
#5
Dave I just tried from both running Explorer (shortcut) as Admin, and also having the Advanced Properties to As Admin. I still cannot create a file in the root folder/directory. I have to create it elsewhere and then move or copy it over.
 
Jun 2, 2008
300
1
#6
Getting Explorer to run as Admin is tricky because it's already running to give you your desktop, so it simply opens a new window rather than a new elevated process. You could disable User Account Control (UAC) like I do and get the full list of things to create in the right click->New menu, but that's advised against.
 
#7
You might be able to use ICACLS.EXE (elevated) on the files you want to be able to modify. On Windows 7, I use this command in the firewall's log directory to get access to the log.
[cpde] icacls pfirewall.log vefatica:F[/code]
"vefatica" is my username. "F" means "full" control.