How to? tty support in V25?

Sep 1, 2008
23
0
So it looks like I haven't upgrade since V23...

I noticed today if I use windows built in OpenSSH client and it wants to go interactive for auth - it does not work in V23.

ssh -v somerealhost-needing-interactive-auth.domain

Code:
debug1: Next authentication method: keyboard-interactive
debug1: read_passphrase: can't open /dev/tty: No such file or directory

I'm guessing this is a ConPTY thing? Can anyone let me know if this works in Take Command V25?
 
Jun 2, 2008
38
0
Denmark
Don't know whether this helps but...

The built-in verion of OpenSSH is:
Code:
C:\Windows\System32\OpenSSH> ssh -V
OpenSSH_for_Windows_7.7p1, LibreSSL 2.6.5
The latest version of OpenSSH is:
Code:
C:\> ssh -V
OpenSSH_for_Windows_8.0p1, LibreSSL 2.6.5
It is perfectly possible to install and run this version instead of the built-in one provided you pay attention to your PATH setup:
Code:
C:\> path /n | grep -i ssh
C:\Program Files\OpenSSH-Win64
C:\WINDOWS\System32\OpenSSH\

(@Rex: Thanks for that very useful /n option for the path command..
 
Sep 1, 2008
23
0
No, it doesn't work in Take Command v25.

But it doesn't work with CMD EXE either. Microsoft seems to have broken something.

Huh. I never ran the '-v' with cmd exe and ssh because it asked for (and accepted) password auth.

But yes - cmd exe does show the same tty fail message.

Odd. (And yeah, this was the built-in 7.7p1). OK. No real request here I guess. :)