How to? How to remove the record of the old version of the Take Command?

Looking through the programs list in the Windows Control Panel I see 2 records of Take Command:
Take Command old version record not removed.err_rep.screenshot.gif


while only Take Command v 28.1.14.0 is in fact installed on the system. How to accurately remove the version's 26 records, remained by the Take Command upgrade, from the Windows registry? I had never installed 2 versions of the Take command on my computer, this is by some antique error in the Take Command's installers, they sometimes do not remove the old version information when upgrading.

I work under the Windows 10 Professional 64 bits, version 21H1, build 19043.1237 .
 
May 20, 2008
11,538
103
Syracuse, NY, USA
I haven't done this and I make no guarantees.

You could verify that this key deals with TakeCommand v26 and delete it.

Code:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{FC985FD2-F87E-44F6-88DF-7F9D18CDAA1C}
  (SZ) Comments
    *This installer database contains the logic and data required to install Take Command 26.
  (SZ) InstallSource
    *C:\Users\vefatica\AppData\Roaming\JP Software\Take Command 26 26.2.43.0\install\8CDAA1C\
  (SZ) DisplayName
    *Take Command 26
 
Have you tried simply uninstalling v26? Often, if it can't find the uninstaller, appwiz.cpl will offer to remove the invalid entry.
I had tried to "uninstall" the older version in such situation several years ago. This had yielded to inoperability of the Windows Installer. I cannot remember the messages, but most of the programs could not be installed/updated after this until the full reinstallation of the Windows.
 
vefatica, yes, this helped. But a question remains: why had this not be maid by your TC version upgrade procedure?

When upgrading a version I must to uninstall the old and then install the new version. If I try to install a new version over the old, no warning is generated, but the old version's entry is sometimes not removed from the Control Panel's Installed programs list. Can you please add some check-up into the install program to verify that the new version does not overwrite the old, and to warn the user?
 

rconn

Administrator
Staff member
May 14, 2008
12,404
152
Installing a new major version of Take Command will NOT remove old major versions (and never has). This is by design, as many users want to keep older versions for compatibility testing (or because they're using scripts written expressly for a single version).
 
Perhaps, it makes sense to make that the installation program would warn about this possible undesirable effect when it is asked to setup the new version in the folder in which there is the old one, with the opportunities for the user: to delete preliminarily the old version, to continue the installation "above" or to select the new folder for the new version? In the latter case the installation program would copy the tc & tcc customization files, tcstart.bat, tcexit.bat, tc.ini, etc., into this new folder?
 
  • Like
Reactions: Alpengreis

rconn

Administrator
Staff member
May 14, 2008
12,404
152
That's not the way the Windows Installer (Microsoft's app, not mine) works -- a new major version (& new GUID) can't invoke a random older uninstaller. The installers & uninstallers are tied to a single version/GUID.

The installer won't try to put a new major version in the same installation directory as an older version unless you manually change the installation directory in the installer dialog. In that case, the installer assumes that the user knows what they're doing and doesn't try to override their selection.
 
Similar threads
Thread starter Title Forum Replies Date
MikeBaas Edit/remove kbd shortcuts of Macro Recorder? Support 7
gworley rd (Remove Directory) gives interesting error: Support 2
x13 TPIPE /REPLACE - Remove line (including EOL) Support 3
C NE1 have BTM to remove %appdata\JP Software\ etc... Support 0
H DOS CMD Sort+Add Sequence+Remove Sequence number Support 12
vefatica Remove double-quotes with TPIPE Support 4
H Remove all previous activations Support 4
D Fixed Cut and paste in TC's file/folder view does not remove file Support 17
vefatica Must update remove my taskbar-pinned shortcut? Support 20
A How to? Remove last argument on command line Support 4
samintz How to? remove adjacent common chars Support 2
C Drag-and-drop from file-view may "remove" Support 1
S Setup - remove older versions? Support 4
C Can't remove leading quote from a string Support 2
A Cannot permanently remove Tabs toolbar using View menu - bug? Support 8
thedave Remove a section from an INI file Support 6
vefatica For the record Support 6
J WAD First Record, Last Record, Next Record, Previous Record Support 11
C old .vs. new system Support 0
gentzel "Check for Updates" appears to be checking for old version Support 2
Charles Dye Old download links on JPSoft.com home page Support 0
Dmitry L. Kobyakov From old version: had the setup's error been corrected? Support 6
C Any reason to keep old versions? Support 8
vefatica WAD IFTP - old problem still there Support 2
SB-Robert Old 4NT Won't Register - Options? Support 8
vefatica All my old TCMDs start slowly Support 9
L How to copy an old xp drive to a large ntfs drive Support 6
M "Reawakening" of an old issue with _complete_ documentation... Support 39
M “Reawakeng" of an old issue with the "copy" command that I'm not sure I've ever reported in the past Support 6
Kachupp old version 4nt v8 Support 0
Kachupp old version 4nt v8 Support 0
L A little startup help from an old CLI guy please. Support 14
A Help | Check for updates "old news" Support 13
M Ansi.sys and old Dos programs Support 7
BobK New to TCC, Why does it use my old 4NT files? Support 3

Similar threads