WAD IFTP - old problem still there

May 20, 2008
11,547
107
Syracuse, NY, USA
Two problems here: With PassiveFTP=No, many files truncated, many aborted.
Code:
v:\> iftp "ftp://lucky/4plugins/test"

v:\> dir ftp:

Directory of  ftp://lucky/4plugins/test/*

2014-06-05  01:53  <DIR>  .
2014-06-05  01:53  <DIR>  ..
2014-06-05  01:52  256  8.bin
2014-06-05  01:52  512  9.bin
2014-06-05  01:52  1,024  10.bin
2014-06-05  01:52  2,048  11.bin
2014-06-05  01:52  4,096  12.bin
2014-06-05  01:52  8,192  13.bin
2014-06-05  01:52  16,384  14.bin
2014-06-05  01:52  32,768  15.bin
2014-06-05  01:52  65,536  16.bin
2014-06-05  01:52  131,072  17.bin
2014-06-05  01:52  262,144  18.bin
2014-06-05  01:52  524,288  19.bin
2014-06-05  01:52  1,048,576  20.bin
2014-06-05  01:52  2,097,152  21.bin
2014-06-05  01:52  4,194,304  22.bin
2014-06-05  01:52  8,388,608  23.bin
2014-06-05  01:52  16,777,216  24.bin
2014-06-05  01:52  33,554,432  25.bin
2014-06-05  01:52  67,108,864  26.bin
2014-06-05  01:52  134,217,728  27.bin
2014-06-05  01:52  268,435,456  28.bin
2014-06-05  01:53  536,870,912  29.bin
2014-06-05  01:53  1,073,741,824  30.bin
  2,147,483,392 bytes in 23 files and 2 dirs

v:\bin> do i=8 to 24 ( copy ftp:%i.bin )
ftp://lucky/4plugins/test/8.bin => V:\bin\8.bin
  1 file copied
ftp://lucky/4plugins/test/9.bin => V:\bin\9.bin
  1 file copied
ftp://lucky/4plugins/test/10.bin => V:\bin\10.bin
  1 file copied
ftp://lucky/4plugins/test/11.bin => V:\bin\11.bin
  1 file copied
ftp://lucky/4plugins/test/12.bin => V:\bin\12.bin
  1 file copied
ftp://lucky/4plugins/test/13.bin => V:\bin\13.bin
  1 file copied
ftp://lucky/4plugins/test/14.bin => V:\bin\14.bin
  1 file copied
ftp://lucky/4plugins/test/15.bin => V:\bin\15.bin
  1 file copied
ftp://lucky/4plugins/test/16.bin => V:\bin\16.bin
  1 file copied
ftp://lucky/4plugins/test/17.bin => V:\bin\17.bin
  1 file copied
ftp://lucky/4plugins/test/18.bin => V:\bin\18.bin
TCC: FTP protocol error: 426 Data connection unexpectedly closed,
lugins/test/18.bin"
  0 files copied  1 failed

MORE OF THE SAME

v:\bin> dir

Volume in drive V is DATA  Serial number is c007:d3e4
Directory of  V:\bin\*

2014-10-28  21:35  <DIR>  .
2014-10-28  21:35  <DIR>  ..
2014-10-28  21:34  256  8.bin
2014-10-28  21:34  512  9.bin
2014-10-28  21:34  1,024  10.bin
2014-10-28  21:34  1,985  11.bin
2014-10-28  21:34  1,360  12.bin
2014-10-28  21:34  1,360  13.bin
2014-10-28  21:34  1,360  14.bin
2014-10-28  21:34  1,360  15.bin
2014-10-28  21:34  1,360  16.bin
2014-10-28  21:34  1,360  17.bin
  11,937 bytes in 10 files and 2 dirs  40,960 bytes a
 
May 20, 2008
11,547
107
Syracuse, NY, USA
Not reproducible here.

And as I have told you (several times) previously, there's absolutely no reason for you to be using PassiveFTP=no (unless you really, really want to generate continual errors on your system).
Then why don't you remove the option?

COPY ftp://... can get them (with PassiveFTP=No)

An ancient CuteFTP (not even capable of PASV) can get them all in one session.

It seems like a bug to me.
 
Similar threads
Thread starter Title Forum Replies Date
cgunhouse Problems With IFTP Support 3
vefatica IFTP and SFTP Support 7
vefatica WAD IFTP timeout? Support 3
B when doing SFTP via IFTP to my secure site my users always get the finger print key prompt Support 1
S iftp copying pgp files from ftp is not working Support 11
cgunhouse IFTP "/S" Option Support 6
cgunhouse IFTP Path Issue in V17 - Fixed Support 7
vefatica IFTP and active FTP Support 13
vefatica Both IFTP problems remain in build 50 Support 35
vefatica More on IFTP Support 7
vefatica IFTP problems (broken pipe?) Support 24
cgunhouse Foldermonitor and iftp Support 1
Charles Dye Minor nit: DIR /F, IFTP, colorization Support 4
Charles Dye IFTP, current directory, open new connection Support 0
D iftp problem Support 2
D iftp failure after upgrading to build 65 Support 9
S FTP site; IFTP access Support 10
K iftp script copy deletes target files Support 17
J Problems with FTP after IFTP timeout Support 2
P iftp with ftp proxy Support 0
J IFTP issue Support 1
nikbackm IFTP questions Support 3
D "534 Fallback to [C]" after iftp Support 7
Dmitry L. Kobyakov How to? How to remove the record of the old version of the Take Command? Support 9
C old .vs. new system Support 0
gentzel "Check for Updates" appears to be checking for old version Support 2
Charles Dye Old download links on JPSoft.com home page Support 0
Dmitry L. Kobyakov From old version: had the setup's error been corrected? Support 6
C Any reason to keep old versions? Support 8
SB-Robert Old 4NT Won't Register - Options? Support 8
vefatica All my old TCMDs start slowly Support 9
L How to copy an old xp drive to a large ntfs drive Support 6
M "Reawakening" of an old issue with _complete_ documentation... Support 39
M “Reawakeng" of an old issue with the "copy" command that I'm not sure I've ever reported in the past Support 6
Kachupp old version 4nt v8 Support 0
Kachupp old version 4nt v8 Support 0
L A little startup help from an old CLI guy please. Support 14
A Help | Check for updates "old news" Support 13
M Ansi.sys and old Dos programs Support 7
BobK New to TCC, Why does it use my old 4NT files? Support 3
old coot Problem with INS key flag in the debugger status bar Support 3
Dick Johnson Weird Color Problem Support 10
fishman@panix.com Problem with 27.15 Support 2
M Problem with VSDevCmd.bat in VS 16.7.3 Support 0
R Problem with @INT[ value] in V26 Support 9
M Selecting test "off by one" problem in Take command Support 4
Alpengreis UTF-8 problem in TCC related to Python Support 7
K_Meinhard Small problem in german IDE 26 Support 3
B Problem with color in nested shells Support 1
Joe Caverly Problem creating and switching to a DESKTOP Support 9

Similar threads