1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

iftp failure after upgrading to build 65

Discussion in 'Support' started by drrob1, May 7, 2011.

  1. drrob1

    drrob1 Guest

    Suddenly after upgrading to build 65 of tcmd 12.10, my iftp stopped working. I can connect without trouble using filezilla, so I know it's tcmd that's not working. The command I use is:

    iftp ftp://username:passwd@ftp-adr

    And I'm getting this error from an attached tcc window:

    TCC: [141] (no description available) "ftp.drrob1.com"

    Again, I can connect easily using filezilla.

    I know the ftp code is not written by Rex, but it was working before.
     
  2. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    ---- Original Message ----
    From: drrob1
    | Suddenly after upgrading to build 65 of tcmd 12.10, my iftp stopped
    | working. I can connect without trouble using filezilla, so I know
    | it's tcmd that's not working. The command I use is:
    |
    | iftp ftp://usernameasswd@ftp-adr
    |
    | And I'm getting this error from an attached tcc window:
    |
    | TCC: [141] (no description available) "ftp.drrob1.com"
    |
    | Again, I can connect easily using filezilla.
    |
    | I know the ftp code is not written by Rex, but it was working before.

    I used FTP.CFG to provide the username and password for the IFTP command, and was successful using FTP to upload an update to a website I maintain. Same build of TCC (without using TCMD), WinXP SP3 home.
    --
    Steve
     
  3. drrob1

    drrob1 Guest

    that works for me too, but that's not the bug I'm reporting. The format
    I use is supposed to work. If it is reproducibly not working, this is a
    bug.

    And the FTP.CFG file leaves me in the root of that server. The command
    I use is

    iftp ftp://username:passwd@ftp-adr/myworkingdir


    Does this command work for you?
     
  4. Glennbo51

    Glennbo51 Guest

    The above command works fine for me.
    TCMD12x64 build 65 on Win 7 SP1
     
  5. drrob106

    Joined:
    Jan 24, 2009
    Messages:
    36
    Likes Received:
    0
    I forgot to say this is on windows xp sp3

    Sent from my Droid Incredible Verizon Wireless phone

    ----- Reply message -----
    From: "drrob1" <>
    Date: Sat, May 7, 2011 4:49 pm
    Subject: [Support-t-2832] iftp failure after upgrading to build 65
    To: <rob@drrob1.com>

    ---Quote---

    ---End Quote---
    that works for me too, but that's not the bug I'm reporting. The format
    I use is supposed to work. If it is reproducibly not working, this is a
    bug.

    And the FTP.CFG file leaves me in the root of that server. The command
    I use is

    iftp ftp://username:passwd@ftp-adr/myworkingdir


    Does this command work for you?
     
  6. Glennbo51

    Glennbo51 Guest

    The above command also works in TCMD12 Build 65 on Win XP SP3 as well.

    No problems observed

    </rob@drrob1.com>
     
  7. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    ---- Original Message ----
    From: drrob1
    | And the FTP.CFG file leaves me in the root of that server. The command
    | I use is
    |
    | iftp ftp://usernameasswd@ftp-adr/myworkingdir
    |
    |
    | Does this command work for you?

    Yes, it does.

    However, normally I prefer to just use FTP.CFG.
    --
    Steve
     
  8. Jim Cook

    Joined:
    May 20, 2008
    Messages:
    604
    Likes Received:
    0

    TCC 12.10.65 x64 Windows 7 [Version 6.1.7600]
    TCC Build 65 Windows 7 Build 7600

    I thought I could reproduce the failure because I saw that message too, but then realized I was using the password for another computer. Once I got the password right, everything worked as expected.
     
  9. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,959
    Likes Received:
    30
    On Sun, 08 May 2011 00:57:02 -0400, Jim Cook <> wrote:

    |---Quote (Originally by drrob1)---
    |iftp ftp://username:passwd@ftp-adr
    |
    |And I'm getting this error from an attached tcc window:
    |
    |TCC: [141] (no description available) "ftp.drrob1.com"
    |---End Quote---
    |
    |
    |TCC 12.10.65 x64 Windows 7 [Version 6.1.7600]
    |TCC Build 65 Windows 7 Build 7600
    |
    |I thought I could reproduce the failure because I saw that message too, but then realized I was using the password for another computer. Once I got the password right, everything worked as expected.

    I also get that message when I use a bad password. Drrob1, does your password
    contain any special characters? If so, "quote" the whole URL. Also, use IFTP's
    "/v" option to see what's happening.

    The error message seems a little odd. The server returns "530 Not logged in."
     
  10. drrob1

    drrob1 Guest

    On 05/08/2011 12:57 AM, Jim Cook wrote:

    Thanks, that was it. I had the wrong password. I did not catch that
    myself because I hide the password.

    NEVERMIND.

    --rob
     

Share This Page