IFTP "/S" Option

Dec 2, 2008
226
2
Canada
I have not been able to determine how the "/S" switch works for IFTP.

I successfully open a connection using IFTP and then start send commands using the "/S". The Help for the command says the following:

/S Allows you to send commands directly to an FTP server. The connection must have already been opened by a previous IFTP command.

So I tried:

iftp /S ls

This yielded:

TCC: [11001] Host not found "ls"
And I tried:

iftp /S verbose on

This yielded:

TCC: [11004] Valid name, no data record (check DNS setup) "verbose on"
After using both these commands the connection is disconnected as well.
So how does the "/S" option work?
 

rconn

Administrator
Staff member
May 14, 2008
12,345
150
The best rule of thumb is that if you don't know why you would /S, then you definitely should not be using /S!

/S is intended for sending configuration options to the FTP server, not for executing commands on the remote system. Exactly what options are valid depends on what FTP server software you're running.
 
Dec 2, 2008
226
2
Canada
If I connect using IFTP

Then I do:

cd ftp:\Test

This will change the directory to Test on the ftp connection. This works
but isn't this the same as:

IFTP /S cd /Test

or

IFTP /S cd Test


This doesn't work.​
 

rconn

Administrator
Staff member
May 14, 2008
12,345
150
No, it is definitely not the same. In the first example, you're changing the default directory for your session on the FTP server. In the second example, you're telling your FTP server to set its internal configuration option "cd /Test".

I don't know of any FTP server that will take a "cd" as an internal configuration option.

If you tell me exactly what you want to do with /S (i.e., that you can't do with something like "cd ftp:\Test"), and exactly what FTP software is running on your server, I can provide a better answer.
 
Dec 2, 2008
226
2
Canada
ftp> help
Commands may be abbreviated. Commands are:

! delete literal prompt send
? debug ls put status
append dir mdelete pwd trace
ascii disconnect mdir quit type
bell get mget quote user
binary glob mkdir recv verbose
bye hash mls remotehelp
cd help mput rename
close lcd open rmdir


When it came to commands this is what I thought was available. I would probably use "trace", "verbose", "debug", etc. Anything to help with connection issues.
 
Similar threads
Thread starter Title Forum Replies Date
cgunhouse Problems With IFTP Support 3
vefatica IFTP and SFTP Support 7
vefatica WAD IFTP timeout? Support 3
B when doing SFTP via IFTP to my secure site my users always get the finger print key prompt Support 1
S iftp copying pgp files from ftp is not working Support 11
vefatica WAD IFTP - old problem still there Support 2
cgunhouse IFTP Path Issue in V17 - Fixed Support 7
vefatica IFTP and active FTP Support 13
vefatica Both IFTP problems remain in build 50 Support 35
vefatica More on IFTP Support 7
vefatica IFTP problems (broken pipe?) Support 24
cgunhouse Foldermonitor and iftp Support 1
Charles Dye Minor nit: DIR /F, IFTP, colorization Support 4
Charles Dye IFTP, current directory, open new connection Support 0
D iftp problem Support 2
D iftp failure after upgrading to build 65 Support 9
S FTP site; IFTP access Support 10
K iftp script copy deletes target files Support 17
J Problems with FTP after IFTP timeout Support 2
P iftp with ftp proxy Support 0
J IFTP issue Support 1
nikbackm IFTP questions Support 3
D "534 Fallback to [C]" after iftp Support 7
D Bug TCMD /X option Support 6
Jay Sage WAD Possible Bug With OPTION Command With @FILE Support 5
Jay Sage WAD Failure of Alias Command with /Z Option Support 14
D Purpose of DIRHISTORY /N option Support 2
Peter Murschall OPTION //directive=value is a ENDLOCAL Support 3
Charles Dye Does HASH's /E option do anything? Support 1
Charles Dye ASSOCIATE loses /P option Support 4
A Documentation [Help file] OPTION "//" synopsis formatting issue Support 0
thorntonpg option /u not working The directory name is invalid Support 5
rps TCMD Tabs priority option setting Support 0
A How to? TCMD Configuration Dialog: 'Smooth Scrolling' Option missing? Support 1
A Fixed (CMD compat) START /D fails to recognize the switch option. Support 3
R Fixed 7ZIP Compression Method Option Doesn't Work Support 1
D everything /o does not open the option dialog Support 4
fishman@panix.com How do I make the selections in the option menu sticky? Support 23
vefatica OPTION /U Support 2
cgunhouse Foldermonitor with "/E" Option Issue Support 6
cgunhouse Foldermonitor with /W option Support 10
Alpengreis TCC-Option for EnableDelayedExpansion (!var!) problem Support 15
D The BatchEcho option Support 8
D /extract: option for the installer Support 4
fishman@panix.com Why are the OPTION settings not sticky??? Support 11
vefatica OPTION /U Support 1
vefatica TPIPE's /perl option? Support 1
I TC "Registering" but NOT Registering, Now Hung on TCMD Option Screen Support 2
Alpengreis [TC 17.x] Install with "option /u" failed Support 5
cgunhouse Jabber Command Line Option Being Transmitted -- Fixed with Build 42 Support 2

Similar threads