1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IFTP and active FTP

Discussion in 'Support' started by vefatica, Jun 23, 2014.

  1. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    This problem remains, but has changed. With build 54 ...

    With 'iftp "ftp://lucky/4plugins/test"', 'do i=8 to 20 ( copy ftp:%i.bin )' still fails for files big enough (426 Data connection unexpectedly closed), but now, for smaller files bigger than one packet, 1360 bytes are saved (as opposed to 1460 previously).
     
    #1 vefatica, Jun 23, 2014
    Last edited: Jun 23, 2014
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    Absolutely nothing changed in the FTP code in build 54.

    Use passive FTP.
     
  3. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    I'm just reporting my observations.
    Haven't we been here before? If it's a feature of TCC, it should work. It works everywhere else, including older TCCs, and even in TCC v16 with the v15 IPWorks DLLs.
     
  4. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,015
    Likes Received:
    0
    Code:
    [C:\test]ver /r & iftp "ftp://lucky.syr.edu/4plugins/test" & do i=8 to 20 ( copy /q ftp:%i.bin ) & dir & iftp /c
    
    TCC  16.03.53 x64   Windows 7 [Version 6.1.7601]
    TCC Build 53   Windows 7 Build 7601  Service Pack 1
    Registered to Charles S. Galloway - 5 System License
    TCC: FTP protocol error: 426 Data connection unexpectedly closed, file transfer /4plugins/test/18.bin aborted by client. "/4plugins/test/18.bin"
    TCC: FTP protocol error: 426 Data connection unexpectedly closed, file transfer /4plugins/test/19.bin aborted by client. "/4plugins/test/19.bin"
    TCC: FTP protocol error: 426 Data connection unexpectedly closed, file transfer /4plugins/test/20.bin aborted by client. "/4plugins/test/20.bin"
    
    Volume in drive C is Win7_Galloway   Serial number is aea6:a855
    Directory of  C:\test\*
    
    6/23/2014  21:26         <DIR>    .
    6/23/2014  21:26         <DIR>    ..
    6/04/2014  21:52             256  8.bin
    6/04/2014  21:52             512  9.bin
    6/04/2014  21:52           1,024  10.bin
    6/04/2014  21:52           1,460  11.bin
    6/04/2014  21:52           1,460  12.bin
    6/04/2014  21:52           1,460  13.bin
    6/04/2014  21:52           1,460  14.bin
    6/04/2014  21:52           1,460  15.bin
    6/04/2014  21:52           1,460  16.bin
    6/04/2014  21:52           1,460  17.bin
                12,012 bytes in 10 files and 2 dirs    40,960 bytes allocated
       351,830,556,672 bytes free
    
    [C:\test]
    Passive FTP is OFF. If PassiveFTP is ON - the results are as expected....
     
  5. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,015
    Likes Received:
    0
    Code:
    [C:\test]ver /r & iftp "ftp://lucky.syr.edu/4plugins/test" & do i=8 to 20 ( copy /q ftp:%i.bin ) & dir & iftp /c
    
    TCC  16.03.54 x64   Windows 7 [Version 6.1.7601]
    TCC Build 54   Windows 7 Build 7601  Service Pack 1
    Registered to Charles S. Galloway - 5 System License
    TCC: FTP protocol error: 426 Data connection unexpectedly closed, file transfer /4plugins/test/18.bin aborted by client. "/4plugins/test/18.bin"
    TCC: FTP protocol error: 426 Data connection unexpectedly closed, file transfer /4plugins/test/20.bin aborted by client. "/4plugins/test/20.bin"
    
    Volume in drive C is Win7_Galloway   Serial number is aea6:a855
    Directory of  C:\test\*
    
    6/23/2014  21:36         <DIR>    .
    6/23/2014  21:36         <DIR>    ..
    6/04/2014  21:52             256  8.bin
    6/04/2014  21:52             512  9.bin
    6/04/2014  21:52           1,024  10.bin
    6/04/2014  21:52           1,460  11.bin
    6/04/2014  21:52           1,460  12.bin
    6/04/2014  21:52           1,460  13.bin
    6/04/2014  21:52           1,460  14.bin
    6/04/2014  21:52           1,460  15.bin
    6/04/2014  21:52           1,460  16.bin
    6/04/2014  21:52           1,460  17.bin
    6/04/2014  21:52           1,985  19.bin
                13,997 bytes in 11 files and 2 dirs    45,056 bytes allocated
       350,820,823,040 bytes free
    
    [C:\test]
    b54 doesn't work if PassiveFTP is OFF....
     
  6. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    No, you're not -- you're neglecting to mention that you replaced ipworksssl9.dll (which does all FTP in TCC) with an old version.
     
  7. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    No, I'm using the new one downloaded as suggested in your announcement. If I were using the one from v15, it would work!
     
  8. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    Your original "behavior has changed" report in this thread was before I posted the ipworksssl9.dll fix.
     
  9. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    No, it was 3 hours, 20 minutes later.
    upload_2014-6-24_10-43-55.png
     
  10. nickles

    Joined:
    Jun 24, 2008
    Messages:
    220
    Likes Received:
    0
    Same here. Having used

    mv "ftp://%admin%:%admin_pass%@%server%/%archive%" .

    for a long time, it stopped working (don't remember the version, maybe 49). Then it was fixed, and has reappeared with 54 (or before).
    Whichever version it was, right now I have to resort to a plethora of "real" FTP commands to get the job done...

    Would be nice to see that fixed.
     
  11. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    Do you have passive FTP turned off? (And if so, why?)
     
  12. nickles

    Joined:
    Jun 24, 2008
    Messages:
    220
    Likes Received:
    0
    Corrupt with both, PassiveFTP = Yes, and PassiveFTP = No in tcmd.ini. Using 64 version; all ipwork* DLLs (all version 9.0.0.5259) are 64 bit.
     
  13. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,804
    Likes Received:
    82
    That is unrelated to the topic of this thread. Please post a bug report in a new thread (preferably with a way to reliably reproduce the problem).
     
  14. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,883
    Likes Received:
    29
    Rex, FWIW, in spite of your router's firewall, you should be able to test this by turning on the Windows FTP server and IIS management console features. With very little effort, and with no messing with the firewall, you should be able to connect on the localhost interface. I did so and again observed the problem with active FTP and IFTP. In fact, the firewall wasn't messed with automatically at all. So that I could test from the outside, I had to manually enable all the FTP-associated built-in rules. And even that wasn't enough. I noticed that the outbound rule specified only port 20. Only when I added my own rule for local port 21 outbound could I connect from work.
    upload_2014-6-26_17-27-6.png
     

Share This Page