TakeCommand has stopped working

May 20, 2008
11,378
98
Syracuse, NY, USA
I havent run TakeCmd in a couple builds and it was OK the last time I tried it. With the latest, 13.04.63, it crashes every time I close it (with the "X" or File\Close). Beta14 (with identical INI, start, and exit files) doesn't do this.

TCMD 13.04.63
Module=G:\TC13\tcmd.exe
Address=0041072C
Exception=C0000005
EAX=00000000 EBX=754A8601 ECX=03049E68 EDX=000E0180
ESI=03054800 EDI=0318CCA8 EBP=768D64F7 ESP=01B5BD28
CS=0000001B DS=00000023 ES=00000023 SS=00000023
Flags=00010202

Stack:
1 : tcmd.exe 0001:0000f72c
Problem signature:
Problem Event Name: APPCRASH
Application Name: tcmd.exe
Application Version: 13.0.4.63
Application Timestamp: 4fa1ddb3
Fault Module Name: tcmd.exe
Fault Module Version: 13.0.4.63
Fault Module Timestamp: 4fa1ddb3
Exception Code: c0000005
Exception Offset: 0001072c
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 6e20
Additional Information 2: 6e202ab67437ef41a4dabce957adb59b
Additional Information 3: 8ea4
Additional Information 4: 8ea4023cf10fd52851ef8cc7d9e3526e
 
May 20, 2008
11,378
98
Syracuse, NY, USA
Not reproducible here.

Your register info is gibberish; I suspect you've destroyed the stack. Do you have a TCMD.GPF file?
I posted its contents right after my observation. Here it is again (or probably another similar one).
Code:
TCMD  13.04.63
Module=G:\TC13\tcmd.exe
Address=0041072C
Exception=C0000005
EAX=00000000  EBX=754A8601  ECX=040D9E68  EDX=00100180
ESI=040E4800  EDI=02AFCCA8  EBP=768D64F7  ESP=01B5C2B8
CS=0000001B  DS=00000023  ES=00000023  SS=00000023
Flags=00010202
 
Stack:
1 : tcmd.exe 0001:0000f72c
 
May 20, 2008
11,378
98
Syracuse, NY, USA
The removal of this line (below) from the [TakeCommand] section of TCMD.INI gets rid of the shutdown crashes.

Code:
StartDirectory=v:\

"v:" is a subst. If I leave the line but change it to, say, "c:" it still crashes.

If, after removing the line, I use OPTION to reinstate it, it starts crashing on shutdown again.
 
Similar threads
Thread starter Title Forum Replies Date
C "TakeCommand has stopped working" Support 3
samintz Starting Terminal from TakeCommand Support 3
H Takecommand.pdf failed not a pdf file Support 6
AndrewJ TakeCommand v23 + ANSI color sequences leads to black on black text Support 6
vefatica Permanently registering TakeCommand v8.02.106? Support 17
K Unable to register TakeCommand Support 4
P Access denied TakeCommand.19.0.key Support 2
nickles Move takecommand.18.0.key location to installation directory Support 4
C TakeCommand 18 Installation Failure Support 13
Phileosophos TakeCommand exits after launching TortoiseHg Workbench Support 4
mikea TakeCommand "evangelism" -- how? Support 1
Stefano Piccardi can start TakeCommand 15.01 on Windows XP Support 6
knudvaneeden cls in TakeCommand screen does not clear full screen Support 26
Vasilich Does TakeCommand support projects? Support 2
Phileosophos Fixed TakeCommand exits upon "set [" command Support 14
B Lockups with TakeCommand v12 Support 17
williamleara Can't Close TakeCommand After Adding 2nd Toolbar Tab Support 3
C TakeCommand 11 won't start Support 1
mscheuner TakeCommand no longer showing its icon in Win7 Taskbar Support 12
A TakeCommand screen width Support 1
mscheuner TakeCommand doesn't "see" my LiveDrive Support 1
J History file load hangs if file has complete garbage in it... Support 1
Peter Murschall TCC V26.01.3x Debugging has problems with Alias /R Support 1
Peter Murschall CMDebug 26.01.37 has problems with Alias Support 21
D TCC has much more elegant ways for usebackq. What ways? Support 12
D Pasting Unicode data has different behavior on TCC and CMD Support 2
D [cosmetic] Shortcut for v24 still has v23 in its comment Support 1
D Envar _tcexit has value, even with /IX startup parameter Support 0
Charles Dye Functions which no-one has ever tried to use.... Support 5
C "Take Command has stopped working" Support 1
R Fixed set /r has stopped working in build 35 Support 4
D Help index has GUNZIP Support 0
samintz WAD @format has issues in v18.00.14 Support 10
D Fixed @FORMATNC has changed. Support 6
D Fixed Dir /Nm:n has changed Support 1
V Fixed CD ~ has trash characters in it Support 5
vefatica Has NthArgument changed? Support 7
S Documentation KEYSTACK - has this feature been dropped? Support 5
forbin Fixed OSD /C has no effect Support 14
H Documentation Help for head has ... Support 0
D Documentation @ISPUNCT has rogue links Support 2
J Extended directory search has stopped working Support 9
old coot TC DIR command has trouble on my SSD Support 2
vefatica WAD TPIPE.EXE has stopped working Support 13
ehab aboudaya WAD starting tcmd.exe with dir that has Boost C++ Libraries zip file delays Support 2
Alan Strader Take Command IDE/Debugger has stopped working Support 5
M A new problem that has actually got me a little panicky... Support 10
cgunhouse NTVDM CPU has encountered an illegal instruction. Support 2
S PDIR has trouble processing filenames with embedded percent sign Support 3
nikbackm Find out when a process has stopped Support 5

Similar threads