Version 20.11 installed on Windows 10 problems

Apr 21, 2011
4
0
#1
Version 20.11 installed on Windows 10 by the local IT organization doesn't work as it does not appear to accept and maintain customization, i.e. TCCStart.bat appears to disappear, options entered on the Options, Take Command tab do the same, etc. Any suggestions gladly accepted. Note all of the items including TCstart.bat are from what was a WORKING configuration on MS last OS Windows 7.

Cheers
 
#4
According to the help, TCC will look for an INI file first, in the installation directory. If it was installed by IT, that's probably in "c:\program files" ... a place you probably can't write (so changes aren't saved). You can copy that INI file to %LOCALAPPDATA (here that's C:\Users\vefatica\AppData\Local), and start TCC with the option "@C:\Users\vefatica\AppData\Local\tcmd.ini" (at least until you can get IT to remove the other INI file).

You can find out what INI file is in use with "ECHO %_ININAME".

Rex, why not start the INIfile search in %LOCALAPPDATA?
 

rconn

Administrator
Staff member
May 14, 2008
10,321
93
#5
TCMD / TCC look first in the installation directory, then in PROGRAMDATA, then in LOCALAPPDATA. This is because (1) the installation directory is for backwards compatibility, (2) PROGRAMDATA is where Microsoft wants everyone to put their data now, and (3) LOCALAPPDATA is where Microsoft *used* to want everyone to put their data.

The other reason to default to the (possibly non-writeable) installation directory is that a lot of the corporate (multisystem) installations want to distribute a TCC environment that is locked down & not changeable by the end users.
 
#6
This, from "Initialization Files", should be updated.
Locating the TCMD.INI File



1) When starting TCC (a "primary shell"):


If there is an @d:\path\inifile option on the startup command line, TCC will use the path and file name specified there.


Otherwise, the default .INI file name in the table below is used, and the search starts in the directory where the TCC program file is stored. If the .INI file is not found, TCC will look in the %LOCALAPPDATA% directory.
 
Apr 21, 2011
4
0
#7
Thanks all, particularly Vince. I started changing SECURITY assignments for the "C:\Program Files\JPSoft\TCMD20\" directory. That has helped somewhat. Now all I have to find out is why certain configuration info that works perfectly for WIN 7 does NOT appear to work for WIN 10.. Now if anyone has an idea why the directory "C:\Users\rguenther\Desktop\IRACxls\" gives up at Desktop and complains that IRACxls does not exist I'll have a cup of coffee and go home.
 
#9
I have a similar situation: I install TCMD with an administrator account and run it from a non-administrator account.
Rather than changing the security of the "C:\Program Files\JPSoft\TCMD22\" directory, I remove (as administrator) TCMD.INI from that directory.
Then I run TCMD (as non-administrator) and TCMD.INI goes to the "C:\ProgramData\JP Software\Take Command 22\" directory.