Strange error messages from TCC in FTP copy

Sep 10, 2009
40
0
I have a BTM file. I enabled an echo, so the output shows the complete execution.
I use the lates version 26.00.31 x64. I saw this error also in version 22 before... I can see this since years now I ask.

For each file I see a strange warning with a one letter text. Seams that there is a problem with the text output.

-------------------------
REM --- Start connection
iftp /R ftp://anything
FOR %name In ("F:\anypath\Docs\Handbuch*.pdf" "F:\anypath\Docs\Sem*.pdf") ( COPY /g /uf "%name" ftp://anything/anything.de/www2
/sites/default/files/bedienungsanleitung/%@lower[%@replace[ ,_,%@filename[%name]]] )

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D
 
Last edited:
May 20, 2009
293
5
57
ITALY
I have a BTM file. I enabled an echo, so the output shows the complete execution.
I use the lates version 26.00.31 x64. I saw this error also in version 22 before... I can see this since years now I ask.

For each file I see a strange warning with a one letter text. Seams that there is a problem with the text output.

-------------------------
REM --- Start connection
iftp /R ftp://anything
FOR %name In ("F:\anypath\Docs\Handbuch*.pdf" "F:\anypath\Docs\Sem*.pdf") ( COPY /g /uf "%name" ftp://anything/anything.de/www2
/sites/default/files/bedienungsanleitung/%@lower[%@replace[ ,_,%@filename[%name]]] )

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D

0 Dateien kopiert
TCC: D:\Dev\Root\Setup\UploadManuals.btm [33] D
Maybe You have to quote / escape / something else the part "%@lower[%@replace[ ,_,%@filename[%name]]]"?
Maybe there are spaces in the names?

Regards

Rodolfo Giovanninetti
 
Sep 10, 2009
40
0
No definitely not.
This are the names copied:

----
handbuch_ag-vip_sql_administrator.pdf
handbuch_ag-vip_sql_anwender.pdf
handbuch_ag-vip_sql_crm-option.pdf
handbuch_ag-vip_sql_installation.pdf
handbuch_ag-vip_sql_makroprogrammierung.pdf
handbuch_ag-vip_sql_overdial-service.pdf
handbuch_ag-vip_sql_reporting.pdf
handbuch_ag-vip_sql_terminvereinbarung.pdf
handbuch_ag-vip_sql_workflow.pdf
----

It seams that this is a warning in a FTP action.
 
Sep 10, 2009
40
0
I get this strange text on any action when using ftp://

D:\source>copy updateD.txt ftp://anything/download.anything.de
TCC: D
D:\source\updateD.txt => ftp://anything/download.anything.de/updateD.txt
TCC: D
 
May 20, 2009
293
5
57
ITALY
The copy command maybe is an alias?
Also, I do not understand the syntax of these commands.
You write "copy updateD.txt ftp://anything/download.anything.de".
But, if I check the syntax for ftp in an old version of TCC (the new pc in this moment is busy) I see something like "copy updateD.txt ftp://username:password@download.anything.de".
I understand that You cannot write real names, but the syntax is the one that You are using?
I mean "/something/servername"?
As You see, I do not understand the "/something/".

Regards

Rodolfo Giovanninetti
 
Sep 10, 2009
40
0
It doesn't make a difference. I get this warning always when using FTP with a cfg....
I have a ftp.cfg where anything is defined.
 

rconn

Administrator
Staff member
May 14, 2008
12,340
149
I'm unable to reproduce this here (either with or without an FTP.CFG).

The error message is definitely not coming from the FTP code; those errors have a different format. (And they would appear before the "0 files copied" message.)

So I suspect it's something else in your batch file. Do you have an ON ERROR / ERRORMSG / ERRORLEVEL?

Have you tried stepping through it with BDEBUGGER?
 
Similar threads
Thread starter Title Forum Replies Date
vefatica REGDIR, strange error message Support 7
A strange error in alias Support 9
J Strange error: unset /s Support 14
J ASSOC / FTYPE strange error message Support 3
R strange bug? Support 7
Jesse Heines Strange Line Wrapping Behavior Support 14
F strange results Support 9
M Another possibly strange remote registry issue Support 5
forbin Strange handling of [nonbright] magenta background (v22) Support 2
N Fixed Strange dir behavior Support 6
T WAD Strange Unexpected "features" in the Debugger Support 2
P Strange mouse behavior with list Support 2
vefatica Strange tcc.exception.log Support 7
vefatica A strange one Support 0
D Strange DO behavior with /O Support 5
Glenn Bowes Strange text at startup Support 5
Steve Pitts WAD Strange output from DEL of a non-existent directory Support 7
vefatica Big numbers, strange errors Support 1
aedthuio Strange... lpksetup Support 4
CWBillow dir /4 strange Support 2
D Strange issue with FOR loop Support 15
MikeBaas Strange prob with %@replace.. Support 4
vefatica OT: strange files in %TEMP Support 10
Dan Glynhampton Documentation v15 help: Strange links in @INT topic Support 0
R WAD Strange output from "memory" command Support 1
M Yet another strange something re something called "@TCONVERT" Support 8
Roedy How to? Strange colours Support 9
M WAD Strange "Start" misbehavior... Support 10
vefatica Very strange console font corruption Support 3
Steve Pitts Strange problem with FREE Support 10
newgeekorder Debugger IDE - strange tab and parameter behaviour Support 1
Exolon Strange Prompt. Support 6
vefatica Strange folders Support 1
T Strange CPU value Support 3
M Strange behavior... Support 2
CWBillow Strange happenings Support 2
B Strange handling of a .BAT file Support 5
vefatica Strange behavior reloading SHRALIAS sav files. Support 1
D Strange crashes in @CRC32 and @MD5 Support 9
Charles Dye Strange output, here-doc redirection, TYPE, //UnicodeOutput=Yes Support 6
S Strange CHKDSK behavior Support 6
vefatica Strange results with CP 1252 Support 12
S Strange REN problem - non-English characters Support 3
dcantor Strange status in ACTIVATE command Support 0
C Copy (sys) error Support 3
T Error: This page can’t be displayed Make sure the web address //ieframe.dll/dnserrordiagoff.htm# is correct. Support 8
kb6ojs How to? "Specified Account Already Exists" error installing TCMD v27 Support 12
samintz How to? Abort on error DO loop Support 10
mfarah Fixed The DATE command produces the wrong error message. Support 1
vefatica ON ERROR terminates DO loop. Support 0

Similar threads