Strange handling of [nonbright] magenta background (v22)

Dec 29, 2009
30
0
Atlanta, GA
#1
Running:
TCC 22.00.41 x64 Windows 7 [Version 6.1.7601]
TCC Build 41 Windows 7 Build 7601 Service Pack 1

I'm observing strange behavior in using the (non-bright) magenta background for text in Take Command, both when using SCRPUT and when using ANSI control sequences.

Example:
> SCRPUT +3 0 bright white on magenta ` foobar `

If I attempt to use this in a TCC tab in Take Command, it shows the background incorrectly as bright red.
If I then detach the tab to a plain console, the already printed "foobar" background color shows up correctly as magenta.
Subsequent executions of the command (in console) also show up correctly.
If I attach the session as a tab again, all of the lines are back to bright red.

HOWEVER...

If I start TCC as a console and run the same command as above, it behaves slightly differently!
It shows up in the console correctly as magenta.
If I attach the session as a tab in Take Command, it stays magenta!
Further executions of the same command will show correctly.
I can detach and reattach all I want and it still shows correctly.

My settings and options are identical to the ones I used in v17, and it didn't behave this way.
Unfortunately, I didn't keep myself updated, so I cannot comment on v18-21, sorry.


Best regards,
johnb in atlanta
aka forbin
 
Dec 29, 2009
30
0
Atlanta, GA
#2
UPDATE:

On a strange hunch, I shut down all instances of TCC and TCMD, renamed my TCMD.INI file to TCMD.INI.SAVE, and restarted.
Then I manually went through the dialogs and set things up from scratch.
Problem solved.

So there's an obscure bug somewhere in legacy INI settings handling... which you may or may not want to go to the trouble of working on.